summaryrefslogtreecommitdiff
path: root/multiple-topic-monitor.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-03-25 08:24:18 +0000
committerCoprDistGit <infra@openeuler.org>2025-03-25 08:24:18 +0000
commit433ed1abeb2512ba5507b2734afd5e864d919fd6 (patch)
treed6d3a08448edff88e575f47d2e4260ef4430cf3a /multiple-topic-monitor.spec
parentc9e18e6c2f50991be5eebd7a0a2b14945e6e968a (diff)
automatic import of ros-humble-multiple-topic-monitoropeneuler24.03_LTS
Diffstat (limited to 'multiple-topic-monitor.spec')
-rw-r--r--multiple-topic-monitor.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/multiple-topic-monitor.spec b/multiple-topic-monitor.spec
new file mode 100644
index 0000000..5607ca4
--- /dev/null
+++ b/multiple-topic-monitor.spec
@@ -0,0 +1,74 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global debug_package %{nil}
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
+%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
+
+%define RosPkgName multiple-topic-monitor
+%define ros_distro humble
+%define with_tests 0
+
+Name: ros-%{ros_distro}-%{RosPkgName}
+Version: 1.0.2
+Release: 1%{?dist}%{?release_suffix}
+Summary: ROS 2 package for monitoring the frequency and delay of multiple topics.
+
+License: Apache License 2.0 and BSD-3-Clause
+Source0: %{name}_%{version}.orig.tar.gz
+
+BuildRequires: ros-%{ros_distro}-ament-cmake
+BuildRequires: ros-%{ros_distro}-ros-workspace
+
+%if 0%{?with_tests}
+BuildRequires: ros-%{ros_distro}-ament-copyright
+BuildRequires: ros-%{ros_distro}-ament-flake8
+BuildRequires: ros-%{ros_distro}-ament-pep257
+BuildRequires: python3-pytest
+%endif
+
+Provides: %{name}-devel = %{version}-%{release}
+Provides: %{name}-doc = %{version}-%{release}
+Provides: %{name}-runtime = %{version}-%{release}
+
+%description
+ROS 2 package for monitoring the frequency and delay of multiple topics.
+
+%prep
+%autosetup -p1
+
+%build
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%py3_build
+
+%install
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%py3_install -- --prefix "/opt/ros/%{ros_distro}"
+
+%if 0%{?with_tests}
+%check
+# Look for a directory with a name indicating that it contains tests
+TEST_TARGET=$(ls -d * | grep -m1 "\(test\|tests\)" ||:)
+if [ -n "$TEST_TARGET" ] && %__python3 -m pytest --version; then
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%__python3 -m pytest $TEST_TARGET || echo "RPM TESTS FAILED"
+else echo "RPM TESTS SKIPPED"; fi
+%endif
+
+%files
+/opt/ros/%{ros_distro}
+
+%changelog
+* 三 12月 04 2024 Yukihiro Saito yukky.saito@gmail.com - 1.0.2-1
+- Autogenerated by ros-porting-tools