summaryrefslogtreecommitdiff
path: root/nmea-navsat-driver.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-03-27 08:36:50 +0000
committerCoprDistGit <infra@openeuler.org>2025-03-27 08:36:50 +0000
commit86c44de7e76c39cece8c6824954dd358a924559e (patch)
tree26f3aec94256c7fb28a208da15caa2751129439c /nmea-navsat-driver.spec
parentde149fe624ff4139257cd56c3e45e131099b025d (diff)
automatic import of ros-humble-nmea-navsat-driveropeneuler24.03_LTS
Diffstat (limited to 'nmea-navsat-driver.spec')
-rw-r--r--nmea-navsat-driver.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/nmea-navsat-driver.spec b/nmea-navsat-driver.spec
new file mode 100644
index 0000000..88afff7
--- /dev/null
+++ b/nmea-navsat-driver.spec
@@ -0,0 +1,81 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global debug_package %{nil}
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
+%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
+
+%define RosPkgName nmea-navsat-driver
+%define ros_distro humble
+%define with_tests 0
+
+Name: ros-%{ros_distro}-%{RosPkgName}
+Version: 2.0.1
+Release: 1%{?dist}%{?release_suffix}
+Summary: ROS nmea-navsat-driver package
+
+Url: http://ros.org/wiki/nmea_navsat_driver
+License: BSD
+Source0: %{name}_%{version}.orig.tar.gz
+
+Requires: ros-%{ros_distro}-geometry-msgs
+Requires: nmea_msgs
+Requires: ros-%{ros_distro}-rclpy
+Requires: ros-%{ros_distro}-sensor-msgs
+Requires: python3-numpy
+Requires: python3-serial
+Requires: tf_transformations
+
+
+%if 0%{?with_tests}
+BuildRequires: python3-pytest
+%endif
+
+Provides: %{name}-devel = %{version}-%{release}
+Provides: %{name}-doc = %{version}-%{release}
+Provides: %{name}-runtime = %{version}-%{release}
+
+%description
+
+ Package to parse NMEA strings and publish a very simple GPS message. Does not
+ require or use the GPSD deamon.
+
+
+%prep
+%autosetup -p1
+
+%build
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%py3_build
+
+%install
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%py3_install -- --prefix "/opt/ros/%{ros_distro}"
+
+%if 0%{?with_tests}
+%check
+# Look for a directory with a name indicating that it contains tests
+TEST_TARGET=$(ls -d * | grep -m1 "\(test\|tests\)" ||:)
+if [ -n "$TEST_TARGET" ] && %__python3 -m pytest --version; then
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%__python3 -m pytest $TEST_TARGET || echo "RPM TESTS FAILED"
+else echo "RPM TESTS SKIPPED"; fi
+%endif
+
+%files
+/opt/ros/%{ros_distro}
+
+%changelog
+* 三 12月 04 2024 Ed Venator evenator@gmail.com - 2.0.1-1
+- Autogenerated by ros-porting-tools