summaryrefslogtreecommitdiff
path: root/python-mrpt.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-03-27 12:29:14 +0000
committerCoprDistGit <infra@openeuler.org>2025-03-27 12:29:14 +0000
commit49f729e98ae1c176e3f14a925f281f07c1e47be4 (patch)
treefaa5cd99b4ba0b0882e0e3d8e111f9e415251c75 /python-mrpt.spec
parent0b0464ceedc52de80013f152e209f50bb364576e (diff)
automatic import of ros-humble-python-mrpt-rosopeneuler24.03_LTS
Diffstat (limited to 'python-mrpt.spec')
-rw-r--r--python-mrpt.spec134
1 files changed, 134 insertions, 0 deletions
diff --git a/python-mrpt.spec b/python-mrpt.spec
new file mode 100644
index 0000000..b11f2e3
--- /dev/null
+++ b/python-mrpt.spec
@@ -0,0 +1,134 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global debug_package %{nil}
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
+%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
+
+%define RosPkgName python-mrpt
+%define ros_distro humble
+%define with_tests 0
+
+Name: ros-%{ros_distro}-%{RosPkgName}
+Version: 2.14.4
+Release: 1%{?dist}%{?release_suffix}
+Summary: Python wrapper for Mobile Robot Programming Toolkit (MRPT) libraries
+
+Url: https://www.mrpt.org/
+License: BSD
+Source0: %{name}_%{version}.orig.tar.gz
+
+Requires: ros-%{ros_distro}-mrpt-libapps
+Requires: ros-%{ros_distro}-mrpt-libslam
+Requires: ros-%{ros_distro}-mrpt-libgui
+Requires: ros-%{ros_distro}-mrpt-libnav
+
+BuildRequires: ros-%{ros_distro}-mrpt-libapps
+BuildRequires: ros-%{ros_distro}-mrpt-libslam
+BuildRequires: ros-%{ros_distro}-mrpt-libgui
+BuildRequires: ros-%{ros_distro}-mrpt-libnav
+BuildRequires: ros-%{ros_distro}-ros-environment
+BuildRequires: pkgconfig
+BuildRequires: zlib-devel
+BuildRequires: libjpeg
+BuildRequires: freeglut
+BuildRequires: libglfw3-dev
+BuildRequires: libXrandr-devel
+BuildRequires: libxxf86vm
+BuildRequires: mesa-libGL-devel
+BuildRequires: assimp-devel
+BuildRequires: ffmpeg
+BuildRequires: libfreenect-devel
+BuildRequires: libopenni2-devel
+BuildRequires: libpcap-devel
+BuildRequires: libudev-devel
+BuildRequires: libusbx-devel
+BuildRequires: pybind11-devel
+BuildRequires: python3-pip
+BuildRequires: tinyxml2-devel
+BuildRequires: wx-common
+BuildRequires: wxwidgets
+BuildRequires: ros-%{ros_distro}-ament-cmake
+BuildRequires: ros-%{ros_distro}-cv-bridge
+BuildRequires: opencv
+BuildRequires: liboctomap-dev
+BuildRequires: rosbag2_storage
+BuildRequires: ros-%{ros_distro}-rclcpp
+
+%if 0%{?with_tests}
+%endif
+
+Provides: %{name}-devel = %{version}-%{release}
+Provides: %{name}-doc = %{version}-%{release}
+Provides: %{name}-runtime = %{version}-%{release}
+
+%description
+Python wrapper for Mobile Robot Programming Toolkit (MRPT) libraries
+
+%prep
+%autosetup -p1
+
+%build
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+export ROS_DISTRO=%{ros_distro}
+export ROS_PYTHON_VERSION=%{python3_version}
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+mkdir -p .obj-%{_target_platform} && cd .obj-%{_target_platform}
+%cmake3 \
+ -UINCLUDE_INSTALL_DIR \
+ -ULIB_INSTALL_DIR \
+ -USYSCONF_INSTALL_DIR \
+ -USHARE_INSTALL_PREFIX \
+ -ULIB_SUFFIX \
+ -DCMAKE_INSTALL_PREFIX="/opt/ros/%{ros_distro}" \
+ -DAMENT_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+ -DCMAKE_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+ -DCMAKE_INSTALL_LIBDIR="/opt/ros/%{ros_distro}/lib" \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+%if !0%{?with_tests}
+ -DBUILD_TESTING=OFF \
+%endif
+ ..
+
+%make_build
+
+%install
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%make_install -C .obj-%{_target_platform}
+
+%if 0%{?with_tests}
+%check
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# Look for a Makefile target with a name indicating that it runs tests
+TEST_TARGET=$(%__make -qp -C .obj-%{_target_platform} | sed "s/^\(test\|check\):.*/\\1/;t f;d;:f;q0")
+if [ -n "$TEST_TARGET" ]; then
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+CTEST_OUTPUT_ON_FAILURE=1 \
+ %make_build -C .obj-%{_target_platform} $TEST_TARGET || echo "RPM TESTS FAILED"
+else echo "RPM TESTS SKIPPED"; fi
+%endif
+
+%files
+/opt/ros/%{ros_distro}
+
+%changelog
+* 三 12月 04 2024 Jose-Luis Blanco-Claraco joseluisblancoc@gmail.com - 2.14.4-1
+- Autogenerated by ros-porting-tools