summaryrefslogtreecommitdiff
path: root/rqt-dotgraph.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-03-27 12:33:00 +0000
committerCoprDistGit <infra@openeuler.org>2025-03-27 12:33:00 +0000
commit63498dec6691189f907bbc036b970447056f5dee (patch)
tree366da1f7c54005ae0cc9910a522dd663f0880604 /rqt-dotgraph.spec
parentb73b9b5952e13928b6e26d1e5d807ef0fcf4b299 (diff)
automatic import of ros-humble-rqt-dotgraphopeneuler24.03_LTS
Diffstat (limited to 'rqt-dotgraph.spec')
-rw-r--r--rqt-dotgraph.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/rqt-dotgraph.spec b/rqt-dotgraph.spec
new file mode 100644
index 0000000..12e0220
--- /dev/null
+++ b/rqt-dotgraph.spec
@@ -0,0 +1,83 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global debug_package %{nil}
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
+%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
+
+%define RosPkgName rqt-dotgraph
+%define ros_distro humble
+%define with_tests 0
+
+Name: ros-%{ros_distro}-%{RosPkgName}
+Version: 0.0.4
+Release: 1%{?dist}%{?release_suffix}
+Summary: rqt GUI plugin to visualize dot graphs.
+
+License: LGPLv3 and CC0
+Source0: %{name}_%{version}.orig.tar.gz
+
+Requires: ros-%{ros_distro}-ament-indexpython
+Requires: python3-pyside2
+Requires: python3-qt5-devel
+Requires: python_qt_binding
+Requires: qt_dotgraph
+Requires: ros-%{ros_distro}-qt-gui-py-common
+Requires: rqt_graph
+Requires: ros-%{ros_distro}-rqt-gui
+Requires: ros-%{ros_distro}-rqt-gui-py
+Requires: ros-%{ros_distro}-std-msgs
+
+
+%if 0%{?with_tests}
+BuildRequires: ros-%{ros_distro}-ament-copyright
+BuildRequires: ros-%{ros_distro}-ament-flake8
+BuildRequires: ros-%{ros_distro}-ament-pep257
+BuildRequires: python3-pytest
+%endif
+
+Provides: %{name}-devel = %{version}-%{release}
+Provides: %{name}-doc = %{version}-%{release}
+Provides: %{name}-runtime = %{version}-%{release}
+
+%description
+rqt GUI plugin to visualize dot graphs.
+
+%prep
+%autosetup -p1
+
+%build
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%py3_build
+
+%install
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%py3_install -- --prefix "/opt/ros/%{ros_distro}"
+
+%if 0%{?with_tests}
+%check
+# Look for a directory with a name indicating that it contains tests
+TEST_TARGET=$(ls -d * | grep -m1 "\(test\|tests\)" ||:)
+if [ -n "$TEST_TARGET" ] && %__python3 -m pytest --version; then
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%__python3 -m pytest $TEST_TARGET || echo "RPM TESTS FAILED"
+else echo "RPM TESTS SKIPPED"; fi
+%endif
+
+%files
+/opt/ros/%{ros_distro}
+
+%changelog
+* 三 12月 04 2024 Alexander Xydes alexander.l.xydes.civ@us.navy.mil - 0.0.4-1
+- Autogenerated by ros-porting-tools