summaryrefslogtreecommitdiff
path: root/web-video-server.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2025-03-27 12:37:00 +0000
committerCoprDistGit <infra@openeuler.org>2025-03-27 12:37:00 +0000
commit30a9cc4ab7f28f3cfbc5ef817ad836101482449c (patch)
tree6aee8f92c01c393f4c6ee71bc9c9aa9c11ea3a2e /web-video-server.spec
parentdb75e055959151e372e55acb6a814e69a698a469 (diff)
automatic import of ros-humble-web-video-serveropeneuler24.03_LTS
Diffstat (limited to 'web-video-server.spec')
-rw-r--r--web-video-server.spec118
1 files changed, 118 insertions, 0 deletions
diff --git a/web-video-server.spec b/web-video-server.spec
new file mode 100644
index 0000000..e63b48b
--- /dev/null
+++ b/web-video-server.spec
@@ -0,0 +1,118 @@
+%bcond_without tests
+%bcond_without weak_deps
+
+%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
+%global __provides_exclude_from ^/opt/ros/%{ros_distro}/.*$
+%global __requires_exclude_from ^/opt/ros/%{ros_distro}/.*$
+
+%define RosPkgName web-video-server
+%define ros_distro humble
+%define with_tests 0
+
+Name: ros-%{ros_distro}-%{RosPkgName}
+Version: 2.0.1
+Release: 1%{?dist}%{?release_suffix}
+Summary: HTTP Streaming of ROS Image Topics in Multiple Formats
+
+Url: http://ros.org/wiki/web_video_server
+License: BSD
+Source0: %{name}_%{version}.orig.tar.gz
+
+Requires: ros-%{ros_distro}-rclcpp
+Requires: ros-%{ros_distro}-cv-bridge
+Requires: ros-%{ros_distro}-image-transport
+Requires: ros-%{ros_distro}-async-web-server-cpp
+Requires: ffmpeg
+Requires: ros-%{ros_distro}-sensor-msgs
+
+BuildRequires: ros-%{ros_distro}-rclcpp
+BuildRequires: ros-%{ros_distro}-cv-bridge
+BuildRequires: ros-%{ros_distro}-image-transport
+BuildRequires: ros-%{ros_distro}-async-web-server-cpp
+BuildRequires: ffmpeg
+BuildRequires: ros-%{ros_distro}-sensor-msgs
+BuildRequires: ros-%{ros_distro}-ament-cmake-ros
+
+%if 0%{?with_tests}
+BuildRequires: ros-%{ros_distro}-ament-lint-auto
+BuildRequires: ros-%{ros_distro}-ament-cmake-copyright
+BuildRequires: ros-%{ros_distro}-ament-cmake-cpplint
+BuildRequires: ros-%{ros_distro}-ament-cmake-lint-cmake
+BuildRequires: ros-%{ros_distro}-ament-cmake-xmllint
+BuildRequires: ros-%{ros_distro}-ament-cmake-uncrustify
+BuildRequires: ros-%{ros_distro}-ros-environment
+%endif
+
+Provides: %{name}-devel = %{version}-%{release}
+Provides: %{name}-doc = %{version}-%{release}
+Provides: %{name}-runtime = %{version}-%{release}
+
+%description
+HTTP Streaming of ROS Image Topics in Multiple Formats
+
+%prep
+%autosetup -p1
+
+%build
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+export ROS_DISTRO=%{ros_distro}
+export ROS_PYTHON_VERSION=%{python3_version}
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+mkdir -p .obj-%{_target_platform} && cd .obj-%{_target_platform}
+%cmake3 \
+ -UINCLUDE_INSTALL_DIR \
+ -ULIB_INSTALL_DIR \
+ -USYSCONF_INSTALL_DIR \
+ -USHARE_INSTALL_PREFIX \
+ -ULIB_SUFFIX \
+ -DCMAKE_INSTALL_PREFIX="/opt/ros/%{ros_distro}" \
+ -DAMENT_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+ -DCMAKE_PREFIX_PATH="/opt/ros/%{ros_distro}" \
+ -DCMAKE_INSTALL_LIBDIR="/opt/ros/%{ros_distro}/lib" \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+%if !0%{?with_tests}
+ -DBUILD_TESTING=OFF \
+%endif
+ ..
+
+%make_build
+
+%install
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+%make_install -C .obj-%{_target_platform}
+
+%if 0%{?with_tests}
+%check
+# Needed to bootstrap since the ros_workspace package does not yet exist.
+export PYTHONPATH=/opt/ros/%{ros_distro}/lib/python%{python3_version}/site-packages
+
+# Look for a Makefile target with a name indicating that it runs tests
+TEST_TARGET=$(%__make -qp -C .obj-%{_target_platform} | sed "s/^\(test\|check\):.*/\\1/;t f;d;:f;q0")
+if [ -n "$TEST_TARGET" ]; then
+# In case we're installing to a non-standard location, look for a setup.sh
+# in the install tree and source it. It will set things like
+# CMAKE_PREFIX_PATH, PKG_CONFIG_PATH, and PYTHONPATH.
+if [ -f "/opt/ros/%{ros_distro}/setup.sh" ]; then . "/opt/ros/%{ros_distro}/setup.sh"; fi
+CTEST_OUTPUT_ON_FAILURE=1 \
+ %make_build -C .obj-%{_target_platform} $TEST_TARGET || echo "RPM TESTS FAILED"
+else echo "RPM TESTS SKIPPED"; fi
+%endif
+
+%files
+/opt/ros/%{ros_distro}
+
+%changelog
+* 三 12月 04 2024 Błażej Sowa blazej@fictionlab.pl - 2.0.1-1
+- Autogenerated by ros-porting-tools