summaryrefslogtreecommitdiff
path: root/swoole.spec
diff options
context:
space:
mode:
Diffstat (limited to 'swoole.spec')
-rw-r--r--swoole.spec46
1 files changed, 46 insertions, 0 deletions
diff --git a/swoole.spec b/swoole.spec
new file mode 100644
index 0000000..2ced918
--- /dev/null
+++ b/swoole.spec
@@ -0,0 +1,46 @@
+Name: swoole
+Version: 5.0.3
+Release: 1
+Summary: Event-driven asynchronous and concurrent networking engine with high performance for PHP
+License: Apache 2.0
+URL: https://www.swoole.com/
+Source0: https://github.com/swoole/swoole-src/archive/refs/tags/v%{version}.tar.gz
+BuildRequires: php(language) >= 7.2.5
+BuildRequires: php-devel
+BuildRequires: openssl-devel >= 1.0.2
+
+%description
+Event-driven asynchronous and concurrent networking engine with high performance for PHP.
+ - event-driven
+ - coroutine
+ - asynchronous non-blocking
+ - multi-thread reactor
+ - multi-process worker
+ - multi-protocol
+ - millisecond timer
+ - built-in tcp/http/websocket/http2 server
+ - coroutine tcp/http/websocket client
+ - coroutine mysql client
+ - coroutine redis client
+ - coroutine read/write file system
+ - coroutine dns lookup
+ - support IPv4/IPv6/UnixSocket/TCP/UDP
+ - support SSL/TLS encrypted transmission
+
+%prep
+%autosetup -p1 -n swoole-src-%{version}
+
+%build
+%{_bindir}/phpize
+%configure --enable-openssl --enable-sockets
+%make_build
+
+%install
+%make_install
+
+%files
+%license LICENSE
+
+%changelog
+* Mon Aug 21 2023 Funda Wang <fundawang@yeah.net> - 5.0.3-1
+- Import package