summaryrefslogtreecommitdiff
path: root/golang.spec
diff options
context:
space:
mode:
Diffstat (limited to 'golang.spec')
-rw-r--r--golang.spec18
1 files changed, 17 insertions, 1 deletions
diff --git a/golang.spec b/golang.spec
index 2af841f..b9639dc 100644
--- a/golang.spec
+++ b/golang.spec
@@ -66,7 +66,7 @@
Name: golang
Version: 1.21.4
-Release: 17
+Release: 21
Summary: The Go Programming Language
License: BSD and Public Domain
URL: https://golang.org/
@@ -136,6 +136,10 @@ Patch6012: backport-0012-net-http-send-body-or-close-connection-on-expect-100.pa
Patch6013: backport-0013-release-branch.go1.21-net-http-update-bundled-golang.patch
Patch6014: backport-0014-cmd-compile-handle-constant-pointer-offsets-in-dead-.patch
Patch6015: backport-0015-release-branch.go1.21-cmd-compile-ensure-pointer-ari.patch
+Patch6016: backport-0016-release-branch.go1.21-internal-poll-add-SPLICE_F_NON.patch
+Patch6017: backport-0017-release-branch.go1.21-runtime-call-enableMetadataHug.patch
+Patch6018: backport-0018-release-branch.go1.21-cmd-compile-fix-findIndVar-so-.patch
+Patch6019: backport-0019-release-branch.go1.21-cmd-compile-fix-escape-analysi.patch
ExclusiveArch: %{golang_arches}
@@ -374,6 +378,18 @@ fi
%files devel -f go-tests.list -f go-misc.list -f go-src.list
%changelog
+* Thu Sep 19 2024 Vanient <xiadanni1@huawei.com> - 1.21.4-21
+- cmd/compile: fix escape analysis of string min/max
+
+* Thu Aug 1 2024 EulerOSWander <314264452@qq.com> - 1.21.4-20
+- cmd/compile: fix findIndVar so it does not match disjointed loop headers
+
+* Thu Aug 1 2024 EulerOSWander <314264452@qq.com> - 1.21.4-19
+- runtime: call enableMetadataHugePages and its callees on the systemstack
+
+* Thu Aug 1 2024 EulerOSWander <314264452@qq.com> - 1.21.4-18
+- internal/poll:add SPLICE_F_NONBLOCK flag for splice to avoid insonsistency with O_NONBLOCK
+
* Mon Jul 30 2024 jingxiaolu <lujingxiao@huawei.com> - 1.21.4-17
- cmd/compile: ensure pointer arithmetic happens after the nil check