summaryrefslogtreecommitdiff
path: root/nginx.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-02-02 12:25:03 +0000
committerCoprDistGit <infra@openeuler.org>2024-02-02 12:25:03 +0000
commit913f89578b506ecf7da04b0ce7c08d7f44141711 (patch)
tree9fb24300ef8ddebb2df2b181fc4faab8549bd567 /nginx.spec
parent998c19f0244c3eacbc632e58fbdeabee90527b7c (diff)
Diffstat (limited to 'nginx.spec')
-rw-r--r--nginx.spec25
1 files changed, 14 insertions, 11 deletions
diff --git a/nginx.spec b/nginx.spec
index 87d3c14..9cacee3 100644
--- a/nginx.spec
+++ b/nginx.spec
@@ -39,6 +39,7 @@ Source210: UPGRADE-NOTES-1.6-to-1.10
Patch0: nginx-auto-cc-gcc.patch
Patch1: nginx-1.12.1-logs-perm.patch
Patch2: nginx-fix-pidfile.patch
+Patch3: backport-CVE-2023-44487.patch
BuildRequires: gcc openssl-devel pcre2-devel zlib-devel systemd gperftools-devel
Requires: nginx-filesystem = %{epoch}:%{version}-%{release} openssl
@@ -160,8 +161,7 @@ mv ../%{name}-%{version}-%{release}-src .
%build
export DESTDIR=%{buildroot}
-nginx_ldopts="$RPM_LD_FLAGS -Wl,-E -Wl,-z,relro -Wl,-z,now -Wl,-z,noexecstack"
-nginx_ccopts="-fPIC -D_FORTIFY_SOURCE=2 -O2 -Wtrampolines -fsigned-char"
+nginx_ldopts="$RPM_LD_FLAGS -Wl,-E"
if ! ./configure \
--prefix=%{_datadir}/nginx --sbin-path=%{_sbindir}/nginx --modules-path=%{_libdir}/nginx/modules \
--conf-path=%{_sysconfdir}/nginx/nginx.conf --error-log-path=%{_localstatedir}/log/nginx/error.log \
@@ -185,9 +185,9 @@ if ! ./configure \
--with-http_gunzip_module --with-http_gzip_static_module --with-http_random_index_module \
--with-http_secure_link_module --with-http_degradation_module --with-http_slice_module \
--with-http_perl_module=dynamic --with-http_auth_request_module \
- --with-mail=dynamic --with-mail_ssl_module --with-pcre --with-pcre-jit --with-stream=dynamic \
+ --with-mail=dynamic --with-mail_ssl_module --with-openssl-opt=yes --with-pcre --with-pcre-jit --with-stream=dynamic \
--with-stream_ssl_module --with-google_perftools_module --with-debug \
- --with-cc-opt="%{optflags} $(pcre2-config --cflags) $nginx_ccopts" --with-ld-opt="$nginx_ldopts"; then
+ --with-cc-opt="%{optflags} $(pcre2-config --cflags)" --with-ld-opt="$nginx_ldopts"; then
: configure failed
cat objs/autoconf.err
exit 1
@@ -387,17 +387,20 @@ fi
%{_mandir}/man8/nginx.8*
%changelog
-* Thu Aug 17 2023 Funda Wang <fundawang@yeah.net> - 1:1.24.0-1
-- New version 1.24.0
+* Tue Jan 02 2024 gaihuiying <eaglegai@163.com> - 1:1.24.0-1
+- update nginx to 1.24.0
-* Wed Dec 21 2022 snoweay <snoweay@163.com> - 1:1.21.5-5
-- add safety compile options
+* Thu Oct 19 2023 yanglu <yanglu72@h-partners.com> - 1:1.23.3-2
+- fix CVE-2023-44487
-* Thu Nov 24 2022 zhouyihang <zhouyihang3@h-partners.com> - 1:1.21.5-4
+* Thu Mar 16 2023 gaihuiying <eaglegai@163.com> - 1:1.23.3-1
+- update nginx to 1.23.3
+
+* Thu Nov 24 2022 zhouyihang <zhouyihang3@h-partners.com> - 1:1.23.2-2
- add package mod-devel
-* Wed Oct 26 2022 gaihuiying <eaglegai@163.com> - 1:1.21.5-3
-- fix CVE-2022-41742 CVE-2022-41741
+* Mon Nov 14 2022 gaihuiying <eaglegai@163.com> - 1:1.23.2-1
+- update nginx to 1.23.2
* Tue Jul 19 2022 gaihuiying <eaglegai@163.com> - 1:1.21.5-2
- switch pcre to pcre2