summaryrefslogtreecommitdiff
path: root/valkey.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-10-18 00:58:25 +0000
committerCoprDistGit <infra@openeuler.org>2024-10-18 00:58:25 +0000
commit5f235febc4746e03919ce15b8d4fb0b69895aea2 (patch)
treedd75072a20a6b4958ca41aa5992d99715bc69a6a /valkey.spec
parent04c70613ebc1a9998bc78d65bb694a5c72558722 (diff)
automatic import of valkey
Diffstat (limited to 'valkey.spec')
-rw-r--r--valkey.spec291
1 files changed, 291 insertions, 0 deletions
diff --git a/valkey.spec b/valkey.spec
new file mode 100644
index 0000000..8fc6a73
--- /dev/null
+++ b/valkey.spec
@@ -0,0 +1,291 @@
+# Tests fail in mock, not in local build.
+%bcond_with tests
+
+Name: valkey
+Version: 8.0.1
+Release: 1
+Summary: A persistent key-value database
+# valkey: BSD-3-Clause
+# hiredis: BSD-3-Clause
+# hdrhistogram, jemalloc, lzf, linenoise: BSD-2-Clause
+# lua: MIT
+# fpconv: BSL-1.0
+License: BSD-3-Clause AND BSD-2-Clause AND MIT AND BSL-1.0
+URL: https://valkey.io
+Source0: https://github.com/valkey-io/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
+Source1: %{name}.logrotate
+Source2: %{name}-sentinel.service
+Source3: %{name}.service
+Source4: %{name}.sysusers
+# could have pulled this out of unpacked sources but
+# our copy has additional options pre-programmed in
+Source5: %{name}-limit-systemd
+Source6: %{name}.sysconfig
+Source7: %{name}-sentinel.sysconfig
+Source8: macros.%{name}
+Source9: migrate_redis_to_valkey.sh
+
+BuildRequires: make
+BuildRequires: gcc
+%if %{with tests}
+BuildRequires: procps-ng
+BuildRequires: tcl
+%endif
+BuildRequires: pkgconfig(libsystemd)
+BuildRequires: systemd-devel
+BuildRequires: openssl-devel
+Requires: logrotate
+Requires(pre): shadow-utils
+Requires(post): systemd
+Requires(preun): systemd
+Requires(postun): systemd
+# from deps/hiredis/hiredis.h
+Provides: bundled(hiredis) = 1.0.3
+# from deps/jemalloc/VERSION
+Provides: bundled(jemalloc) = 5.3.0
+# from deps/lua/src/lua.h
+Provides: bundled(lua-libs) = 5.1.5
+# from deps/linenoise/linenoise.h
+Provides: bundled(linenoise) = 1.0
+Provides: bundled(lzf)
+# from deps/hdr_histogram/README.md
+Provides: bundled(hdr_histogram) = 0.11.0
+# no version
+Provides: bundled(fpconv)
+
+%global valkey_modules_abi 1
+%global valkey_modules_dir %{_libdir}/%{name}/modules
+Provides: valkey(modules_abi)%{?_isa} = %{valkey_modules_abi}
+
+ExcludeArch: %{ix86}
+
+%description
+Valkey is an advanced key-value store. It is often referred to as a data
+structure server since keys can contain strings, hashes, lists, sets and
+sorted sets.
+
+You can run atomic operations on these types, like appending to a string;
+incrementing the value in a hash; pushing to a list; computing set
+intersection, union and difference; or getting the member with highest
+ranking in a sorted set.
+
+In order to achieve its outstanding performance, Valkey works with an
+in-memory dataset. Depending on your use case, you can persist it either
+by dumping the dataset to disk every once in a while, or by appending
+each command to a log.
+
+Valkey also supports trivial-to-setup master-slave replication, with very
+fast non-blocking first synchronization, auto-reconnection on net split
+and so forth.
+
+Other features include Transactions, Pub/Sub, Lua scripting, Keys with a
+limited time-to-live, and configuration settings to make Valkey behave like
+a cache.
+
+You can use Valkey from most programming languages also.
+
+%package devel
+Summary: Development header for Valkey module development
+# Header-Only Library (https://fedoraproject.org/wiki/Packaging:Guidelines)
+Provides: %{name}-static = %{version}-%{release}
+
+%description devel
+Header file required for building loadable Valkey modules.
+
+
+%package compat-redis
+Summary: Conversion script and compatibility symlinks for Redis
+Requires: valkey
+Conflicts: redis
+# if change proposal is approved
+#%if 0%%{?fedora} > 40
+#Obsoletes: redis <= 7.2.4
+#%endif
+
+%description compat-redis
+%summary
+
+
+%prep
+%autosetup -n %{name}-%{version} -p1
+
+mv deps/lua/COPYRIGHT COPYRIGHT-lua
+mv deps/jemalloc/COPYING COPYING-jemalloc
+mv deps/hiredis/COPYING COPYING-hiredis-BSD-3-Clause
+mv deps/hdr_histogram/LICENSE.txt LICENSE-hdrhistogram
+mv deps/hdr_histogram/COPYING.txt COPYING-hdrhistogram
+mv deps/fpconv/LICENSE.txt LICENSE-fpconv
+
+# See https://bugzilla.redhat.com/2240293
+# See https://src.fedoraproject.org/rpms/jemalloc/blob/rawhide/f/jemalloc.spec#_34
+%ifarch %ix86 %arm x86_64 s390x
+sed -e 's/--with-lg-quantum/--with-lg-page=12 --with-lg-quantum/' -i deps/Makefile
+%endif
+%ifarch ppc64 ppc64le aarch64
+sed -e 's/--with-lg-quantum/--with-lg-page=16 --with-lg-quantum/' -i deps/Makefile
+%endif
+
+# Module API version safety check
+api=`sed -n -e 's/#define VALKEYMODULE_APIVER_[0-9][0-9]* //p' src/valkeymodule.h`
+if test "$api" != "%{valkey_modules_abi}"; then
+ : Error: Upstream API version is now ${api}, expecting %%{valkey_modules_abi}.
+ : Update the valkey_modules_abi macro, the rpmmacros file, and rebuild.
+ exit 1
+fi
+
+%global make_flags CFLAGS="%{build_cflags}" DEBUG="" V="echo" PREFIX=%{buildroot}%{_prefix} BUILD_WITH_SYSTEMD=yes BUILD_TLS=yes
+
+%build
+%make_build %{make_flags}
+
+%install
+%make_install %{make_flags}
+
+# remove sample confs
+rm -rf %{buildroot}%{_datadir}/%{name}
+
+# System user
+install -p -D -m 0644 %{S:4} %{buildroot}%{_sysusersdir}/%{name}.conf
+
+# Filesystem.
+install -d %{buildroot}%{_sharedstatedir}/%{name}
+install -d %{buildroot}%{_localstatedir}/log/%{name}
+install -d %{buildroot}%{_localstatedir}/run/%{name}
+install -d %{buildroot}%{valkey_modules_dir}
+
+# Install logrotate file.
+install -pDm644 %{S:1} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
+
+# Install configuration files.
+install -pDm640 %{name}.conf %{buildroot}%{_sysconfdir}/%{name}/%{name}.conf
+install -pDm640 sentinel.conf %{buildroot}%{_sysconfdir}/%{name}/sentinel.conf
+
+# Install systemd unit files.
+mkdir -p %{buildroot}%{_unitdir}
+install -pm644 %{S:3} %{buildroot}%{_unitdir}
+install -pm644 %{S:2} %{buildroot}%{_unitdir}
+
+# Install systemd limit files
+install -p -D -m 644 %{S:5} %{buildroot}%{_unitdir}/%{name}.service.d/limit.conf
+install -p -D -m 644 %{S:5} %{buildroot}%{_unitdir}/%{name}-sentinel.service.d/limit.conf
+
+# Fix non-standard-executable-perm error.
+chmod 755 %{buildroot}%{_bindir}/%{name}-*
+
+# Install valkey module header
+install -pDm644 src/%{name}module.h %{buildroot}%{_includedir}/%{name}module.h
+
+# Install rpm macros for valkey modules
+#mkdir -p %{buildroot}%{_rpmmacrodir}
+install -pDm644 %{S:8} %{buildroot}%{_rpmmacrodir}/macros.%{name}
+
+# Install sysconfig files
+install -Dpm 644 %{S:6} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
+install -Dpm 644 %{S:7} %{buildroot}%{_sysconfdir}/sysconfig/%{name}-sentinel
+
+# compat script
+install -Dpm 755 %{S:9} %{buildroot}%{_libexecdir}/migrate_redis_to_valkey.sh
+
+
+%check
+%if %{with tests}
+# https://github.com/redis/redis/issues/1417 (for "taskset -c 1")
+taskset -c 1 make %{make_flags} test
+make %{make_flags} test-sentinel
+%endif
+
+%pre
+getent group 'valkey' >/dev/null || groupadd -r 'valkey' || :
+getent passwd 'valkey' >/dev/null || \
+ useradd -r -g 'valkey' -d '/dev/null' -s '/sbin/nologin' -c 'Valkey Database Server' 'valkey' || :
+
+%post
+%systemd_post %{name}.service
+%systemd_post %{name}-sentinel.service
+
+
+%post compat-redis
+%{_libexecdir}/migrate_redis_to_valkey.sh
+
+
+%preun
+%systemd_preun %{name}.service
+%systemd_preun %{name}-sentinel.service
+
+
+%postun
+%systemd_postun_with_restart %{name}.service
+%systemd_postun_with_restart %{name}-sentinel.service
+
+
+%files
+%license COPYING
+%license COPYRIGHT-lua
+%license COPYING-jemalloc
+%license LICENSE-hdrhistogram
+%license COPYING-hdrhistogram
+%license LICENSE-fpconv
+%license COPYING-hiredis-BSD-3-Clause
+%config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
+%attr(0750, valkey, root) %dir %{_sysconfdir}/%{name}
+%attr(0640, valkey, root) %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
+%attr(0640, valkey, root) %config(noreplace) %{_sysconfdir}/%{name}/sentinel.conf
+%dir %{_libdir}/%{name}
+%dir %{valkey_modules_dir}
+%dir %attr(0750, valkey, valkey) %{_sharedstatedir}/%{name}
+%dir %attr(0750, valkey, valkey) %{_localstatedir}/log/%{name}
+%{_bindir}/%{name}-*
+%{_unitdir}/%{name}.service
+%{_unitdir}/%{name}-sentinel.service
+%dir %{_unitdir}/%{name}.service.d
+%{_unitdir}/%{name}.service.d/limit.conf
+%dir %{_unitdir}/%{name}-sentinel.service.d
+%{_unitdir}/%{name}-sentinel.service.d/limit.conf
+%dir %attr(0755, valkey, valkey) %ghost %{_localstatedir}/run/%{name}
+%{_sysusersdir}/%{name}.conf
+%config(noreplace) %{_sysconfdir}/sysconfig/%{name}
+%config(noreplace) %{_sysconfdir}/sysconfig/%{name}-sentinel
+
+
+%files devel
+# main package is not required
+%license COPYING
+%{_includedir}/%{name}module.h
+%{_rpmmacrodir}/macros.%{name}
+
+
+%files compat-redis
+%{_libexecdir}/migrate_redis_to_valkey.sh
+%{_bindir}/redis-*
+
+
+%changelog
+* Fri Oct 18 2024 Funda Wang <fundawang@yeah.net> - 8.0.1-1
+- update to 8.0.1
+
+* Mon Sep 23 2024 Funda Wang <fundawang@yeah.net> - 8.0.0-1
+- update to 8.0.0
+- Set build flags
+
+* Mon Apr 29 2024 Jonathan Wright <jonathan@almalinux.org> - 7.2.5-5
+- improve migration scripts
+- rename compat package
+- fix working dir
+
+* Mon Apr 22 2024 Nathan Scott <nathans@redhat.com> - 7.2.5-3
+- remove version_no_tilde code
+
+* Mon Apr 22 2024 Nathan Scott <nathans@redhat.com> - 7.2.5-2
+- move redis compat symlinks to compat subpackage
+
+* Wed Apr 17 2024 Jonathan Wright <jonathan@almalinux.org> - 7.2.5-1
+- update to 7.2.5 rhbz#2275379
+
+* Fri Apr 12 2024 Jonathan Wright <jonathan@almalinux.org> - 7.2.5~rc1-2
+- add compat subpackage with migration scripts from redis
+
+* Fri Apr 12 2024 Jonathan Wright <jonathan@almalinux.org> - 7.2.5~rc1-1
+- update to 7.2.5-rc1
+
+* Tue Apr 09 2024 Jonathan Wright <jonathan@almalinux.org> - 7.2.4~rc1-1
+- Initial package build, release candidate