summaryrefslogtreecommitdiff
path: root/catch1.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-12-12 16:35:32 +0000
committerCoprDistGit <infra@openeuler.org>2024-12-12 16:35:32 +0000
commit2b79f7bae3ea7395a1067f6480b01313136b3e2b (patch)
treeff566d10e1f468e8d66c3c80a8afd4eea4f2f50e /catch1.spec
parentbad0e9e6aca7fb5b3dcef1b8cb6cb923436295ee (diff)
automatic import of catch1openeuler24.03_LTS
Diffstat (limited to 'catch1.spec')
-rw-r--r--catch1.spec63
1 files changed, 63 insertions, 0 deletions
diff --git a/catch1.spec b/catch1.spec
new file mode 100644
index 0000000..7716caf
--- /dev/null
+++ b/catch1.spec
@@ -0,0 +1,63 @@
+%global debug_package %{nil}
+
+Name: catch1
+Version: 1.12.2
+Release: 7
+Summary: A modern, C++-native, header-only, framework for unit-tests, TDD and BDD
+
+License: Boost
+URL: https://github.com/philsquared/Catch
+Source0: https://github.com/philsquared/Catch/archive/v%{version}/%{name}-%{version}.tar.gz
+Patch1: catch1-sigstksz.patch
+BuildRequires: cmake make gcc-c++
+
+%description
+Catch stands for C++ Automated Test Cases in Headers and is a
+multi-paradigm automated test framework for C++ and Objective-C (and,
+maybe, C). It is implemented entirely in a set of header files, but
+is packaged up as a single header for extra convenience.
+
+
+%package devel
+Summary: Development files for %{name}
+Provides: %{name}-static = %{version}-%{release}
+Conflicts: catch-devel
+
+%description devel
+Catch stands for C++ Automated Test Cases in Headers and is a
+multi-paradigm automated test framework for C++ and Objective-C (and,
+maybe, C). It is implemented entirely in a set of header files, but
+is packaged up as a single header for extra convenience.
+
+
+%prep
+%autosetup -p 1 -n Catch2-%{version}
+
+
+%build
+%cmake
+%cmake_build
+
+
+%install
+mkdir -p %{buildroot}%{_includedir}
+cp -pr include %{buildroot}%{_includedir}/catch
+
+%check
+%ctest
+
+%files devel
+%doc README.md catch-logo-small.png docs
+%license LICENSE.txt
+%{_includedir}/catch
+
+
+%changelog
+* Thu Nov 21 2024 Funda Wang <fundawang@yeah.net> - 1.12.2-7
+- adopt to new cmake macro
+
+* Tue Aug 10 2021 wangyue <wangyue92@huawei.com> - 1.12.2-6
+- Add patch for non-constant SIGSTKSZ
+
+* Sat Jul 18 2020 sunguoshuai <sunguoshuai@huawei.com> - 1.12.2-5
+- Package init