summaryrefslogtreecommitdiff
path: root/fluidsynth.spec
diff options
context:
space:
mode:
Diffstat (limited to 'fluidsynth.spec')
-rw-r--r--fluidsynth.spec114
1 files changed, 114 insertions, 0 deletions
diff --git a/fluidsynth.spec b/fluidsynth.spec
new file mode 100644
index 0000000..dd42de1
--- /dev/null
+++ b/fluidsynth.spec
@@ -0,0 +1,114 @@
+Name: fluidsynth
+Version: 2.4.3
+Release: 1
+Summary: Real-time software synthesizer
+License: LGPL-2.1-or-later
+URL: https://www.fluidsynth.org/
+Source0: https://github.com/FluidSynth/fluidsynth/archive/refs/tags/v%{version}.tar.gz
+
+BuildRequires: alsa-lib-devel cmake dbus-devel gcc jack-audio-connection-kit-devel readline-devel
+BuildRequires: ladspa-devel ncurses-devel libsndfile-devel pkgconfig pulseaudio-libs-devel doxygen
+BuildRequires: g++ make libxslt-devel systemd
+Provides: fluidsynth-libs = %{version}-%{release}
+Obsoletes: fluidsynth-libs < %{version}-%{release}
+%{?systemd_requires}
+
+%description
+FluidSynth is a free software synthesizer. Its currently based on the SoundFont
+2 specifications and supports real time MIDI effect controls. It can be used as a
+shared library for embedding in other applications, can play MIDI files and has
+a command line shell. Many other applications use FluidSynth for audio synthesis.
+
+%package devel
+Summary: Provides development package for fluidsynth
+Requires: fluidsynth-libs = %{version}-%{release}
+
+%description devel
+This package holds header files for building programs that link against fluidsynth.
+
+%package_help
+
+%prep
+%autosetup -n %{name}-%{version} -p1
+
+%build
+%cmake \
+ -Denable-ladspa=on \
+ -DFLUID_DAEMON_ENV_FILE=%{_sysconfdir}/sysconfig/%{name}.conf
+%cmake_build
+%cmake_build --target doxygen
+
+%install
+%cmake_install
+
+# manually install systemd service files
+install -Dm 644 %{__cmake_builddir}/fluidsynth.conf %{buildroot}%{_sysconfdir}/sysconfig/%{name}.conf
+install -Dm 644 %{__cmake_builddir}/fluidsynth.service %{buildroot}%{_unitdir}/%{name}.service
+
+%post
+%systemd_post %{name}.service
+
+%preun
+%systemd_preun %{name}.service
+
+%postun
+%systemd_postun %{name}.service
+
+%files
+%license LICENSE
+%doc AUTHORS
+%{_bindir}/fluid*
+%{_libdir}/libfluidsynth.so.3*
+%config(noreplace) %{_sysconfdir}/sysconfig/fluidsynth.conf
+%{_unitdir}/fluidsynth.service
+
+%files devel
+%doc %{__cmake_builddir}/doc/api/html doc/*fluid*.txt doc/*.odt
+%{_includedir}/fluidsynth.h
+%{_includedir}/fluidsynth/
+%{_libdir}/libfluidsynth.so
+%{_libdir}/pkgconfig/*
+%{_libdir}/cmake/fluidsynth/
+
+%files help
+%{_mandir}/man1/fluidsynth*
+%doc README.md THANKS TODO
+
+%changelog
+* Mon Jan 27 2025 Funda Wang <fundawang@yeah.net> - 2.4.3-1
+- update to 2.4.3
+
+* Wed Jan 01 2025 Funda Wang <fundawang@yeah.net> - 2.4.2-1
+- update to 2.4.2
+
+* Mon Dec 02 2024 Funda Wang <fundawang@yeah.net> - 2.4.1-1
+- update to 2.4.1
+
+* Tue Sep 03 2024 zhangxingrong <zhangxingrong@uniontech.cn> - 2.3.6-1
+- Update to 2.3.6
+- Fix a build issue on OS/2
+- Fix various encoding issues on Windows related to device names
+- Fix discovery of gobject by CMake
+- Fix a numerical instability that caused the chorus effect to stop working correctly when fluidsynth was compiled in single precision mode
+- Fix timing issues in MIDI player related to incorrect handling of running status
+- Fix ignoring LSB for RPN Pitch bend range events
+
+* Mon Jul 01 2024 wangkai <13474090681@163.com> - 2.3.5-1
+- Update to 2.3.5
+- Fix setting synth.chorus.speed to its minimum value being reported as out of range
+- Fix Pipewire audio driver not cleanly being destroy
+- Fix selection logic for XG drum banks
+- Add cmake flag FLUID_HOST_COMPILER to allow overriding default host compiler required during compilation
+- LASH support has been deprecated
+
+* Wed Mar 6 2024 liyanan <liyanan61@h-partners.com> - 2.3.4-1
+- Upgrade to 2.3.4
+
+* Wed Jun 15 2022 wulei <wulei80@h-partners.com> - 2.2.7-1
+- Upgrade to 2.2.7
+
+* Thu May 13 2021 wangxiao <wangxiao65@huawei.com> - 1.1.11-4
+- Fix CVE-2021-21417
+
+* Fri Nov 22 2019 sunguoshuai <sunguoshuai@huawei.com> - 1.1.11-3
+- Package init.