summaryrefslogtreecommitdiff
path: root/git-lfs.spec
diff options
context:
space:
mode:
Diffstat (limited to 'git-lfs.spec')
-rw-r--r--git-lfs.spec61
1 files changed, 61 insertions, 0 deletions
diff --git a/git-lfs.spec b/git-lfs.spec
new file mode 100644
index 0000000..26cd266
--- /dev/null
+++ b/git-lfs.spec
@@ -0,0 +1,61 @@
+%define debug_package %{nil}
+%bcond_without check
+
+# https://github.com/git-lfs/git-lfs
+Name: git-lfs
+Version: 3.6.0
+Release: 1
+Summary: Git extension for versioning large files
+
+License: MIT AND BSD-3-Clause
+URL: https://git-lfs.github.io/
+Source0: https://github.com/%{name}/%{name}/releases/download/v%{version}/%{name}-v%{version}.tar.gz
+Patch6000: 0001-use-vendor-dir-for-build.patch
+
+%if %{with check}
+# Tests
+BuildRequires: perl-Digest-SHA
+BuildRequires: perl-Test-Harness
+# Tests require full git suite, but not generally needed.
+BuildRequires: git >= 1.8.5
+%endif
+BuildRequires: golang, tar, which
+
+Requires: git-core >= 1.8.5
+Enhances: git-core
+
+%description
+Git Large File Storage (LFS) replaces large files such as audio samples,
+videos, datasets, and graphics with text pointers inside Git, while
+storing the file contents on a remote server.
+
+
+%prep
+%autosetup -n %{name}-%{version} -p1
+cd ..
+mv %{name}-%{version} %{name}
+mkdir -p %{name}-%{version}/src/github.com/git-lfs
+mv %{name} %{name}-%{version}/src/github.com/git-lfs/
+
+
+%build
+pushd src/github.com/git-lfs/%{name}
+make
+popd
+# BaseOS is not support rubygem-ronn/ronn, ignore generate man pages
+
+
+%install
+install -Dpm0755 src/github.com/git-lfs/git-lfs/bin/git-lfs %{buildroot}%{_bindir}/%{name}
+
+
+%files
+%{_bindir}/%{name}
+
+
+%changelog
+* Mon Dec 09 2024 Funda Wang <fundawang@yeah.net> - 3.6.0-1
+- update to 3.6.0
+
+* Tue Jul 12 2022 zhoukang <gameoverboss@163.com> - 3.2.0-1
+- Initial package