summaryrefslogtreecommitdiff
path: root/lasso.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-10-26 04:19:13 +0000
committerCoprDistGit <infra@openeuler.org>2024-10-26 04:19:13 +0000
commita83cb1f7d5605cdaac687e4bbfeae693fc0e466f (patch)
tree5a6ed349d161aed9147b7fc5db37811d5d2a69ae /lasso.spec
parenta8c1d0a9eebadff22f16130cdd4473ef9013443f (diff)
automatic import of lasso
Diffstat (limited to 'lasso.spec')
-rw-r--r--lasso.spec119
1 files changed, 119 insertions, 0 deletions
diff --git a/lasso.spec b/lasso.spec
new file mode 100644
index 0000000..8359344
--- /dev/null
+++ b/lasso.spec
@@ -0,0 +1,119 @@
+Name: lasso
+Version: 2.8.2
+Release: 3
+Summary: Liberty Alliance Single Sign On
+License: GPL-2.0-or-later
+URL: http://lasso.entrouvert.org/
+Source: http://dev.entrouvert.org/lasso/lasso-%{version}.tar.gz
+Patch6001: lasso-HEAD.patch
+Requires: xmlsec1 >= 1.2.25-4
+
+BuildRequires: autoconf automake check-devel glib2-devel gtk-doc libtool
+BuildRequires: libxml2-devel openssl-devel swig xmlsec1-devel >= 1.2.25-4
+BuildRequires: xmlsec1-openssl-devel >= 1.2.25-4 zlib-devel
+BuildRequires: perl(ExtUtils::MakeMaker) perl(strict) perl(Error)
+BuildRequires: perl-devel perl-generators perl(XSLoader) perl(warnings)
+BuildRequires: perl(Test::More) python3 python3-devel
+BuildRequires: python3-lxml libtool-ltdl-devel
+BuildRequires: openEuler-rpm-config >= 31-7
+
+Obsoletes: java-lasso < %{version}-%{release}
+
+%description
+The package is a implements the Liberty Alliance Single Sign On standards library,
+includeing the SAML2 and SAML specifications. it provides bindings for multiple
+languages.and allows to handle the whole life-cycle of SAML based Federations.
+
+%package devel
+Summary: Provide the development headers and documentation for lasso
+Requires: lasso = %{version}-%{release}
+%description devel
+The devel packages contains the header files, develpoment documentation
+and static libraries for lasso.
+
+%package -n perl-lasso
+Summary: Liberty Alliance Single Sign On (lasso) Perl bindings
+Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
+Requires: lasso = %{version}-%{release}
+%description -n perl-lasso
+The package provide Perl language bindings for the lasso
+(Liberty Alliance Single Sign On) library.
+
+%package -n python3-lasso
+%{?python_provide:%python_provide python3-lasso}
+Summary: Liberty Alliance Single Sign On (lasso) Python bindings
+Requires: python3 lasso = %{version}-%{release}
+
+%description -n python3-lasso
+The package provide Python language bindings for the lasso
+(Liberty Alliance Single Sign On)library.
+
+%package_help
+
+%prep
+%autosetup -n lasso-%{version} -p1
+sed -i -E -e '/^#![[:blank:]]*(\/usr\/bin\/env[[:blank:]]+python[^3]?\>) \
+|(\/usr\/bin\/python[^3]?\>)/d' `grep -r -l -E '^#![[:blank:]]*(/usr/bin/python[^3]?) \
+|(/usr/bin/env[[:blank:]]+python[^3]?)' *`
+
+%build
+autoreconf -fi
+%configure --enable-php5=no --with-python=%{__python3}
+%make_build
+
+%check
+%make_build check CK_TIMEOUT_MULTIPLIER=10
+
+%install
+%make_install
+%delete_la_and_a
+find %{buildroot}/usr/lib*/perl5 -type f -print |
+ sed "s@^%{buildroot}@@g" > lasso-perl-filelist
+if [ "$(cat lasso-perl-filelist)X" = "X" ] ; then
+ echo "ERROR: EMPTY FILE LIST"
+ exit -1
+fi
+
+rm -fr %{buildroot}%{_datadir}/doc
+
+%files
+%license COPYING
+%{_libdir}/liblasso.so.3*
+
+%files devel
+%{_includedir}/lasso
+%{_libdir}/liblasso.so
+%{_libdir}/pkgconfig/lasso.pc
+
+%files -n perl-lasso -f lasso-perl-filelist
+
+%files -n python3-lasso
+%{python3_sitearch}/*
+
+%files help
+%doc AUTHORS NEWS README
+
+%changelog
+* Fri Oct 25 2024 Funda Wang <fundawang@yeah.net> - 2.8.2-3
+- fix build with xmlsec 1.3 and libxml 2.12
+
+* Mon Jul 22 2024 yuanlipeng <yuanlipeng2@huawei.com> - 2.8.2-2
+- Fix build failure due to automake upgrade
+
+* Thu Jul 6 2023 liyanan <thistleslyn@163.com> - 2.8.2-1
+- Update to version 2.8.2
+
+* Wed Feb 08 2023 Ge Wang <wangge20@h-partners.com> - 2.8.0-1
+- Update to version 2.8.0 fix build failure due to openssl update to version 3.0.8
+
+* Fri Apr 8 2022 yaoxin <yaoxin30@h-partners.com> - 2.7.0-1
+- Resolve compilation failures
+
+* Sat Jul 10 2021 shixuantong <shixuantong@huawei.com> - 2.6.0-13
+- fix CVE-2021-28091
+
+* Wed Oct 21 2020 Ge Wang <wangge20@huawei.com> - 2.6.0-12
+- remove python2
+
+* Wed Jun 18 2020 yaokai <yaoaki13@huawei.com> - 2.6.0-11
+- package init