summaryrefslogtreecommitdiff
path: root/python-rpm-generators.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-10-23 08:44:55 +0000
committerCoprDistGit <infra@openeuler.org>2024-10-23 08:44:55 +0000
commit8baaf0fea2fb6bda8ff77272fbc3d4d8b0c014e3 (patch)
treee6a6cc8c06953ef151d9792be3ac767bf859810a /python-rpm-generators.spec
parent2970a8685236bf3143f35d221bab53a4dd988e25 (diff)
automatic import of python-rpm-generators
Diffstat (limited to 'python-rpm-generators.spec')
-rw-r--r--python-rpm-generators.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-rpm-generators.spec b/python-rpm-generators.spec
new file mode 100644
index 0000000..fe699c2
--- /dev/null
+++ b/python-rpm-generators.spec
@@ -0,0 +1,72 @@
+%undefine py_auto_byte_compile
+
+Name: python-rpm-generators
+Version: 14
+Release: 2
+Summary: Dependency generators for Python RPMs
+
+License: GPL-2.0-or-later AND LGPL-2.1-or-later AND (Public Domain OR LGPL-2.1-or-later OR GPL-2.0-or-later)
+URL: https://src.fedoraproject.org/rpms/python-rpm-generators
+Source0: https://raw.githubusercontent.com/rpm-software-management/rpm/102eab50b3d0d6546dfe082eac0ade21e6b3dbf1/COPYING
+Source1: python.attr
+Source2: pythondist.attr
+# This one is also originally from RPM, but it has its own license declaration: LGPL-2.1-or-later
+Source4: pythondistdeps.py
+# This was crafted in-place with the following license declaration:
+# Public-Domain OR CC0-1.0 OR LGPL-2.1-or-later OR GPL-2.0-or-later
+Source5: pythonbundles.py
+
+BuildArch: noarch
+
+%description
+Fedora's dependency generators for Python RPMS.
+
+%package -n python3-rpm-generators
+Summary: %{summary}
+Requires: python3-setuptools
+Requires: rpm > 4.15.90
+Conflicts: rpm-build < 4.13.0.1-2
+Conflicts: python-rpm-macros < 3-35
+
+%description -n python3-rpm-generators
+Fedora's dependency generators for Python RPMS.
+
+%prep
+%autosetup -c -T
+cp -a %{sources} .
+
+%install
+install -Dpm0644 -t %{buildroot}%{_fileattrsdir} *.attr
+install -Dpm0755 -t %{buildroot}%{_rpmconfigdir} *.py
+
+%files -n python3-rpm-generators
+%license COPYING
+%{_fileattrsdir}/python.attr
+%{_fileattrsdir}/pythondist.attr
+%{_rpmconfigdir}/pythondistdeps.py
+%{_rpmconfigdir}/pythonbundles.py
+
+%changelog
+* Wed Oct 23 2024 Funda Wang <fundawang@yeah.net> - 14-2
+- drop pythonname.attr as it requries fedora.srpm.python which is not available
+
+* Sat Oct 19 2024 Funda Wang <fundawang@yeah.net> - 14-1
+- update to latest upstream version
+
+* Tue Aug 06 2024 chenhuihan <chenhuihan@huawei.com> - 9-5
+- Fix python provide and requires
+
+* Sun Apr 23 2023 caodongxia <caodongxia@h-partners.com> - 9-4
+- Fix the python3 version cannot be found when pyproject.toml is used for building
+
+* Thu Oct 27 2022 zhangruifang <zhangruifang1@h-partners.com> - 9-3
+- Rebuild for next release
+
+* Fri Jan 07 2022 shixuantong <shixuantong@huawei.com> - 9-2
+- downgrade version to 9
+
+* Thu Dec 09 2021 liudabo <liudabo1@huawei.com> - 12-1
+- upgrade version to 12
+
+* Tue Sep 17 2019 openEuler Buildteam <buildteam@openeuler.org> - 9-1
+- Package init