summaryrefslogtreecommitdiff
path: root/python3.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-10-25 03:46:06 +0000
committerCoprDistGit <infra@openeuler.org>2024-10-25 03:46:06 +0000
commit821c6eda1599c3afc99513163bf75c6ea31a5bb0 (patch)
tree1aabda5a5061940519b458f6a2b5d9dc6396183a /python3.spec
parent36e0c27298a5f9d680385b60df3a84e82d60b16b (diff)
automatic import of python3
Diffstat (limited to 'python3.spec')
-rw-r--r--python3.spec2
1 files changed, 2 insertions, 0 deletions
diff --git a/python3.spec b/python3.spec
index 0daa0fc..b0c003c 100644
--- a/python3.spec
+++ b/python3.spec
@@ -187,6 +187,8 @@ rm -r Modules/expat
rm Lib/ensurepip/_bundled/*.whl
rm configure pyconfig.h.in
+%global extra_cflags -O2
+
export CFLAGS="%{extension_cflags} %{?extra_cflags} -D_GNU_SOURCE -fPIC -fwrapv -fstack-protector-strong -D_FORTIFY_SOURCE=2 -O2"
export CFLAGS_NODIST="%{build_cflags} %{?extra_cflags} -D_GNU_SOURCE -fPIC -fwrapv"
export CXXFLAGS="%{extension_cxxflags} -D_GNU_SOURCE -fPIC -fwrapv"