summaryrefslogtreecommitdiff
path: root/python3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python3.spec')
-rw-r--r--python3.spec18
1 files changed, 1 insertions, 17 deletions
diff --git a/python3.spec b/python3.spec
index 740bccc..ea44207 100644
--- a/python3.spec
+++ b/python3.spec
@@ -1,19 +1,3 @@
-%global __extension_strip_flags() %{lua:
---the only argument to this macro is the "name" of the flags we strip (e.g. cflags, ldflags, etc.)
-local name = rpm.expand("%{1}")
---store all the individual flags in a variable as a continuous string
-local flags = rpm.expand("%{build_" .. name .. "}")
---create an empty table for the minimal set of flags we wanna preserve
-local stripped_flags = { }
---iterate over the individual flags and store the ones we want in the table as unique keys
-for flag in flags:gmatch("%%S+") do
- if flag:find("^%%-fexceptions") or flag:find("^%%-fcf%%-protection") then
- stripped_flags[flag] = true end
- end
---print out the finalized set of flags for use by the extension builders
-for k,_ in pairs(stripped_flags) do print(k .. " ") end
-}
-
Name: python3
Summary: Interpreter of the Python3 programming language
URL: https://www.python.org/
@@ -205,7 +189,7 @@ rm configure pyconfig.h.in
%global extra_cflags -O2
-#trace
+%trace
export CFLAGS="%{extension_cflags} %{?extra_cflags} -D_GNU_SOURCE -fPIC -fwrapv -fstack-protector-strong -D_FORTIFY_SOURCE=2 -O2"
export CFLAGS_NODIST="%{build_cflags} %{?extra_cflags} -D_GNU_SOURCE -fPIC -fwrapv"