summaryrefslogtreecommitdiff
path: root/qscintilla.spec
diff options
context:
space:
mode:
Diffstat (limited to 'qscintilla.spec')
-rw-r--r--qscintilla.spec6
1 files changed, 6 insertions, 0 deletions
diff --git a/qscintilla.spec b/qscintilla.spec
index 0a0dae9..32b7fa0 100644
--- a/qscintilla.spec
+++ b/qscintilla.spec
@@ -78,6 +78,12 @@ pushd Python
--sip=/usr/bin/sip-pyqt5 \
--qsci-incdir=../Qt4Qt5 --qsci-libdir=../Qt4Qt5
make sub-Qsci-qmake_all
+sed -i \
+ -e '#^CXXFLAGS#s#$# %{build_cxxflags}#' \
+ -e '#^LFLAGS#s#$# %{build_ldflags}#'\
+ -e '#^INCPATH#s#$# -I%{_qt5_includedir}/QtWidgets#' \
+ -e '#^LIBS#s#$# %{_qt5_libdir}/libQt5Widgets.so#'\
+ Qsci/Makefile
cat Qsci/Makefile
%make_build
popd