summaryrefslogtreecommitdiff
path: root/qscintilla.spec
diff options
context:
space:
mode:
Diffstat (limited to 'qscintilla.spec')
-rw-r--r--qscintilla.spec13
1 files changed, 4 insertions, 9 deletions
diff --git a/qscintilla.spec b/qscintilla.spec
index 6afb180..2c8869b 100644
--- a/qscintilla.spec
+++ b/qscintilla.spec
@@ -12,7 +12,6 @@ Source0: https://github.com/opencor/qscintilla/archive/refs/tags/v%{
Patch100: QScintilla_gpl-2_10_7-sip_check.patch
Patch101: QScintilla_gpl-2_11-QUrl.patch
Patch102: fix-build-error.patch
-Patch103: qscintilla-2.11.6-add-qtwidgets-and-printsupport.patch
BuildRequires: gcc-c++
BuildRequires: pkgconfig(Qt5Designer) pkgconfig(Qt5Gui) pkgconfig(Qt5Widgets)
Provides: bundled(scintilla) = %{scintilla_ver}
@@ -66,7 +65,7 @@ pushd Qt4Qt5
%make_build
popd
-QMAKEFEATURES=`pwd`/Qt5/features; export QMAKEFEATURES
+QMAKEFEATURES=`pwd`/Qt4Qt5/features; export QMAKEFEATURES
pushd designer-Qt4Qt5
%{qmake_qt5} designer.pro INCLUDEPATH+=../Qt4Qt5 LIBS+=-L../Qt4Qt5
%make_build
@@ -79,13 +78,9 @@ pushd Python
--sip=/usr/bin/sip-pyqt5 \
--qsci-incdir=../Qt4Qt5 --qsci-libdir=../Qt4Qt5
-cat Qsci/Qsci.pro
-make sub-Qsci-qmake_all
-sed -i \
- -e '#^CXXFLAGS#s#$# %{build_cxxflags}#' \
- -e '#^LFLAGS#s#$# %{build_ldflags}#'\
- Qsci/Makefile
-cat Qsci/Makefile
+pushd Qsci
+%{qmake_qt5} Qsci.pro -o Makefile
+popd
%make_build
popd