summaryrefslogtreecommitdiff
path: root/acl.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-08-10 18:02:20 +0000
committerCoprDistGit <infra@openeuler.org>2024-08-10 18:02:20 +0000
commitb8d53392c251d5565625b72e860a3e5f2d56ec83 (patch)
treea2e73dba6bd1295372548118ee6bfdd0dba4549b /acl.spec
parent7ab591f04a0aface320ad8a499997f7905b42bf4 (diff)
automatic import of aclopeneuler24.03_LTS
Diffstat (limited to 'acl.spec')
-rw-r--r--acl.spec111
1 files changed, 111 insertions, 0 deletions
diff --git a/acl.spec b/acl.spec
new file mode 100644
index 0000000..a142765
--- /dev/null
+++ b/acl.spec
@@ -0,0 +1,111 @@
+Name: acl
+Version: 2.3.2
+Release: 1
+Summary: Commands for manipulating POSIX access control lists
+
+License: GPL-2.0-or-later AND LGPL-2.1-or-later
+URL: https://savannah.nongnu.org/projects/acl
+Source0: http://download.savannah.nongnu.org/releases/acl/%{name}-%{version}.tar.xz
+
+Patch1: backport-acl_copy_entry-Prevent-accidental-NULL-pointer-deref.patch
+
+BuildRequires: libattr-devel gawk libtool gettext
+BuildRequires: chrpath
+
+%description
+This package contains commands for manipulating POSIX access control lists,
+and the libacl.so dynamic library which contains the POSIX 1003.1e draft
+standard 17 functions for manipulating access control lists.
+
+%package -n libacl
+Summary: Library for supporting access control list
+License: LGPL-2.1-or-later
+Conflicts: filesystem < 3
+
+%description -n libacl
+This package contains the library for manipulating access control list.
+
+%package -n libacl-devel
+Summary: Files necessary to develop applications with libacl
+License: LGPL-2.1-or-later
+Requires: libacl = %{version}-%{release}
+Obsoletes: acl-devel < %{version}-%{release}
+
+%description -n libacl-devel
+This package contains header files for the POSIX ACL library.
+
+%package_help
+
+%prep
+%autosetup -n %{name}-%{version} -p1
+
+%build
+%configure --disable-static
+%make_build
+
+%install
+%make_install
+%delete_la
+rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}*
+chrpath -d $RPM_BUILD_ROOT%{_bindir}/setfacl
+chrpath -d $RPM_BUILD_ROOT%{_bindir}/getfacl
+chrpath -d $RPM_BUILD_ROOT%{_bindir}/chacl
+
+%find_lang %{name}
+
+%check
+# permissions.test needs 'daemon' users to be in the 'bin' group. If not, stop this test.
+if test 0 = "$(id -u)"; then
+ sed -e 's|test/root/permissions.test||' -i test/Makemodule.am Makefile.in Makefile
+fi
+# setfacl.test needs 'bin' users to have the access to build dir. If not, stop this test.
+if ! runuser -u bin -- "${PWD}/setfacl" --version; then
+ sed -e 's|test/root/setfacl.test||' -i test/Makemodule.am Makefile.in Makefile
+fi
+
+%make_build check
+
+%files -f %{name}.lang
+%license doc/COPYING*
+%{_bindir}/*acl
+
+%files -n libacl
+%{_libdir}/libacl.so.*
+
+%files -n libacl-devel
+%{_includedir}/acl/libacl.h
+%{_includedir}/sys/acl.h
+%{_libdir}/libacl.so
+%{_libdir}/pkgconfig/libacl.pc
+
+%files help
+%{_mandir}/man?/*
+
+%changelog
+* Sun Aug 11 2024 Funda Wang <fundawang@yeah.net> - 2.3.2-1
+- update to 2.3.2
+- drop useless ld.so.conf.d scriptlet
+
+* Wed Jul 10 2024 yixiangzhike <yixiangzhike007@163.com> - 2.3.1-3
+- Backport upstream patch to avoid NULL dereferences
+
+* Tue Sep 20 2022 yixiangzhike <yixiangzhike007@163.com> - 2.3.1-2
+- Remove rpath and runpath of exec files
+
+* Tue Jul 27 2021 panxiaohe <panxiaohe@huawei.com> - 2.3.1-1
+- Update to 2.3.1
+
+* Fri Feb 28 2020 openEuler Buildteam <buildteam@openeuler.org> - 2.2.53-7
+- Obsoletes acl-devel
+
+* Wed Feb 12 2020 openEuler Buildteam <buildteam@openeuler.org> - 2.2.53-6
+- Change acl-devel to libacl-devel
+
+* Wed Jan 22 2020 openEuler Buildteam <buildteam@openeuler.org> - 2.2.53-5
+- Add libacl package
+
+* Sat Dec 14 2019 openEuler Buildteam <buildteam@openeuler.org> - 2.2.53-4
+- Provides arch releated rpm
+
+* Tue Sep 10 2019 openEuler Buildteam <buildteam@openeuler.org> - 2.2.53-3
+- Package init