summaryrefslogtreecommitdiff
path: root/libtool.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-08-17 15:22:52 +0000
committerCoprDistGit <infra@openeuler.org>2024-08-17 15:22:52 +0000
commitde8ed43665a5b49250f53b7444fe3f80b7bb1e59 (patch)
treef9630c35d772656c50699fe93c76160a2de55649 /libtool.spec
parentd1de1640e4900a16fd4a78f829c1f67a97aeb7bd (diff)
automatic import of libtoolopeneuler24.03_LTS
Diffstat (limited to 'libtool.spec')
-rw-r--r--libtool.spec140
1 files changed, 140 insertions, 0 deletions
diff --git a/libtool.spec b/libtool.spec
new file mode 100644
index 0000000..042ea19
--- /dev/null
+++ b/libtool.spec
@@ -0,0 +1,140 @@
+%undefine _hardened_build
+
+Name: libtool
+Version: 2.5.1
+Release: 1
+License: GPL-2.0-or-later AND GPL-2.0-or-later WITH Autoconf-exception-generic AND GPL-2.0-or-later WITH Libtool-exception AND LGPL-2.0-or-later WITH Libtool-exception AND GPL-3.0-or-later WITH Autoconf-exception-generic-3.0 AND MIT AND FSFAP AND FSFULLR AND FSFULLRWD AND GFDL-1.3-or-later AND X11
+Summary: The GNU Portable Library Tool
+URL: http://www.gnu.org/software/libtool/
+Source0: https://alpha.gnu.org/gnu/libtool/%{name}-%{version}.tar.xz
+
+Patch0: libtool-2.5.1-rpath.patch
+
+Requires: gcc(major),autoconf, automake, sed, tar, findutils
+
+BuildRequires: texinfo autoconf automake help2man libtool-devel libtool
+BuildRequires: libstdc++-devel gcc-gfortran gcc gcc-c++
+
+%description
+GNU libtool is a generic library support script.
+Libtool hides the complexity of using shared libraries behind a consistent, portable interface.
+
+%package ltdl
+Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
+License: LGPL-2.1-or-later
+Provides: %{name}-libs = %{version}-%{release}
+
+%description ltdl
+The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
+library that provides a consistent, portable interface which simplifies the
+process of using dynamic modules.
+
+%package devel
+Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
+License: LGPL-2.1-or-later
+Requires: automake
+Requires: %{name}-ltdl = %{version}-%{release}
+Provides: %{name}-ltdl-devel = %{version}-%{release}
+Obsoletes: %{name}-ltdl-devel < %{version}-%{release}
+
+%description devel
+Static libraries and header files for development with ltdl.
+
+%package_help
+
+%prep
+%autosetup -n libtool-%{version} -p1
+
+%build
+autoreconf -v
+export CC=gcc
+export CXX=g++
+export F77=gfortran
+export CFLAGS="$RPM_OPT_FLAGS -fPIC"
+export FFLAGS=$(echo "$RPM_OPT_FLAGS -I/usr/lib64/gfortran/modules"| sed 's/-fstack-protector-strong/ /g')
+export FCFLAGS=$(echo "$RPM_OPT_FLAGS -I/usr/lib64/gfortran/modules"| sed 's/-fstack-protector-strong/ /g')
+%ifarch x86_64 riscv64
+export FFLAGS="$RPM_OPT_FLAGS -fPIE"
+export FCFLAGS="$RPM_OPT_FLAGS -fPIE"
+%endif
+
+%configure --disable-static
+
+%make_build CUSTOM_LTDL_CFLAGS="%_hardening_cflags" CUSTOM_LTDL_LDFLAGS="%_hardening_ldflags"
+
+%check
+%make_build check VERBOSE=yes
+
+%install
+%make_install
+%delete_la
+rm -f %{buildroot}%{_infodir}/dir
+
+%files
+%license COPYING
+%doc AUTHORS NEWS THANKS TODO ChangeLog*
+%{_bindir}/libtool
+%{_bindir}/libtoolize
+%{_datadir}/aclocal/*.m4
+%dir %{_datadir}/libtool
+%{_datadir}/libtool/build-aux
+
+%files ltdl
+%license libltdl/COPYING.LIB
+%{_libdir}/libltdl.so.*
+
+%files devel
+%license libltdl/COPYING.LIB
+%doc libltdl/README
+%{_datadir}/libtool
+%exclude %{_datadir}/libtool/build-aux
+%{_includedir}/ltdl.h
+%{_includedir}/libltdl
+%{_libdir}/libltdl.so
+
+%files help
+%doc README
+%{_infodir}/libtool.info*.gz
+%{_mandir}/man1/libtool.1*
+%{_mandir}/man1/libtoolize.1*
+
+
+%changelog
+* Sat Jul 27 2024 Funda Wang <fundawang@yeah.net> - 2.5.1-1
+- update to 2.5.1
+
+* Tue Jun 06 2023 laokz <zhangkai@iscas.ac.cn> - 2.4.7-3
+- add -fPIC to fortran flags for riscv
+
+*Thu Feb 02 2023 renhongxun <renhongxun@h-partners.com> - 2.4.7-2
+- backport: tests/link-order.at: avoid warning and test failure with GNU grep 3.8
+
+* Thu Nov 03 2022 renhongxun <renhongxun@h-partners.com> - 2.4.7-1
+- upgrade version to 2.4.7
+
+* Tue Apr 26 2022 renhongxun <renhongxun@h-partners.com> - 2.4.6-35
+- udpate license from GFDL to GFDL-1.3-or-later
+
+* Fri Jul 23 2021 yuanxin <yuanxin24@huawei.com> - 2.4.6-34
+- remove BuildRequires gdb
+
+* Thu Aug 20 2020 tianwei <tianwei12@huawei.com> - 2.4.6-33
+- fixbug testcase fail for gfortan
+
+* Thu Mar 19 2020 openEuler Buildteam <buildteam@openeuler.org> - 2.4.6-32
+- add necessary BuildRequires
+
+* Mon Jan 20 2020 openEuler Buildteam <buildteam@openeuler.org> - 2.4.6-31
+- fixbug in wrong dependency of kernel-devel
+
+* Wed Jan 8 2020 openEuler Buildteam <buildteam@openeuler.org> - 2.4.6-30
+- format patches
+
+* Thu Sep 5 2019 openEuler Buildteam <buildteam@openeuler.org> - 2.4.6-29
+- Package init
+
+* Sun Feb 24 2019 zoujing <zoujing13@huawei.com> - 2.4.6-28
+- Type:NA
+- ID:NA
+- SUG:NA
+- DESC: change gcc version number on aarch64