summaryrefslogtreecommitdiff
path: root/gstreamer1.spec
diff options
context:
space:
mode:
Diffstat (limited to 'gstreamer1.spec')
-rw-r--r--gstreamer1.spec579
1 files changed, 579 insertions, 0 deletions
diff --git a/gstreamer1.spec b/gstreamer1.spec
new file mode 100644
index 0000000..4371c7e
--- /dev/null
+++ b/gstreamer1.spec
@@ -0,0 +1,579 @@
+%global majorminor 1.0
+
+#global gitrel 140
+#global gitcommit a70055b58568f7304ba46bd8742232337013487b
+#global shortcommit %(c=%{gitcommit}; echo ${c:0:5})
+
+%global _glib2 2.32.0
+%global _libxml2 2.4.0
+%global _gobject_introspection 1.31.1
+%global __python %{__python3}
+
+%if 0%{?fedora}
+%bcond_without unwind
+%else
+%bcond_with unwind
+%endif
+
+Name: gstreamer1
+Version: 1.22.1
+Release: 2%{?gitcommit:.git%{shortcommit}}%{?dist}
+Summary: GStreamer streaming media framework runtime
+
+License: LGPLv2+
+URL: http://gstreamer.freedesktop.org/
+%if 0%{?gitrel}
+# git clone git://anongit.freedesktop.org/gstreamer/gstreamer
+# cd gstreamer; git reset --hard %{gitcommit}; ./autogen.sh; make; make distcheck
+Source0: gstreamer-%{version}.tar.xz
+%else
+Source0: http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
+%endif
+## For GStreamer RPM provides
+Patch0: gstreamer-inspect-rpm-format.patch
+Source1: gstreamer1.prov
+Source2: gstreamer1.attr
+
+BuildRequires: meson >= 0.48.0
+BuildRequires: gcc
+BuildRequires: glib2-devel >= %{_glib2}
+BuildRequires: libxml2-devel >= %{_libxml2}
+BuildRequires: gobject-introspection-devel >= %{_gobject_introspection}
+BuildRequires: bison
+BuildRequires: flex
+BuildRequires: check-devel
+BuildRequires: gettext
+BuildRequires: pkgconfig
+BuildRequires: libcap-devel
+%if %{with unwind}
+BuildRequires: libunwind-devel
+%endif
+BuildRequires: elfutils-devel
+BuildRequires: bash-completion
+
+%description
+GStreamer is a streaming media framework, based on graphs of filters which
+operate on media data. Applications using this library can do anything
+from real-time sound processing to playing videos, and just about anything
+else media-related. Its plugin-based architecture means that new data
+types or processing capabilities can be added simply by installing new
+plugins.
+
+
+%package devel
+Summary: Libraries/include files for GStreamer streaming media framework
+Requires: %{name}%{?isa} = %{version}-%{release}
+Requires: glib2-devel%{?_isa} >= %{_glib2}
+Requires: libxml2-devel%{?_isa} >= %{_libxml2}
+Requires: check-devel
+# file /usr/include/gstreamer-1.0/gst/base/gstaggregator.h conflicts between attempted installs of gstreamer1-plugins-bad-free-devel-1.12.4-3.fc28.x86_64 and gstreamer1-devel-1.13.1-1.fc29.x86_64
+Conflicts: gstreamer1-plugins-bad-free-devel < 1.13
+
+%description devel
+The %{name}-devel package contains libraries and header files for
+developing applications that use %{name}.
+
+%if 0
+%package devel-docs
+Summary: Developer documentation for GStreamer streaming media framework
+Requires: %{name} = %{version}-%{release}
+BuildArch: noarch
+
+%description devel-docs
+This %{name}-devel-docs contains developer documentation for the
+GStreamer streaming media framework.
+%endif
+
+
+%prep
+%setup -q -n gstreamer-%{version}
+%patch0 -p1 -b .rpm-provides
+
+%build
+%meson \
+ -D package-name='Fedora GStreamer package' \
+ -D package-origin='http://download.fedoraproject.org' \
+ -D tests=disabled -D examples=disabled \
+ -D ptp-helper-permissions=capabilities \
+ %{!?with_unwind:-D libunwind=disabled -D libdw=disabled } \
+ -D dbghelp=disabled \
+ -D doc=disabled
+%meson_build
+
+%install
+%meson_install
+
+%find_lang gstreamer-%{majorminor}
+# Add the provides script
+install -m0755 -D %{SOURCE1} $RPM_BUILD_ROOT%{_rpmconfigdir}/gstreamer1.prov
+# Add the gstreamer plugin file attribute entry (rpm >= 4.9.0)
+install -m0644 -D %{SOURCE2} $RPM_BUILD_ROOT%{_rpmconfigdir}/fileattrs/gstreamer1.attr
+
+%ldconfig_scriptlets
+
+%files -f gstreamer-%{majorminor}.lang
+%license COPYING
+%doc AUTHORS NEWS README.md README.static-linking RELEASE
+%{_libdir}/libgstreamer-%{majorminor}.so.*
+%{_libdir}/libgstbase-%{majorminor}.so.*
+%{_libdir}/libgstcheck-%{majorminor}.so.*
+%{_libdir}/libgstcontroller-%{majorminor}.so.*
+%{_libdir}/libgstnet-%{majorminor}.so.*
+
+%{_libexecdir}/gstreamer-%{majorminor}/
+
+%dir %{_libdir}/gstreamer-%{majorminor}
+%{_libdir}/gstreamer-%{majorminor}/libgstcoreelements.so
+%{_libdir}/gstreamer-%{majorminor}/libgstcoretracers.so
+
+%{_libdir}/girepository-1.0/Gst-%{majorminor}.typelib
+%{_libdir}/girepository-1.0/GstBase-%{majorminor}.typelib
+%{_libdir}/girepository-1.0/GstCheck-%{majorminor}.typelib
+%{_libdir}/girepository-1.0/GstController-%{majorminor}.typelib
+%{_libdir}/girepository-1.0/GstNet-%{majorminor}.typelib
+
+%{_bindir}/gst-inspect-%{majorminor}
+%{_bindir}/gst-launch-%{majorminor}
+%{_bindir}/gst-stats-%{majorminor}
+%{_bindir}/gst-typefind-%{majorminor}
+
+%{_rpmconfigdir}/gstreamer1.prov
+%{_rpmconfigdir}/fileattrs/gstreamer1.attr
+
+%doc %{_mandir}/man1/gst-inspect-%{majorminor}.*
+%doc %{_mandir}/man1/gst-launch-%{majorminor}.*
+%doc %{_mandir}/man1/gst-stats-%{majorminor}.*
+%doc %{_mandir}/man1/gst-typefind-%{majorminor}.*
+
+%{_datadir}/bash-completion/completions/gst-inspect-1.0
+%{_datadir}/bash-completion/completions/gst-launch-1.0
+%{_datadir}/bash-completion/helpers/gst
+
+%files devel
+%dir %{_includedir}/gstreamer-%{majorminor}
+%dir %{_includedir}/gstreamer-%{majorminor}/gst
+%dir %{_includedir}/gstreamer-%{majorminor}/gst/base
+%dir %{_includedir}/gstreamer-%{majorminor}/gst/check
+%dir %{_includedir}/gstreamer-%{majorminor}/gst/controller
+%dir %{_includedir}/gstreamer-%{majorminor}/gst/net
+%{_includedir}/gstreamer-%{majorminor}/gst/*.h
+%{_includedir}/gstreamer-%{majorminor}/gst/base/*.h
+%{_includedir}/gstreamer-%{majorminor}/gst/check/*.h
+%{_includedir}/gstreamer-%{majorminor}/gst/controller/*.h
+%{_includedir}/gstreamer-%{majorminor}/gst/net/*.h
+
+%{_libdir}/libgstreamer-%{majorminor}.so
+%{_libdir}/libgstbase-%{majorminor}.so
+%{_libdir}/libgstcheck-%{majorminor}.so
+%{_libdir}/libgstcontroller-%{majorminor}.so
+%{_libdir}/libgstnet-%{majorminor}.so
+
+%{_datadir}/gir-1.0/Gst-%{majorminor}.gir
+%{_datadir}/gir-1.0/GstBase-%{majorminor}.gir
+%{_datadir}/gir-1.0/GstCheck-%{majorminor}.gir
+%{_datadir}/gir-1.0/GstController-%{majorminor}.gir
+%{_datadir}/gir-1.0/GstNet-%{majorminor}.gir
+
+%{_datadir}/aclocal/gst-element-check-%{majorminor}.m4
+
+%dir %{_datadir}/gstreamer-%{majorminor}/gdb/
+%{_datadir}/gstreamer-%{majorminor}/gdb/
+%{_datadir}/gdb/auto-load/
+
+%{_libdir}/pkgconfig/gstreamer-%{majorminor}.pc
+%{_libdir}/pkgconfig/gstreamer-base-%{majorminor}.pc
+%{_libdir}/pkgconfig/gstreamer-controller-%{majorminor}.pc
+%{_libdir}/pkgconfig/gstreamer-check-%{majorminor}.pc
+%{_libdir}/pkgconfig/gstreamer-net-%{majorminor}.pc
+
+%if 0
+%files devel-docs
+%doc %{_datadir}/gtk-doc/html/gstreamer-%{majorminor}
+%doc %{_datadir}/gtk-doc/html/gstreamer-libs-%{majorminor}
+%doc %{_datadir}/gtk-doc/html/gstreamer-plugins-%{majorminor}
+%endif
+
+
+%changelog
+* Wed Apr 12 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.1-2
+- Bump for rebuild
+
+* Tue Mar 21 2023 Wim Taymans <wtaymans@redhat.com> - 1.22.1-1
+- Update to 1.22.1
+
+* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.18.4-4
+- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
+ Related: rhbz#1991688
+
+* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.18.4-3
+- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
+
+* Tue Apr 6 2021 Wim Taymans <wtaymans@redhat.com> - 1.18.4-2
+- Fix build options to disable libunwind and libdw
+
+* Tue Mar 16 2021 Wim Taymans <wtaymans@redhat.com> - 1.18.4-1
+- Update to 1.18.4
+
+* Tue Feb 23 2021 Wim Taymans <wtaymans@redhat.com> - 1.18.2-3
+- Use libunwind only on fedora
+
+* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.18.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
+
+* Thu Dec 10 2020 Wim Taymans <wtaymans@redhat.com> - 1.18.2-1
+- Update to 1.18.2
+
+* Fri Oct 30 2020 Wim Taymans <wtaymans@redhat.com> - 1.18.1-1
+- Update to 1.18.1
+
+* Tue Sep 8 2020 Wim Taymans <wtaymans@redhat.com> - 1.18.0-1
+- Update to 1.18.0
+
+* Fri Aug 21 2020 Wim Taymans <wtaymans@redhat.com> - 1.17.90-1
+- Update to 1.17.90
+
+* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.17.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Mon Jul 6 2020 Wim Taymans <wtaymans@redhat.com> - 1.17.2-1
+- Update to 1.17.2
+
+* Mon Jun 22 2020 Wim Taymans <wtaymans@redhat.com> - 1.17.1-2
+- Enable debug again
+
+* Mon Jun 22 2020 Wim Taymans <wtaymans@redhat.com> - 1.17.1-1
+- Update to 1.17.1
+- Update to meson build
+- Disable docs because it needs Hotdoc, which is not in Fedora yet
+- remove BuildRequires: for gtk-doc and autoconf related things
+- Add BuildRequires: for libunwind-devel, elfutils-devel, bash-completion
+
+* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.16.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Thu Jan 2 2020 Wim Taymans <wtaymans@redhat.com> - 1.16.2-1
+- Update to 1.16.2
+
+* Tue Sep 24 2019 Wim Taymans <wtaymans@redhat.com> - 1.16.1-1
+- Update to 1.16.1
+- Enable libcap for the ptp helper permissions
+
+* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.16.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Tue Apr 23 2019 Wim Taymans <wtaymans@redhat.com> - 1.16.0-1
+- Update to 1.16.0
+
+* Fri Mar 01 2019 Wim Taymans <wtaymans@redhat.com> - 1.15.2-1
+- Update to 1.15.2
+
+* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.15.1-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Mon Jan 28 2019 Wim Taymans <wtaymans@redhat.com> - 1.15.1-2
+- Rebuild for dependencies
+
+* Fri Jan 25 2019 Wim Taymans <wtaymans@redhat.com> - 1.15.1-1
+- Update to 1.15.1
+
+* Wed Oct 03 2018 Wim Taymans <wtaymans@redhat.com> - 1.14.4-1
+- Update to 1.14.4
+
+* Tue Sep 18 2018 Wim Taymans <wtaymans@redhat.com> - 1.14.3-1
+- Update to 1.14.3
+
+* Mon Jul 23 2018 Wim Taymans <wtaymans@redhat.com> - 1.14.2-1
+- Update to 1.14.2
+
+* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.14.1-6
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
+* Fri Jun 15 2018 Wim Taymans <wtaymans@redhat.com> - 1.14.1-5
+- Remove xfig build dependency. It has not been needed since
+ version 1.2.0
+
+* Wed Jun 06 2018 Bastien Nocera <bnocera@redhat.com> - 1.14.1-4
+- Remove -Wcast-align fix patch, it's not complete
+
+* Wed Jun 06 2018 Bastien Nocera <bnocera@redhat.com> - 1.14.1-3
+- Add test patch to shut -Wcast-align warnings
+
+* Fri May 25 2018 Wim Taymans <wtaymans@redhat.com> - 1.14.1-2
+- Update gstreamer1.prov file: Only scan in plugin directories
+ and relax file name and type. (#1581325)
+
+* Mon May 21 2018 Wim Taymans <wtaymans@redhat.com> - 1.14.1-1
+- Update to 1.14.1
+- Remove obsolete patch
+
+* Tue Mar 20 2018 Wim Taymans <wtaymans@redhat.com> - 1.14.0-1
+- Update to 1.14.0
+
+* Wed Mar 14 2018 Wim Taymans <wtaymans@redhat.com> - 1.13.91-1
+- Update to 1.13.91
+- fix doc dependencies
+
+* Mon Mar 05 2018 Wim Taymans <wtaymans@redhat.com> - 1.13.90-1
+- Update to 1.13.90
+
+* Fri Feb 23 2018 Rex Dieter <rdieter@fedoraproject.org> - 1.13.1-3
+- %%build: --disable-fatal-warnings --disable-silent-rules
+- fix rpath harder
+- use %%ldconfig_scriptlets, %%make_build, %%make_install
+- -devel: tighten deps with %%{_isa}
+
+* Fri Feb 23 2018 Rex Dieter <rdieter@fedoraproject.org> - 1.13.1-2
+- -devel: Conflicts: gstreamer1-plugins-bad-free-devel < 1.13
+
+* Thu Feb 22 2018 Wim Taymans <wtaymans@redhat.com> - 1.13.1-1
+- Update to 1.13.1
+- Update rpm patch
+- Fix compiler error
+
+* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.4-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Mon Dec 11 2017 Wim Taymans <wtaymans@redhat.com> - 1.12.4-1
+- Update to 1.12.4
+
+* Fri Oct 13 2017 Troy Dawson <tdawson@redhat.com> - 1.12.3-2
+- Cleanup spec file conditionals
+
+* Tue Sep 19 2017 Wim Taymans <wtaymans@redhat.com> - 1.12.3-1
+- Update to 1.12.3
+
+* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.2-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
+
+* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.12.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Mon Jul 17 2017 Wim Taymans <wtaymans@redhat.com> - 1.12.2-1
+- Update to 1.12.2
+
+* Tue Jun 20 2017 Wim Taymans <wtaymans@redhat.com> - 1.12.1-1
+- Update to 1.12.1
+- Add gst-stats manpage
+
+* Wed May 10 2017 Wim Taymans <wtaymans@redhat.com> - 1.12.0-1
+- Update to 1.12.0
+
+* Fri Apr 28 2017 Wim Taymans <wtaymans@redhat.com> - 1.11.91-1
+- Update to 1.11.91
+
+* Tue Apr 11 2017 Wim Taymans <wtaymans@redhat.com> - 1.11.90-1
+- Update to 1.11.90
+
+* Thu Mar 30 2017 Wim Taymans <wtaymans@redhat.com> - 1.11.2-2
+- rebuild for https://github.com/UnitedRPMs/packages/issues/106#issuecomment-290404434
+
+* Fri Feb 24 2017 Wim Taymans <wtaymans@redhat.com> - 1.11.2-1
+- Update to 1.11.2
+
+* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.11.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
+- fix build
+
+* Fri Jan 13 2017 Wim Taymans <wtaymans@redhat.com> - 1.11.1-1
+- Update to 1.11.1
+- update rpm patch
+
+* Mon Dec 05 2016 Wim Taymans <wtaymans@redhat.com> - 1.10.2-1
+- Update to 1.10.2
+
+* Mon Nov 28 2016 Wim Taymans <wtaymans@redhat.com> - 1.10.1-1
+- Update to 1.10.1
+
+* Thu Nov 3 2016 Wim Taymans <wtaymans@redhat.com> - 1.10.0-1
+- Update to 1.10.0
+
+* Fri Sep 30 2016 Wim Taymans <wtaymans@redhat.com> - 1.9.90-1
+- Update to 1.9.90
+- remove obsolete patches
+
+* Thu Sep 8 2016 Peter Robinson <pbrobinson@fedoraproject.org> 1.9.2-3
+- fix build on Power64
+
+* Thu Sep 01 2016 Wim Taymans <wtaymans@redhat.com> - 1.9.2-2
+- fix build on s390x
+
+* Thu Sep 01 2016 Wim Taymans <wtaymans@redhat.com> - 1.9.2-1
+- Update to 1.9.2
+- gstconfig.h was moved to normal include dir
+
+* Thu Jul 07 2016 Wim Taymans <wtaymans@redhat.com> - 1.9.1-1
+- Update to 1.9.1
+
+* Thu Jun 09 2016 Wim Taymans <wtaymans@redhat.com> - 1.8.2-1
+- Update to 1.8.2
+
+* Thu Apr 21 2016 Wim Taymans <wtaymans@redhat.com> - 1.8.1-1
+- Update to 1.8.1
+
+* Thu Mar 24 2016 Wim Taymans <wtaymans@redhat.com> - 1.8.0-1
+- Update to 1.8.0
+
+* Wed Mar 16 2016 Wim Taymans <wtaymans@redhat.com> - 1.7.91-1
+- Update to 1.7.91
+
+* Wed Mar 02 2016 Wim Taymans <wtaymans@redhat.com> - 1.7.90-1
+- Update to 1.7.90
+
+* Fri Feb 19 2016 Wim Taymans <wtaymans@redhat.com> - 1.7.2-1
+- Update to 1.7.2
+
+* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
+
+* Mon Jan 4 2016 Wim Taymans <wtaymans@redhat.com> - 1.7.1-1
+- Update to 1.7.1
+- update rpm inspect patch
+- add gst-stats
+- add core traces
+
+* Tue Dec 15 2015 Wim Taymans <wtaymans@redhat.com> - 1.6.2-1
+- Update to 1.6.2
+
+* Mon Nov 2 2015 Wim Taymans <wtaymans@redhat.com> - 1.6.1-1
+- Update to 1.6.1
+
+* Sat Sep 26 2015 Kalev Lember <klember@redhat.com> - 1.6.0-2
+- Remove lib64 rpaths from newly added binaries
+
+* Sat Sep 26 2015 Kalev Lember <klember@redhat.com> - 1.6.0-1
+- Update to 1.6.0
+- Use license macro for COPYING
+
+* Mon Sep 21 2015 Wim Taymans <wtaymans@redhat.com> - 1.5.91-1
+- Update to 1.5.91
+
+* Wed Aug 19 2015 Wim Taymans <wtaymans@redhat.com> - 1.5.90-1
+- Update to 1.5.90
+
+* Thu Jun 25 2015 Wim Taymans <wtaymans@redhat.com> - 1.5.2-1
+- Update to 1.5.2
+
+* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+
+* Tue May 5 2015 Wim Taymans <wtaymans@redhat.com> - 1.5.1-1
+- Update to 1.5.1
+- add new bash-completion scripts
+- gstconfig.h got moved
+
+* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1.4.5-2
+- Rebuilt for Fedora 23 Change
+ https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
+
+* Wed Jan 28 2015 Bastien Nocera <bnocera@redhat.com> 1.4.5-1
+- Update to 1.4.5
+
+* Fri Nov 14 2014 Kalev Lember <kalevlember@gmail.com> - 1.4.4-1
+- Update to 1.4.4
+
+* Mon Sep 22 2014 Wim Taymans <wtaymans@redhat.com> - 1.4.2-1
+- Update to 1.4.2
+
+* Fri Aug 29 2014 Wim Taymans <wtaymans@redhat.com> - 1.4.1-1
+- Update to 1.4.1
+
+* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
+
+* Tue Jul 22 2014 Kalev Lember <kalevlember@gmail.com> - 1.4.0-2
+- Rebuilt for gobject-introspection 1.41.4
+
+* Tue Jul 22 2014 Wim Taymans <wtaymans@redhat.com> - 1.4.0-1
+- Update to 1.4.0
+
+* Fri Jul 11 2014 Wim Taymans <wtaymans@redhat.com> - 1.3.91-1
+- Update to 1.3.91
+
+* Mon Jun 30 2014 Richard Hughes <rhughes@redhat.com> - 1.3.90-1
+- Update to 1.3.90
+
+* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Sun Apr 20 2014 Brian Pepple <bpepple@fedoraproject.org> - 1.2.4-1
+- Update to 1.2.4.
+
+* Mon Feb 10 2014 Brian Pepple <bpepple@fedoraproject.org> - 1.2.3-1
+- Update to 1.2.3.
+
+* Fri Dec 27 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.2.2-1
+- Update to 1.2.2.
+
+* Mon Nov 11 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.2.1-1
+- Update to 1.2.1.
+
+* Tue Sep 24 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.2.0-1
+- Update to 1.2.0.
+
+* Thu Sep 19 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.1.90-1
+- Update to 1.1.90.
+
+* Wed Aug 28 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.1.4-1
+- Update to 1.1.4.
+
+* Mon Jul 29 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.1.3-1
+- Update to 1.1.3.
+
+* Fri Jul 12 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.1.2-1
+- Update to 1.1.2.
+
+* Fri Apr 26 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.0.7-1
+- Update to 1.0.7.
+
+* Wed Mar 27 2013 Adam Jackson <ajax@redhat.com>
+- Tweak BRs for RHEL
+
+* Fri Mar 22 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.0.6-1
+- Update to 1.0.6.
+- Remove BR on PyXML.
+
+* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Tue Jan 8 2013 Brian Pepple <bpepple@fedoraproject.org> - 1.0.5-1
+- Update to 1.0.5.
+
+* Wed Dec 19 2012 Brian Pepple <bpepple@fedoraproject.org> - 1.0.4-1
+- Update to 1.0.4
+
+* Wed Nov 21 2012 Brian Pepple <bpepple@fedoraproject.org> - 1.0.3-1
+- Update to 1.0.3
+
+* Thu Oct 25 2012 Brian Pepple <bpepple@fedoraproject.org> - 1.0.2-1
+- Update to 1.0.2.
+
+* Sun Oct 7 2012 Brian Pepple <bpepple@fedoraproject.org> - 1.0.1-1
+- Update to 1.0.1
+
+* Mon Oct 1 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.0.0-2
+- Enable verbose build
+
+* Mon Sep 24 2012 Brian Pepple <bpepple@fedoraproject.org> - 1.0.0-1
+- Update to 1.0.0.
+
+* Wed Sep 19 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.99-1
+- Update to 0.11.99
+
+* Fri Sep 14 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.94-1
+- Update to 0.11.94.
+
+* Sat Sep 8 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.93-2
+- Add patch to gst-inspect to generate RPM provides
+- Add RPM find-provides script
+
+* Tue Aug 14 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.93-1
+- Update to 0.11.93.
+- Bump minimum version of glib2 needed.
+
+* Fri Aug 3 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.92-2
+- Use %%global instead of %%define.
+- Remove rpath.
+
+* Tue Jul 17 2012 Brian Pepple <bpepple@fedoraproject.org> - 0.11.92-1
+- Initial Fedora spec file.
+