summaryrefslogtreecommitdiff
path: root/compiler-rt.spec
diff options
context:
space:
mode:
Diffstat (limited to 'compiler-rt.spec')
-rw-r--r--compiler-rt.spec451
1 files changed, 451 insertions, 0 deletions
diff --git a/compiler-rt.spec b/compiler-rt.spec
new file mode 100644
index 0000000..2e84fc3
--- /dev/null
+++ b/compiler-rt.spec
@@ -0,0 +1,451 @@
+%bcond_with snapshot_build
+
+%if %{with snapshot_build}
+# Unlock LLVM Snapshot LUA functions
+%{llvm_sb_verbose}
+%{llvm_sb}
+%endif
+
+%global toolchain clang
+
+# Opt out of https://fedoraproject.org/wiki/Changes/fno-omit-frame-pointer
+# https://bugzilla.redhat.com/show_bug.cgi?id=2158587
+%undefine _include_frame_pointers
+
+%bcond_with compat_build
+
+%global maj_ver 18
+%global min_ver 1
+%global patch_ver 6
+#global rc_ver 4
+%if %{with snapshot_build}
+%global maj_ver %{llvm_snapshot_version_major}
+%global min_ver %{llvm_snapshot_version_minor}
+%global patch_ver %{llvm_snapshot_version_patch}
+%undefine rc_ver
+%endif
+%global compiler_rt_version %{maj_ver}.%{min_ver}.%{patch_ver}
+
+%global crt_srcdir compiler-rt-%{compiler_rt_version}%{?rc_ver:rc%{rc_ver}}.src
+
+%if %{with compat_build}
+%global pkg_name compiler-rt%{maj_ver}
+%else
+%global pkg_name compiler-rt
+%endif
+
+# see https://sourceware.org/bugzilla/show_bug.cgi?id=25271
+%global optflags %(echo %{optflags} -D_DEFAULT_SOURCE)
+
+# see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=93615
+%global optflags %(echo %{optflags} -Dasm=__asm__)
+
+Name: %{pkg_name}
+Version: %{compiler_rt_version}%{?rc_ver:~rc%{rc_ver}}%{?llvm_snapshot_version_suffix:~%{llvm_snapshot_version_suffix}}
+Release: 2%{?dist}
+Summary: LLVM "compiler-rt" runtime libraries
+
+License: Apache-2.0 WITH LLVM-exception OR NCSA OR MIT
+URL: http://llvm.org
+%if %{with snapshot_build}
+Source0: %{llvm_snapshot_source_prefix}compiler-rt-%{llvm_snapshot_yyyymmdd}.src.tar.xz
+%{llvm_snapshot_extra_source_tags}
+%else
+Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz
+Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{compiler_rt_version}%{?rc_ver:-rc%{rc_ver}}/%{crt_srcdir}.tar.xz.sig
+Source2: release-keys.asc
+%endif
+
+Patch0: 0001-compiler-rt-Fix-FLOAT16-feature-detection.patch
+
+BuildRequires: clang
+BuildRequires: cmake
+BuildRequires: ninja-build
+BuildRequires: python3
+# We need python3-devel for %%py3_shebang_fix
+BuildRequires: python3-devel
+BuildRequires: llvm-devel = %{version}
+BuildRequires: llvm-cmake-utils = %{version}
+BuildRequires: zlib-devel
+
+# For gpg source verification
+BuildRequires: gnupg2
+
+Requires: clang-resource-filesystem%{?isa} = %{version}
+Provides: %{name}(major) = %{maj_ver}
+
+%description
+The compiler-rt project is a part of the LLVM project. It provides
+implementation of the low-level target-specific hooks required by
+code generation, sanitizer runtimes and profiling library for code
+instrumentation, and Blocks C language extension.
+
+%prep
+%{gpgverify} --keyring='%{SOURCE2}' --signature='%{SOURCE1}' --data='%{SOURCE0}'
+%autosetup -n %{crt_srcdir} -p2
+
+# compiler-rt does not allow configuring LLVM_COMMON_CMAKE_UTILS.
+ln -s %{_datadir}/llvm/cmake ../cmake
+
+%py3_shebang_fix lib/hwasan/scripts/hwasan_symbolize
+
+%build
+# Copy CFLAGS into ASMFLAGS, so -fcf-protection is used when compiling assembly files.
+export ASMFLAGS=$CFLAGS
+
+%cmake -GNinja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_MODULE_PATH=%{_libdir}/cmake/llvm \
+ -DCMAKE_SKIP_RPATH:BOOL=ON \
+ -DCOMPILER_RT_INSTALL_PATH=%{_prefix}/lib/clang/%{maj_ver} \
+ -DLLVM_ENABLE_PER_TARGET_RUNTIME_DIR=ON \
+ \
+%if %{with snapshot_build}
+ -DLLVM_VERSION_SUFFIX="%{llvm_snapshot_version_suffix}" \
+%endif
+ \
+%if 0%{?__isa_bits} == 64
+ -DLLVM_LIBDIR_SUFFIX=64 \
+%else
+ -DLLVM_LIBDIR_SUFFIX= \
+%endif
+ -DCOMPILER_RT_INCLUDE_TESTS:BOOL=OFF # could be on?
+
+%cmake_build
+
+%install
+
+%cmake_install
+%ifarch ppc64le
+# Fix install path on ppc64le so that the directory name matches the triple used
+# by clang.
+mv %{buildroot}%{_prefix}/lib/clang/%{maj_ver}/lib/powerpc64le-redhat-linux-gnu %{buildroot}%{_prefix}/lib/clang/%{maj_ver}/lib/ppc64le-redhat-linux-gnu
+%endif
+%ifarch %{ix86}
+# Fix install path on ix86 so that the directory name matches the triple used
+# by clang on both actual ix86 and on x86_64 with -m32:
+%if "%{_target_cpu}" != "i386"
+ln -s i386-redhat-linux-gnu %{buildroot}%{_prefix}/lib/clang/%{maj_ver}/lib/%{_target_cpu}-redhat-linux-gnu
+%endif
+%endif
+
+%check
+#%%cmake_build --target check-compiler-rt
+
+%files
+%license LICENSE.TXT
+%ifarch x86_64 aarch64 riscv64
+%{_prefix}/lib/clang/%{maj_ver}/bin/*
+%endif
+%{_prefix}/lib/clang/%{maj_ver}/include/*
+%{_prefix}/lib/clang/%{maj_ver}/lib/*
+%{_prefix}/lib/clang/%{maj_ver}/share/*
+#%ifarch x86_64 aarch64
+#{_bindir}/hwasan_symbolize
+#%endif
+
+%changelog
+* Tue Jun 11 2024 Nikita Popov <npopov@redhat.com> - 18.1.6-2
+- Rebuild with new clang
+
+%{?llvm_snapshot_changelog_entry}
+
+* Sun Jun 02 2024 Konrad Kleine <kkleine@redhat.com> - 18.1.6-1
+- Update to 18.1.6
+
+* Mon Dec 11 2023 Timm Bäder <tbaeder@redhat.com> - 17.0.6-1
+- Update to 17.0.6
+
+* Wed Oct 04 2023 Timm Bäder <tbaeder@redhat.com> - 17.0.1-1
+- Update to 17.0.1
+
+* Tue Aug 29 2023 Tom Stellard <tstellar@redhat.com> - 16.0.6-2
+- Fix FLOAT16 detection
+
+* Wed Jul 05 2023 Nikita Popov <npopov@redhat.com> - 16.0.6-1
+- Update to LLVM 16.0.6
+
+* Wed Apr 19 2023 Nikita Popov <npopov@redhat.com> - 16.0.1-1
+- Update to LLVM 16.0.1
+
+* Tue Jan 17 2023 Konrad Kleine <kkleine@redhat.com> - 15.0.7-1
+- Update to LLVM 15.0.7
+
+* Fri Dec 09 2022 Konrad Kleine <kkleine@redhat.com> - 15.0.6-1
+- Update to LLVM 15.0.6
+
+* Thu Sep 29 2022 Konrad Kleine <kkleine@redhat.com> - 15.0.1-1
+- Update to LLVM 15.0.1
+
+* Wed Jul 20 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.6-1
+- 14.0.6 Release
+
+* Wed Jun 22 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.5-1
+- 14.0.5 Release
+
+* Thu May 12 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-2
+- Disable execstack on s390x
+
+* Mon Apr 25 2022 Timm Bäder <tbaeder@redhat.com> - 14.0.0-1
+- 14.0.0 Release
+
+* Thu Feb 03 2022 Tom Stellard <tstellar@redhat.com> - 13.0.1-1
+- 13.0.1 Release
+
+* Tue Oct 12 2021 Timm Bäder <tbaeder@redhat.com> - 13.0.0-1
+- 13.0.0 Release
+- skip rpath
+
+* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 12.0.1-3
+- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
+ Related: rhbz#1991688
+
+* Fri Aug 6 2021 Florian Weimer <fweimer@redhat.com> - 12.0.1-2
+- Rebuild to pick up new build flags from redhat-rpm-config (#1984652)
+
+* Tue Jul 13 2021 Tom Stellard <tstellar@redhat.com> - 12.0.1-1
+- 12.0.1 Release
+
+* Fri Apr 16 2021 Tom Stellard <tstellar@redhat.com> - 12.0.0-1
+- 12.0.0 Release
+
+* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 11.1.0-0.3.rc2
+- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
+
+* Fri Jan 22 2021 Serge Guelton - 11.1.0-0.2.rc2
+- 11.1.0-rc2 release
+
+* Thu Jan 14 2021 Serge Guelton - 11.1.0-0.1.rc1
+- 11.1.0-rc1 release
+
+* Wed Jan 06 2021 Serge Guelton - 11.0.1-3
+- LLVM 11.0.1 final
+
+* Tue Dec 22 2020 sguelton@redhat.com - 11.0.1-2.rc2
+- llvm 11.0.1-rc2
+
+* Tue Dec 01 2020 sguelton@redhat.com - 11.0.1-1.rc1
+- llvm 11.0.1-rc1
+
+* Thu Oct 29 2020 Tom Stellard <tstellar@redhat.com> - 11.0.0-2
+- Add dependency on clang-resource-filesystem
+
+* Thu Oct 15 2020 sguelton@redhat.com - 11.0.0-1
+- Fix NVR
+
+* Mon Oct 12 2020 sguelton@redhat.com - 11.0.0-0.5
+- llvm 11.0.0 - final release
+
+* Thu Oct 08 2020 sguelton@redhat.com - 11.0.0-0.4.rc6
+- 11.0.0-rc6
+
+* Fri Oct 02 2020 sguelton@redhat.com - 11.0.0-0.3.rc5
+- 11.0.0-rc5 Release
+
+* Sun Sep 27 2020 sguelton@redhat.com - 11.0.0-0.2.rc3
+- Fix NVR
+
+* Thu Sep 24 2020 sguelton@redhat.com - 11.0.0-0.1.rc3
+- 11.0.0-rc3 Release
+
+* Tue Sep 01 2020 sguelton@redhat.com - 11.0.0-0.1.rc2
+- 11.0.0-rc2 Release
+
+* Mon Aug 10 2020 Tom Stellard <tstellar@redhat.com> - 11.0.0-0.1.rc1
+- 11.0.0-rc1 Release
+
+* Wed Jul 29 2020 sguelton@redhat.com - 10.0.0-9
+- use %%license macro
+
+* Mon Jul 27 2020 sguelton@redhat.com - 10.0.0-8
+- Remove now obsolete debuginfo package limitation
+
+* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 10.0.0-7
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Mon Jul 20 2020 sguelton@redhat.com - 10.0.0-6
+- Use modern cmake macros
+
+* Wed Jul 15 2020 sguelton@redhat.com - 10.0.0-5
+- Fix multilib runtime links, see rhbz#1855379
+
+* Wed Jul 15 2020 sguelton@redhat.com - 10.0.0-4
+- Correctly use gpg verification
+
+* Thu Jul 09 2020 Tom Stellard <tstellar@redhat.com> - 10.0.0-3
+- Drop dependency on llvm-static
+
+* Thu Jun 11 2020 sguelton@redhat.com - 10.0.0-2
+- Fix msan compilation warnings, see af38074874c605f9 upstream
+
+* Mon Mar 30 2020 sguelton@redhat.com - 10.0.0-1
+- 10.0.0 final
+
+* Wed Mar 25 2020 sguelton@redhat.com - 10.0.0-0.6.rc6
+- 10.0.0 rc6
+
+* Fri Mar 20 2020 sguelton@redhat.com - 10.0.0-0.5.rc5
+- 10.0.0 rc5
+
+* Sun Mar 15 2020 sguelton@redhat.com - 10.0.0-0.4.rc4
+- 10.0.0 rc4
+
+* Thu Mar 5 2020 sguelton@redhat.com - 10.0.0-0.3.rc3
+- 10.0.0 rc3
+
+* Fri Feb 14 2020 sguelton@redhat.com - 10.0.0-0.1.rc2
+- 10.0.0 rc2
+
+* Wed Feb 12 2020 sguelton@redhat.com - 10.0.0-0.2.rc1
+- Ship blacklist files in the proper directory, see rhbz#1794936
+
+* Fri Jan 31 2020 sguelton@redhat.com - 10.0.0-0.1.rc1
+- 10.0.0 rc1
+
+* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 9.0.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Thu Sep 19 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-1
+- 9.0.0 Release
+
+* Thu Aug 22 2019 Tom Stellard <tstellar@redhat.com> - 9.0.0-0.1.rc3
+- 9.0.0-rc3 Release
+
+* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 8.0.0-2.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Tue Jun 18 2019 sguelton@redhat.com - 8.0.0-2
+- Fix rhbz#1678240
+
+* Wed Mar 20 2019 sguelton@redhat.com - 8.0.0-1
+- 8.0.0 final
+
+* Tue Mar 12 2019 sguelton@redhat.com - 8.0.0-0.4.rc4
+- 8.0.0 Release candidate 4
+
+* Mon Mar 4 2019 sguelton@redhat.com - 8.0.0-0.3.rc3
+- 8.0.0 Release candidate 3
+
+* Fri Feb 22 2019 sguelton@redhat.com - 8.0.0-0.2.rc2
+- 8.0.0 Release candidate 2
+
+* Mon Feb 11 2019 sguelton@redhat.com - 8.0.0-0.1.rc1
+- 8.0.0 Release candidate 1
+
+* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.1-2.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Fri Jan 18 2019 sguelton@redhat.com - 7.0.1-2
+- GCC-9 compatibility
+
+* Mon Dec 17 2018 sguelton@redhat.com - 7.0.1-1
+- 7.0.1 Release
+
+* Tue Dec 04 2018 sguelton@redhat.com - 7.0.0-2
+- Ensure rpmlint passes on specfile
+
+* Mon Sep 24 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-1
+- 7.0.0-1 Release
+
+* Wed Sep 12 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.4.rc3
+- 7.0.0-rc3 Release
+
+* Fri Sep 07 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.3.rc1
+- Use python3 for build scripts
+
+* Thu Sep 06 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.2.rc1
+- Drop BuildRequires: python2
+
+* Tue Aug 14 2018 Tom Stellard <tstellar@redhat.com> - 7.0.0-0.1.rc1
+- 7.0.0-rc1 Release
+
+* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
+* Thu Jun 28 2018 Tom Stellard <tstellar@redhat.com> - 6.0.1-1
+- 6.0.1 Release
+
+* Mon Mar 19 2018 Iryna Shcherbina <ishcherb@redhat.com> - 6.0.0-2
+- Update Python 2 dependency declarations to new packaging standards
+ (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
+
+* Thu Mar 08 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-1
+- 6.0.0 Release
+
+* Tue Feb 13 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-0.4.rc2
+- 6.0.0-rc2 Release
+
+* Tue Feb 13 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-0.3.rc1
+- Fix build on AArch64
+
+* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.0.0-0.2.rc1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Thu Jan 25 2018 Tom Stellard <tstellar@redhat.com> - 6.0.0-0.1.rc1
+- 6.0.0-rc1 Release
+
+* Wed Jan 17 2018 Tom Stellard <tstellar@redhat.com> - 5.0.1-2
+- Build libFuzzer with gcc
+
+* Wed Dec 20 2017 Tom Stellard <tstellar@redhat.com> - 5.0.1-1
+- 5.0.1 Release
+
+* Fri Oct 13 2017 Tom Stellard <tstellar@redhat.com> - 5.0.0-1
+- 5.0.0 Release
+
+* Mon Sep 25 2017 Tom Stellard <tstellar@redhat.com> - 4.0.1-6
+- Fix AArch64 build with glibc 2.26
+
+* Tue Sep 12 2017 Tom Stellard <tstellar@redhat.com> - 4.0.1-5
+- Package libFuzzer
+
+* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.1-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
+
+* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.1-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Fri Jun 23 2017 Tom Stellard <tstelar@redhat.com> - 4.0.1-2
+- Fix build with newer glibc
+
+* Fri Jun 23 2017 Tom Stellard <tstellar@redhat.com> - 4.0.1-1
+- 4.0.1 Release
+
+* Tue Mar 14 2017 Tom Stellard <tstellar@redhat.com> - 4.0.0-1
+- compiler-rt 4.0.0 Final Release
+
+* Thu Mar 02 2017 Dave Airlie <airlied@redhat.com> - 3.9.1-1
+- compiler-rt 3.9.1
+
+* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.9.0-4
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
+
+* Mon Nov 21 2016 Dan Horák <dan[at]danny.cz> - 3.9.0-3
+- disable debuginfo on s390(x)
+
+* Wed Nov 02 2016 Dave Airlie <airlied@redhat.com> - 3.9.0-2
+- build for new arches.
+
+* Wed Oct 26 2016 Dave Airlie <airlied@redhat.com> - 3.9.0-1
+- compiler-rt 3.9.0 final release
+
+* Mon May 2 2016 Tom Callaway <spot@fedoraproject.org> 3.8.0-2
+- make symlinks to where the linker thinks these libs are
+
+* Thu Mar 10 2016 Dave Airlie <airlied@redhat.com> 3.8.0-1
+- compiler-rt 3.8.0 final release
+
+* Thu Mar 03 2016 Dave Airlie <airlied@redhat.com> 3.8.0-0.2
+- compiler-rt 3.8.0rc3
+
+* Thu Feb 18 2016 Dave Airlie <airlied@redhat.com> - 3.8.0-0.1
+- compiler-rt 3.8.0rc2
+
+* Fri Feb 05 2016 Dave Airlie <airlied@redhat.com> 3.7.1-3
+- fix compiler-rt paths - from rwindz0@gmail.com - #1304605
+
+* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.7.1-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
+
+* Tue Oct 06 2015 Jan Vcelak <jvcelak@fedoraproject.org> 3.7.0-100
+- initial version using cmake build system