summaryrefslogtreecommitdiff
path: root/lizardfs.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-06 14:02:10 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-06 14:02:10 +0000
commit1b5f52e22f377cd7fa2bffab2ae1cefdc1c43fe2 (patch)
treecd455860dfaed53912bf8e4a99a084b84b94ac8f /lizardfs.spec
parentaac450e024c595ebf20cee258c114444cabacaf0 (diff)
automatic import of lizardfsopeneuler20.03
Diffstat (limited to 'lizardfs.spec')
-rw-r--r--lizardfs.spec565
1 files changed, 338 insertions, 227 deletions
diff --git a/lizardfs.spec b/lizardfs.spec
index 3e8df67..d1956b6 100644
--- a/lizardfs.spec
+++ b/lizardfs.spec
@@ -1,33 +1,58 @@
-%define distro @DISTRO@
-
-Summary: LizardFS - distributed, fault tolerant file system
-Name: lizardfs
-Version: 3.12.0
-Release: 0
-License: GPL v3
-Group: System Environment/Daemons
-URL: http://www.lizardfs.org/
-Source: https://github.com/lizardfs/lizardfs/archive/refs/tags/v%{version}.tar.gz
-BuildRequires: fuse-devel
-BuildRequires: cmake
-BuildRequires: pkgconfig
-BuildRequires: zlib-devel
-BuildRequires: asciidoc
-BuildRequires: systemd
-BuildRequires: fmt
-BuildRequires: fmt-devel
-BuildRequires: spdlog
-BuildRequires: boost-devel
-BuildRequires: boost
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-
-%define liz_project mfs
-%define liz_group %{liz_project}
-%define liz_user %{liz_project}
-%define liz_datadir %{_localstatedir}/lib/%{liz_project}
-%define liz_confdir %{_sysconfdir}/%{liz_project}
-%define liz_limits_conf /etc/security/limits.d/10-lizardfs.conf
-%define liz_pam_d /etc/pam.d/lizardfs
+%define __cmake_in_source_build 1
+
+Name: lizardfs
+Summary: Distributed, fault tolerant file system
+Version: 3.12.0
+Release: 22%{?dist}
+# LizardFS is under GPLv3 while crcutil is under ASL 2.0 and there's one header,
+# src/common/coroutine.h, under the Boost license
+License: GPLv3 and ASL 2.0 and Boost
+URL: http://www.lizardfs.org/
+#Source: https://github.com/lizardfs/%{name}/archive/v%{version}/%{name}-%{version}.tar.gz
+Source0: https://tcm.chinaoss.net/%{name}-%{version}.tar.gz
+Source1: pam-lizardfs
+Source2: 95-lizardfs.conf
+
+# Use spdlog system library if available
+Patch0: 0001-Put-customized-spdlog-in-source-so-we-don-t-download.patch
+
+# Fix for building with GCC 8
+# See https://github.com/lizardfs/lizardfs/pull/677
+Patch1: 0001-Add-missing-header.patch
+
+# Use python 3 rather than python 2 for cgi server
+Patch2: lizardfs-3.12-cgi-py3.patch
+
+# Fix building with GCC13
+Patch3: 0003-gcc-13-missing-includes.patch
+
+BuildRequires: asciidoc
+BuildRequires: cmake
+BuildRequires: gcc
+BuildRequires: gcc-c++
+BuildRequires: make
+BuildRequires: pkgconfig
+BuildRequires: systemd
+
+BuildRequires: boost-devel
+BuildRequires: fuse-devel
+BuildRequires: Judy-devel
+BuildRequires: libdb-devel
+BuildRequires: pam-devel
+BuildRequires: systemd-devel
+BuildRequires: zlib-devel
+
+# libcrcutil is basically a copylib with a dead upstream
+# https://code.google.com/archive/p/crcutil/
+Provides: bundled(libcrcutil) = 1.0
+# spdlog is a copylib that lizardfs changes, so we can't use the system version
+Provides: bundled(spdlib) = 0.14.0
+
+%global liz_project mfs
+%global liz_group %{liz_project}
+%global liz_user %{liz_project}
+%global liz_datadir %{_localstatedir}/lib/%{liz_project}
+%global liz_confdir %{_sysconfdir}/%{liz_project}
%description
LizardFS is an Open Source, easy to deploy and maintain, distributed,
@@ -35,109 +60,75 @@ fault tolerant file system for POSIX compliant OSes.
LizardFS is a fork of MooseFS. For more information please visit
http://lizardfs.com
+
# Packages
############################################################
%package master
-Summary: LizardFS master server
-Group: System Environment/Daemons
-Requires(post): systemd-units
-Requires(preun): systemd-units
-Requires(postun): systemd-units
+Summary: LizardFS master server
+Requires: pam
+%{?systemd_requires}
%description master
-LizardFS master (metadata) server together with metarestore utility.
+LizardFS master (metadata) server together with metadata restore utility.
+
%package metalogger
-Summary: LizardFS metalogger server
-Group: System Environment/Daemons
-Requires(post): systemd-units
-Requires(preun): systemd-units
-Requires(postun): systemd-units
+Summary: LizardFS metalogger server
+%{?systemd_requires}
%description metalogger
LizardFS metalogger (metadata replication) server.
+
%package chunkserver
-Summary: LizardFS data server
-Group: System Environment/Daemons
-Requires(post): systemd-units
-Requires(preun): systemd-units
-Requires(postun): systemd-units
+Summary: LizardFS data server
+%{?systemd_requires}
%description chunkserver
LizardFS data server.
+
%package client
-Summary: LizardFS client
-Group: System Environment/Daemons
-Requires: fuse
-Requires: fuse-libs
-Requires: bash-completion
+Summary: LizardFS client
+Requires: fuse
%description client
-LizardFS client: mfsmount and mfstools.
-
-%package lib-client
-Summary: LizardFS client C/C++ library
-Group: Development/Libraries
+LizardFS client: mfsmount and lizardfs.
-%description lib-client
-LizardFS client library for C/C++ bindings.
-
-### Uncomment lines below to re-enable ganesha build.
-# %package nfs-ganesha
-# Summary: LizardFS plugin for nfs-ganesha
-# Group: System Environment/Libraries
-# Requires: lizardfs-lib-client
-#
-# %description nfs-ganesha
-# LizardFS fsal plugin for nfs-ganesha.
%package cgi
-Summary: LizardFS CGI Monitor
-Group: System Environment/Daemons
-Requires: python3
+Summary: LizardFS CGI Monitor
+Requires: python3
%description cgi
LizardFS CGI Monitor.
+
%package cgiserv
-Summary: Simple CGI-capable HTTP server to run LizardFS CGI Monitor
-Group: System Environment/Daemons
-Requires: %{name}-cgi = %{version}-%{release}
-Requires(post): systemd-units
-Requires(preun): systemd-units
-Requires(postun): systemd-units
+Summary: Simple CGI-capable HTTP server to run LizardFS CGI Monitor
+Requires: %{name}-cgi = %{version}-%{release}
+%{?systemd_requires}
%description cgiserv
Simple CGI-capable HTTP server to run LizardFS CGI Monitor.
+
%package adm
-Summary: LizardFS administration utility
-Group: System Environment/Daemons
+Summary: LizardFS administration utility
%description adm
LizardFS command line administration utility.
+
# Scriptlets - master
############################################################
%pre master
-if ! getent group %{liz_group} > /dev/null 2>&1 ; then
- groupadd --system %{liz_group}
-fi
-if ! getent passwd %{liz_user} > /dev/null 2>&1 ; then
- adduser --system -g %{liz_group} --no-create-home --home-dir %{liz_datadir} %{liz_user}
-fi
-if [ ! -f %{liz_limits_conf} ]; then
- echo "%{liz_user} soft nofile 10000" > %{liz_limits_conf}
- echo "%{liz_user} hard nofile 10000" >> %{liz_limits_conf}
- chmod 0644 %{liz_limits_conf}
-fi
-if [ ! -f %{liz_pam_d} ]; then
- echo "session required pam_limits.so" > %{liz_pam_d}
-fi
+getent group %{liz_group} >/dev/null || groupadd -r %{liz_group}
+getent passwd %{liz_user} >/dev/null || \
+ useradd -r -g %{liz_group} -d %{liz_datadir} -s /sbin/nologin \
+ -c "LizardFS System Account" %{liz_user}
exit 0
%post master
@@ -149,16 +140,15 @@ exit 0
%postun master
%systemd_postun_with_restart lizardfs-master.service
+
# Scriptlets - metalogger
############################################################
%pre metalogger
-if ! getent group %{liz_group} > /dev/null 2>&1 ; then
- groupadd --system %{liz_group}
-fi
-if ! getent passwd %{liz_user} > /dev/null 2>&1 ; then
- adduser --system -g %{liz_group} --no-create-home --home-dir %{liz_datadir} %{liz_user}
-fi
+getent group %{liz_group} >/dev/null || groupadd -r %{liz_group}
+getent passwd %{liz_user} >/dev/null || \
+ useradd -r -g %{liz_group} -d %{liz_datadir} -s /sbin/nologin \
+ -c "LizardFS System Account" %{liz_user}
exit 0
%post metalogger
@@ -170,24 +160,15 @@ exit 0
%postun metalogger
%systemd_postun_with_restart lizardfs-metalogger.service
+
# Scriptlets - chunkserver
############################################################
%pre chunkserver
-if ! getent group %{liz_group} > /dev/null 2>&1 ; then
- groupadd --system %{liz_group}
-fi
-if ! getent passwd %{liz_user} > /dev/null 2>&1 ; then
- adduser --system -g %{liz_group} --no-create-home --home-dir %{liz_datadir} %{liz_user}
-fi
-if [ ! -f %{liz_limits_conf} ]; then
- echo "%{liz_user} soft nofile 10000" > %{liz_limits_conf}
- echo "%{liz_user} hard nofile 10000" >> %{liz_limits_conf}
- chmod 0644 %{liz_limits_conf}
-fi
-if [ ! -f %{liz_pam_d} ]; then
- echo "session required pam_limits.so" > %{liz_pam_d}
-fi
+getent group %{liz_group} >/dev/null || groupadd -r %{liz_group}
+getent passwd %{liz_user} >/dev/null || \
+ useradd -r -g %{liz_group} -d %{liz_datadir} -s /sbin/nologin \
+ -c "LizardFS System Account" %{liz_user}
exit 0
%post chunkserver
@@ -199,6 +180,7 @@ exit 0
%postun chunkserver
%systemd_postun_with_restart lizardfs-chunkserver.service
+
# Scriptlets - CGI server
############################################################
@@ -211,36 +193,78 @@ exit 0
%postun cgiserv
%systemd_postun_with_restart lizardfs-cgiserv.service
+
# Prep, build, install, files...
############################################################
%prep
-%setup
+%autosetup -p1
+
+# Remove /usr/bin/env from bash scripts
+for i in src/tools/mfstools.sh src/master/mfsrestoremaster.in \
+ src/common/serialization_macros_generate.sh src/data/postinst.in \
+ utils/coverage.sh utils/cpp-interpreter.sh utils/wireshark/plugins/lizardfs/generate.sh; do
+ sed -i 's@#!/usr/bin/env bash@#!/bin/bash@' $i
+done
+# Remove /usr/bin/env from python3 scripts
+for i in src/cgi/cgiserv.py.in src/cgi/chart.cgi.in src/cgi/lizardfs-cgiserver.py.in src/cgi/mfs.cgi.in utils/wireshark/plugins/lizardfs/make_dissector.py; do
+ sed -i 's@#!/usr/bin/env python3@#!/usr/bin/python3@' $i
+done
+
%build
-./configure --with-doc
-#make %{?_smp_mflags}
-make -j4
+# Build code taken almost completely ./configure, but with some changes to use
+# Fedora's build flags
+rm -rf build-pack
+mkdir -p build-pack
+cd build-pack
+
+# Shared libraries need to be off because we call some functions that
+# are hidden which aren't accessible in DSOs
+%cmake .. \
+ -DBUILD_SHARED_LIBS:BOOL=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DENABLE_TESTS=NO \
+ -DCMAKE_INSTALL_PREFIX=/ \
+ -DENABLE_DEBIAN_PATHS=YES \
+ -DENABLE_DOCS=YES
+cat >../Makefile <<END
+all:
+ make -C build-pack all
+
+clean:
+ make -C build-pack clean
+
+install:
+ make -C build-pack install
+
+distclean:
+ rm -rf build-pack
+ rm -rf external/gtest*
+ rm -f Makefile
+END
+make VERBOSE=1 %{?_smp_mflags}
+
%install
-rm -rf $RPM_BUILD_ROOT
-make install DESTDIR=$RPM_BUILD_ROOT
-install -d -m755 $RPM_BUILD_ROOT/%{_unitdir}
+make install DESTDIR=%{buildroot}
+install -d -m755 %{buildroot}%{_unitdir}
for f in rpm/service-files/*.service ; do
- install -m644 "$f" $RPM_BUILD_ROOT/%{_unitdir}/$(basename "$f")
+ install -m644 "$f" %{buildroot}%{_unitdir}/$(basename "$f")
done
+mkdir -p %{buildroot}%{_sysconfdir}/pam.d
+install -m644 %{SOURCE1} %{buildroot}%{_sysconfdir}/pam.d/lizardfs
+mkdir -p %{buildroot}%{_sysconfdir}/security/limits.d
+install -m644 %{SOURCE2} %{buildroot}%{_sysconfdir}/security/limits.d/95-lizardfs.conf
-%clean
-rm -rf $RPM_BUILD_ROOT
%files master
-%defattr(644,root,root,755)
%doc NEWS README.md UPGRADE
-%attr(755,root,root) %{_sbindir}/mfsmaster
-%attr(755,root,root) %{_sbindir}/mfsrestoremaster
-%attr(755,root,root) %{_sbindir}/mfsmetadump
-%attr(755,root,root) %{_sbindir}/mfsmetarestore
-%attr(755,%{liz_user},%{liz_group}) %dir %{liz_datadir}
+%license COPYING
+%{_sbindir}/mfsmaster
+%{_sbindir}/mfsrestoremaster
+%{_sbindir}/mfsmetadump
+%{_sbindir}/mfsmetarestore
%{_mandir}/man5/mfsexports.cfg.5*
%{_mandir}/man5/mfstopology.cfg.5*
%{_mandir}/man5/mfsgoals.cfg.5*
@@ -253,42 +277,54 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man8/mfsmetadump.8*
%{_mandir}/man8/mfsmetarestore.8*
%{_mandir}/man8/mfsrestoremaster.8*
-%{liz_confdir}/mfsexports.cfg.dist
-%{liz_confdir}/mfstopology.cfg.dist
-%{liz_confdir}/mfsgoals.cfg.dist
-%{liz_confdir}/mfsmaster.cfg.dist
-%{liz_confdir}/globaliolimits.cfg.dist
-%attr(644,root,root) %{liz_datadir}/metadata.mfs.empty
-%attr(644,root,root) %{_unitdir}/lizardfs-master.service
+%{_unitdir}/lizardfs-master.service
+%attr(-,%{liz_user},%{liz_group}) %dir %{liz_datadir}
+%attr(-,%{liz_user},%{liz_group}) %{liz_datadir}/metadata.mfs.empty
+# Upstream documentation expects default config files to be stored in /etc/mfs
+%dir %{liz_confdir}
+%config %{liz_confdir}/mfsexports.cfg.dist
+%config %{liz_confdir}/mfstopology.cfg.dist
+%config %{liz_confdir}/mfsgoals.cfg.dist
+%config %{liz_confdir}/mfsmaster.cfg.dist
+%config %{liz_confdir}/globaliolimits.cfg.dist
+%config(noreplace) %{_sysconfdir}/pam.d/lizardfs
+%config(noreplace) %{_sysconfdir}/security/limits.d/95-lizardfs.conf
+
%files metalogger
-%defattr(644,root,root,755)
%doc NEWS README.md UPGRADE
-%attr(755,root,root) %{_sbindir}/mfsmetalogger
-%attr(755,%{liz_user},%{liz_group}) %dir %{liz_datadir}
+%license COPYING
+%{_sbindir}/mfsmetalogger
%{_mandir}/man5/mfsmetalogger.cfg.5*
%{_mandir}/man8/mfsmetalogger.8*
-%{liz_confdir}/mfsmetalogger.cfg.dist
-%attr(644,root,root) %{_unitdir}/lizardfs-metalogger.service
+%{_unitdir}/lizardfs-metalogger.service
+%attr(-,%{liz_user},%{liz_group}) %dir %{liz_datadir}
+%dir %{liz_confdir}
+%config %{liz_confdir}/mfsmetalogger.cfg.dist
+
%files chunkserver
-%defattr(644,root,root,755)
%doc NEWS README.md UPGRADE
-%attr(755,root,root) %{_sbindir}/mfschunkserver
-%attr(755,%{liz_user},%{liz_group}) %dir %{liz_datadir}
+%license COPYING
+%{_sbindir}/mfschunkserver
%{_mandir}/man5/mfschunkserver.cfg.5*
%{_mandir}/man5/mfshdd.cfg.5*
%{_mandir}/man8/mfschunkserver.8*
-%{liz_confdir}/mfschunkserver.cfg.dist
-%{liz_confdir}/mfshdd.cfg.dist
-%attr(644,root,root) %{_unitdir}/lizardfs-chunkserver.service
+%{_unitdir}/lizardfs-chunkserver.service
+%attr(-,%{liz_user},%{liz_group}) %dir %{liz_datadir}
+%dir %{liz_confdir}
+%config %{liz_confdir}/mfschunkserver.cfg.dist
+%config %{liz_confdir}/mfshdd.cfg.dist
+%config(noreplace) %{_sysconfdir}/pam.d/lizardfs
+%config(noreplace) %{_sysconfdir}/security/limits.d/95-lizardfs.conf
+
%files client
-%defattr(644,root,root,755)
%doc NEWS README.md UPGRADE
-%attr(755,root,root) %{_bindir}/lizardfs
-%attr(755,root,root) %{_bindir}/mfsmount
-%attr(755,root,root) %{_bindir}/mfstools.sh
+%license COPYING
+%{_bindir}/lizardfs
+%{_bindir}/mfstools.sh
+%{_bindir}/mfsmount
%{_bindir}/mfsappendchunks
%{_bindir}/mfscheckfile
%{_bindir}/mfsdeleattr
@@ -321,117 +357,192 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man1/lizardfs-repquota.1*
%{_mandir}/man1/lizardfs-rgetgoal.1*
%{_mandir}/man1/lizardfs-rgettrashtime.1*
+%{_mandir}/man1/lizardfs-rremove.1*
%{_mandir}/man1/lizardfs-rsetgoal.1*
%{_mandir}/man1/lizardfs-rsettrashtime.1*
%{_mandir}/man1/lizardfs-seteattr.1*
%{_mandir}/man1/lizardfs-setgoal.1*
%{_mandir}/man1/lizardfs-setquota.1*
%{_mandir}/man1/lizardfs-settrashtime.1*
-%{_mandir}/man1/lizardfs-rremove.1*
%{_mandir}/man1/lizardfs.1*
%{_mandir}/man5/iolimits.cfg.5*
+%{_mandir}/man5/mfsmount.cfg.5*
%{_mandir}/man7/mfs.7*
%{_mandir}/man7/moosefs.7*
+%{_mandir}/man7/lizardfs.7*
%{_mandir}/man1/mfsmount.1*
-%{_mandir}/man5/mfsmount.cfg.5*
-%{liz_confdir}/mfsmount.cfg.dist
-%{liz_confdir}/iolimits.cfg.dist
%{_sysconfdir}/bash_completion.d/lizardfs
+%dir %{liz_confdir}
+%config %{liz_confdir}/mfsmount.cfg.dist
+%config %{liz_confdir}/iolimits.cfg.dist
-%files lib-client
-%{_libdir}/liblizardfsmount_shared.so
-%{_libdir}/liblizardfs-client.so
-%{_libdir}/liblizardfs-client-cpp.a
-%{_libdir}/liblizardfs-client-cpp_pic.a
-%{_libdir}/liblizardfs-client.a
-%{_libdir}/liblizardfs-client_pic.a
-%{_includedir}/lizardfs/lizardfs_c_api.h
-%{_includedir}/lizardfs/lizardfs_error_codes.h
-
-### Uncomment lines below to re-enable ganesha build.
-#%files nfs-ganesha
-#%{_libdir}/ganesha/libfsallizardfs.so
-#%{_libdir}/ganesha/libfsallizardfs.so.4
-#%{_libdir}/ganesha/libfsallizardfs.so.4.2.0
%files cgi
-%defattr(644,root,root,755)
%doc NEWS README.md UPGRADE
+%license COPYING
%dir %{_datadir}/mfscgi
%{_datadir}/mfscgi/err.gif
%{_datadir}/mfscgi/favicon.ico
%{_datadir}/mfscgi/index.html
%{_datadir}/mfscgi/logomini.png
%{_datadir}/mfscgi/mfs.css
-%attr(755,root,root) %{_datadir}/mfscgi/mfs.cgi
-%attr(755,root,root) %{_datadir}/mfscgi/chart.cgi
+%{_datadir}/mfscgi/mfs.cgi
+%{_datadir}/mfscgi/chart.cgi
+
%files cgiserv
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_sbindir}/lizardfs-cgiserver
-%attr(755,root,root) %{_sbindir}/mfscgiserv
+%doc NEWS README.md UPGRADE
+%license COPYING
+%{_sbindir}/lizardfs-cgiserver
+%{_sbindir}/mfscgiserv
%{_mandir}/man8/lizardfs-cgiserver.8*
%{_mandir}/man8/mfscgiserv.8*
-%attr(644,root,root) %{_unitdir}/lizardfs-cgiserv.service
+%{_unitdir}/lizardfs-cgiserv.service
+
%files adm
-%defattr(644,root,root,755)
%doc NEWS README.md UPGRADE
-%attr(755,root,root) %{_bindir}/lizardfs-admin
+%license COPYING
+%{_bindir}/lizardfs-admin
%{_mandir}/man8/lizardfs-admin.8*
%{_bindir}/lizardfs-probe
%{_mandir}/man8/lizardfs-probe.8*
+
%changelog
-* Wed Nov 22 2017 Pawel Kalinowski <contact@lizardfs.org> - 3.12.0
-- (all) C API
-- (all) nfs-ganesha plugin (multiple exports allowed)
-- (all) RichACL support (which includes NFSv4)
-- (all) OSX ACL support
-- (master, mount) file lock fixes
-- (mount) client readahead enabled by default
-- (mount) AVX2 extensions support for erasure code goals
-- (chunkserver) more flexible options
-- (all) many fixes
-
-* Tue May 9 2017 Piotr Sarna <contact@lizardfs.org> - 3.11.0
-- (master) improve ACL implementation
-- (master) add option to avoid same-ip chunkserver replication
-- (master) add minimal goal configuration option
-- (master) reimplement directory entry cache for faster lookups
-- (master) add whole-path lookups
-- (master, chunkserver) add chunkserver load awareness
-- (mount) add readahead to improve sequential read perfromance
-- (mount) add secondary groups support
-- (tools) add correct-only flag to filerepair
-- (tools) add -s and -i options to snapshot command
-- (tools) add recursive remove operations (for removing large directories and snapshots)
-- (tools) add tool for stopping execution of tasks (snapshot, recursive remove, etc.)
-- (all) change to semantic versioning system
-- (all) many fixes
-
-* Fri Oct 7 2016 Piotr Sarna <contact@lizardfs.org> - 3.10.4
-- (master) task manager performance improvements
-- (master) trash fixes
-
-* Tue Aug 30 2016 Piotr Sarna <contact@lizardfs.org> - 3.10.2
-- (master) redesign in-memory representation of file system objects - at least 30% reduction in RAM usage
-- (master) name storage - a possibility to keep all file names in BerkeleyDB, thus saving even more RAM
-- (master) redesign of trash - increased performance, reduced RAM usage and CPU pressure
-- (master) huge boost of responsiveness - lengthy operations split into asynchronous bits
-- (master) OPERATIONS_DELAY* config entries, which allow postponing metadata operations on restart/disconnect
-- (master) fix improper handling of endangered chunks
-- (chunkserver) memory optimizations - at least 60% reduction in RAM usage
-- (chunkserver) introduce smart descriptor management
-- (tools) brand new `lizardfs` command, a unified replacement for mfs* tools with prompt and bash completion
-- (all) various fixes and community requests
-
-* Mon Mar 14 2016 Piotr Sarna <contact@lizardfs.org> - 3.10.0
-- (all) Added erasure code goals
-- (all) Added per directory quotas
-- (all) Improved interaction with legacy version (chunkservers, mounts)
-- (all) Ports for OSX and FreeBSD
-- (all) Many fixes
+* Thu Feb 09 2023 Artur Frenszek-Iwicki <fedora@svgames.pl> - 3.12.0-22
+- Add a patch to fix build failures with GCC13
+
+* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-21
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
+
+* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-20
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
+
+* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-19
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
+
+* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-18
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
+
+* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 3.12.0-17
+- Rebuilt for updated systemd-rpm-macros
+ See https://pagure.io/fesco/issue/2583.
+
+* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-16
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
+
+* Sun Aug 09 2020 Jonathan Dieter <jdieter@gmail.com> - 3.12.0-15
+- Fix build issues
+
+* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-14
+- Second attempt - Rebuilt for
+ https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-13
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-12
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Sat Aug 24 2019 Jonathan Dieter <jdieter@gmail.com> - 3.12.0-11
+- Use python 3 for cgi server and web interface
+
+* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-10
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-9
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-8
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
+* Thu Mar 15 2018 Jonathan Dieter <jdieter@gmail.com> - 3.12.0-7
+- Fix building for GCC 8
+
+* Wed Mar 07 2018 Jonathan Dieter <jdieter@gmail.com> - 3.12.0-6
+- Add BuildRequires: gcc and BuildRequires: gcc-c++
+
+* Thu Feb 08 2018 Jonathan Dieter <jdieter@gmail.com> - 3.12.0-5
+- Remove obsolete Group tag
+
+* Thu Feb 08 2018 Iryna Shcherbina <ishcherb@redhat.com> - 3.12.0-4
+- Update Python 2 dependency declarations to new packaging standards
+ (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
+
+* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.12.0-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Sat Jan 27 2018 Jonathan Dieter <jdieter@gmail.com> - 3.12.0-2
+- Fix systemd Requires and BuildRequires
+
+* Tue Dec 26 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.12.0-1
+- Update to 3.12.0
+
+* Sat Aug 26 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.11.3-1
+- Update to 3.11.3, removing upstreamed patches
+
+* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.11.2-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
+
+* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.11.2-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Wed Jul 5 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.11.2-1
+- Update to 3.11.2, removing upstreamed patches and adding in some new ones to
+ fix some small caching bugs
+
+* Sun May 28 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.11.0-3
+- Add more upstream bug-fixes, the most important of which fixes a rare crash
+ in master
+
+* Sat May 20 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.11.0-2
+- Update to 3.11.0 which fixes bug where goals are all empty
+- Remove upstreamed patches
+- Add new upstream patches that fix bugs in 3.11.0
+
+* Tue Apr 25 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.10.6-7
+- Switch to upstream patch for building with GCC 7
+
+* Mon Apr 24 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.10.6-6
+- Add patch to fix building in Rawhide
+
+* Thu Apr 20 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.10.6-5
+- Fix BuildRequires for Judy-devel
+- Add BR: pam-devel
+
+* Wed Apr 19 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.10.6-4
+- Take ownership of /etc/mfs
+- Explain why libcrcutil is bundled
+- Change %%define to %%global
+- Use hardcoded paths when removing /usr/bin/env from scripts so we don't have
+ to BR: python?-devel
+- Remove unnecessary rm -rf %%{buildroot}
+- Update license information
+
+* Tue Apr 18 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.10.6-3
+- Use __python2 and __python3 macros instead of hardcoded paths when removing
+ /usr/bin/env from scripts
+
+* Sun Apr 9 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.10.6-2
+- Cleanup spec file
+- Use Fedora build flags
+- Remove /usr/bin/env from scripts
+
+* Thu Jan 26 2017 Jonathan Dieter <jdieter@lesbg.com> - 3.10.6-1
+- Update to 3.10.6
+- (master) judy library fixes
+- (master) ARM compilation fixes
+
+* Mon Oct 31 2016 Jonathan Dieter <jdieter@lesbg.com> - 3.10.4-1
+- Update to 3.10.4
+- Rename tools
+
+* Tue Aug 16 2016 Jonathan Dieter <jdieter@lesbg.com> - 3.10.0-1
+- Update to 3.10.0
+
+* Thu May 19 2016 Jonathan Dieter <jdieter@lesbg.com> - 3.9.4-1
+- Fix -l option in mfsmakesnapshot
* Wed Dec 2 2015 Piotr Sarna <contact@lizardfs.org> - 3.9.4
- (master) Removed master server overload on restarting chunkservers