summaryrefslogtreecommitdiff
path: root/python-hjson.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-hjson.spec')
-rw-r--r--python-hjson.spec53
1 files changed, 53 insertions, 0 deletions
diff --git a/python-hjson.spec b/python-hjson.spec
new file mode 100644
index 0000000..8a8411a
--- /dev/null
+++ b/python-hjson.spec
@@ -0,0 +1,53 @@
+%global _empty_manifest_terminate_build 0
+Name: hjson
+Version: 3.1.0
+Release: 1
+Summary: Tensors and Dynamic neural networks in Python with strong GPU acceleration
+License: MIT
+URL: https://www.json.org/json-en.html
+Source0: https://github.com/hjson/hjson-py/releases/tag/v%{version}#/%{name}-%{version}.tar.gz
+
+BuildArch: noarch
+
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+
+%description
+DeepSpeed is a deep learning optimization library that makes distributed training and inference easy, efficient, and effective.
+
+%package -n python3-hjson
+Summary: hjson for python3
+
+%description -n python3-hjson
+python3-%{name} description
+
+%package help
+Summary: Development documents and examples for python-%{name}
+Provides: python3-%{name}-doc
+%description help
+hjson for python3 help doc
+
+%prep
+%autosetup -p1 -n %{name}-%{version}
+
+%build
+%py3_build
+
+%install
+%py3_install
+
+%files -n python3-%{name}
+%doc *.md
+%doc README.rst
+%license LICENSE.txt
+%{_bindir}/%{name}*
+%{python3_sitelib}/%{name}-%{version}-py%{python3_version}.egg-info/*
+%{python3_sitelib}/%{name}/*
+
+#%files help -f doclist.lst
+#%{_docdir}/*
+
+%changelog
+* Mon Jan 22 2024 menma <1316818279@qq.com> - 0.13.0-1
+- Package init