summaryrefslogtreecommitdiff
path: root/python-botorch.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-botorch.spec')
-rw-r--r--python-botorch.spec58
1 files changed, 58 insertions, 0 deletions
diff --git a/python-botorch.spec b/python-botorch.spec
new file mode 100644
index 0000000..d164811
--- /dev/null
+++ b/python-botorch.spec
@@ -0,0 +1,58 @@
+%global _empty_manifest_terminate_build 0
+%global pypi_name botorch
+%global source_name botorch
+
+Name: python-%{pypi_name}
+Version: 0.9.5
+Release: 1%{?dist}
+Summary: Botorch package for Python3
+License: MIT
+URL: https://huggingface.co/docs/transformers/index
+Source0: https://github.com/pytorch/botorch/archive/refs/tags/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
+
+Requires: python3-multipledispatch
+Requires: python3-scipy
+Requires: python3-torch >= 1.13.1
+Requires: python3-pyro-ppl >= 1.8.4
+Requires: python3-gpytorch >= 1.11
+Requires: python3-linear_operator == 0.5.1
+
+%description
+BoTorch is a library for Bayesian Optimization built on PyTorch.
+
+%package -n python3-%{pypi_name}
+Summary: Botorch package for Python3
+Provides: python-%{pypi_name}
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-setuptools_scm
+BuildRequires: python3-pip
+BuildRequires: python3-wheel
+BuildRequires: python3-hatchling
+
+%description -n python3-%{pypi_name}
+
+%package help
+Summary: Development documents and examples for botorch
+Provides: python3-%{pypi_name}-doc
+%description help
+documents of botorch package for python3
+
+%prep
+%autosetup -p1 -n %{pypi_name}-%{version}
+
+%build
+%py3_build
+
+%install
+%py3_install
+
+%files -n python3-%{pypi_name}
+%doc *.md
+%license LICENSE
+%{python3_sitearch}/*
+
+
+%changelog
+* Mon Jan 22 2024 menma <1316818279@qq.com> - 0.9.5-1
+- Package init