summaryrefslogtreecommitdiff
path: root/python-torchrl.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2024-01-27 17:21:50 +0000
committerCoprDistGit <infra@openeuler.org>2024-01-27 17:21:50 +0000
commit56efe91764fc28f969cf81cb0260bc8b9855e716 (patch)
treeddfa1bbf61f4e92714769b256bbbca25cd6a5d26 /python-torchrl.spec
parent3960333e26ddf6b76c83e41f6218c19f748a5909 (diff)
automatic import of python-torchrlopeneuler22.03_LTS_SP2
Diffstat (limited to 'python-torchrl.spec')
-rw-r--r--python-torchrl.spec62
1 files changed, 62 insertions, 0 deletions
diff --git a/python-torchrl.spec b/python-torchrl.spec
new file mode 100644
index 0000000..82cda30
--- /dev/null
+++ b/python-torchrl.spec
@@ -0,0 +1,62 @@
+%global _empty_manifest_terminate_build 0
+Name: python-torchrl
+Version: 0.2.1
+Release: 1
+Summary: Tensors and Dynamic neural networks in Python with strong GPU acceleration
+License: MIT
+URL: https://pypi.org/project/torchrl/
+Source0: https://github.com/pytorch/rl/archive/refs/tags/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
+
+Requires: python3-pytorch
+Requires: python3-pytorch_package_dep
+Requires: python3-numpy
+Requires: python3-packaging
+Requires: python3-cloudpickle
+Requires: python3-tensordict_dep
+
+%description
+PyTorch is a Python package that provides two high-level features:
+- Tensor computation (like NumPy) with strong GPU acceleration
+- Deep neural networks built on a tape-based autograd system
+You can reuse your favorite Python packages such as NumPy, SciPy and Cython to extend PyTorch when needed.
+
+%package -n python3-torchrl
+Summary: Tensors and Dynamic neural networks in Python with strong GPU acceleration
+Provides: python-torchrl
+BuildRequires: python3-pip
+#BuildRequires: python3-setuptools_scm
+BuildRequires: python3-setuptools
+BuildRequires: python3-wheel
+BuildRequires: python3-ninja
+#BuildRequires: python3-hatchling
+
+
+%description -n python3-torchrl
+
+%package help
+Summary: Development documents and examples for python-torchrl
+Provides: python3-torchrl-doc
+%description help
+
+%prep
+%autosetup -p1 -n rl-%{version}
+
+%build
+export MAX_JOBS=8
+%pyproject_build
+
+%install
+%pyproject_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+
+%files -n python3-torchrl
+%doc *.md
+%license LICENSE
+%{python3_sitearch}/torchrl/*
+%{python3_sitearch}/torchrl-%{version}.dist-info/*
+%{python3_sitearch}/build_tools/*
+
+
+%changelog
+* Fri Jan 26 2024 menma <1316818279@qq.com> - 0.2.1-1
+- Package init