summaryrefslogtreecommitdiff
path: root/blinken.spec
diff options
context:
space:
mode:
Diffstat (limited to 'blinken.spec')
-rw-r--r--blinken.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/blinken.spec b/blinken.spec
new file mode 100644
index 0000000..b2eea37
--- /dev/null
+++ b/blinken.spec
@@ -0,0 +1,80 @@
+Name: blinken
+Summary: Memory Enhancement Game
+Version: 22.08.0
+Release: 1
+
+License: GPLv2+
+URL: https://cgit.kde.org/%{name}.git
+
+%global revision %(echo %{version} | cut -d. -f3)
+
+%if %{revision} >= 50
+%global stable unstable
+%else
+%global stable stable
+%endif
+
+Source0: http://download.kde.org/%{stable}/release-service/%{version}/src/%{name}-%{version}.tar.xz
+
+BuildRequires: cmake(KF5Crash)
+BuildRequires: desktop-file-utils
+BuildRequires: extra-cmake-modules
+BuildRequires: gettext
+BuildRequires: kf5-rpm-macros
+BuildRequires: kf5-kdbusaddons-devel
+BuildRequires: kf5-kdoctools-devel
+BuildRequires: kf5-kguiaddons-devel
+BuildRequires: kf5-ki18n-devel
+BuildRequires: kf5-kxmlgui-devel
+BuildRequires: pkgconfig(phonon4qt5)
+BuildRequires: pkgconfig(Qt5Widgets) pkgconfig(Qt5Svg)
+BuildRequires: libappstream-glib
+BuildRequires: readline-devel
+
+Requires: sj-stevehand-fonts
+
+Conflicts: kdeedu < 4.7.0-10
+
+%description
+%{summary}.
+
+
+%prep
+%autosetup
+
+
+%build
+mkdir %{_target_platform}
+pushd %{_target_platform}
+%{cmake_kf5} ..
+popd
+%make_build -C %{_target_platform}
+
+
+%install
+make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
+
+%find_lang %{name} --all-name --with-html --with-qt
+
+rm -fv %{buildroot}%{_kf5_datadir}/blinken/fonts/steve.ttf
+
+
+%check
+appstream-util validate-relax --nonet %{buildroot}%{_kf5_metainfodir}/org.kde.%{name}.appdata.xml ||:
+desktop-file-validate %{buildroot}%{_kf5_datadir}/applications/org.kde.%{name}.desktop ||:
+
+
+%files -f %{name}.lang
+%doc AUTHORS
+%license LICENSES/*
+%{_kf5_bindir}/%{name}
+%{_kf5_datadir}/applications/org.kde.%{name}.desktop
+%{_kf5_metainfodir}/org.kde.%{name}.appdata.xml
+%{_kf5_datadir}/icons/hicolor/*/*/*
+%{_kf5_datadir}/%{name}/
+%{_kf5_datadir}/config.kcfg/%{name}.kcfg
+
+
+%changelog
+* Sat Dec 17 2022 misaka00251 <liuxin@iscas.ac.cn> - 22.08.0-1
+- 22.08.0