summaryrefslogtreecommitdiff
path: root/extra-cmake-modules.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-07-22 13:44:32 +0000
committerCoprDistGit <infra@openeuler.org>2023-07-22 13:44:32 +0000
commite2faadd8e5aca08db4111844d568d70d761a4220 (patch)
treebe104b2a77c94e01b5d0e448e603527554786933 /extra-cmake-modules.spec
parent9241b730ad38f33ce5dc783117b153d0549e7aeb (diff)
automatic import of extra-cmake-modulesopeneuler23.03
Diffstat (limited to 'extra-cmake-modules.spec')
-rw-r--r--extra-cmake-modules.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/extra-cmake-modules.spec b/extra-cmake-modules.spec
new file mode 100644
index 0000000..6290aff
--- /dev/null
+++ b/extra-cmake-modules.spec
@@ -0,0 +1,74 @@
+Name: extra-cmake-modules
+Summary: Additional modules for CMake build system
+Version: 5.108.0
+Release: 1
+License: BSD
+URL: https://api.kde.org/ecm/
+
+%global versiondir %(echo %{version} | cut -d. -f1-2)
+%global revision %(echo %{version} | cut -d. -f3)
+%if %{revision} >= 50
+%global stable unstable
+%else
+%global stable stable
+%endif
+Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{name}-%{version}.tar.xz
+Patch01: extra-cmake-modules-5.39.0-poppler_overlinking.patch
+Patch02: extra-cmake-modules-5.89.0-qt_prefix.patch
+BuildArch: noarch
+BuildRequires: kf5-rpm-macros qt5-qttools-devel python3-sphinx
+Requires: kf5-rpm-macros qt5-linguist
+
+%description
+Additional modules for CMake build system needed by KDE Frameworks.
+
+
+%prep
+%autosetup -p1
+
+%build
+mkdir %{_target_platform}
+cd %{_target_platform}
+%{cmake_kf5} .. -DBUILD_HTML_DOCS:BOOL=ON -DBUILD_MAN_DOCS:BOOL=ON -DBUILD_TESTING:BOOL=ON \
+ -DSphinx_BUILD_EXECUTABLE:PATH=%{_bindir}/sphinx-build-3
+cd -
+%make_build -C %{_target_platform}
+
+
+%install
+%make_install -C %{_target_platform}
+
+
+%check
+export CTEST_OUTPUT_ON_FAILURE=1
+make test ARGS="--output-on-failure --timeout 300" -C %{_target_platform} ||:
+
+%files
+%doc README.rst
+%license LICENSES/*.txt
+%{_datadir}/ECM/
+%{_kf5_docdir}/ECM/html/
+%{_kf5_mandir}/man7/ecm*.7*
+
+
+%changelog
+* Fri Dec 09 2022 jiangxinyu <jiangxinyu@kylinos.cn> - 5.100.0-1
+- Update to upstream version 5.100.0
+
+* Mon Sep 05 2022 liweiganga <liweiganga@uniontech.com> - 5.97.0-1
+- update to upstream version 5.97.0
+
+* Mon Jul 04 2022 loong_C <loong_c@yeah.net> - 5.95.0-1
+- update to upstream version 5.95.0
+
+* Fri Feb 11 2022 pei-jiankang<peijiankang@kylinos.cn> - 5.90.0-1
+- update to upstream version 5.90.0
+
+* Wed Jan 12 2022 pei-jiankang<peijiankang@kylinos.cn> - 5.88.0-1
+- update to upstream version 5.88.0
+
+* Thu Mar 12 2020 lingsheng <lingsheng@huawei.com> - 5.59.0-3
+- Remove install require appstream
+
+* Tue Mar 10 2020 zhujunhao <zhujunhao5@huawei.com> - 5.59.0-2
+- Package init