summaryrefslogtreecommitdiff
path: root/kf5-ktnef.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kf5-ktnef.spec')
-rw-r--r--kf5-ktnef.spec95
1 files changed, 95 insertions, 0 deletions
diff --git a/kf5-ktnef.spec b/kf5-ktnef.spec
new file mode 100644
index 0000000..bd43f44
--- /dev/null
+++ b/kf5-ktnef.spec
@@ -0,0 +1,95 @@
+%undefine __cmake_in_source_build
+%global framework ktnef
+
+# uncomment to enable bootstrap mode
+#global bootstrap 1
+
+%if !0%{?bootstrap}
+%global tests 1
+%endif
+
+Name: kf5-%{framework}
+Version: 22.12.0
+Release: 1
+Summary: The KTNef Library
+License: LGPLv2+
+URL: https://invent.kde.org/frameworks/%{framework}
+
+%global revision %(echo %{version} | cut -d. -f3)
+%if %{revision} >= 50
+%global stable unstable
+%else
+%global stable stable
+%endif
+Source0: http://download.kde.org/%{stable}/release-service/%{version}/src/%{framework}-%{version}.tar.xz
+
+BuildRequires: make
+BuildRequires: extra-cmake-modules
+BuildRequires: kf5-rpm-macros
+BuildRequires: kf5-kdelibs4support-devel >= 5.15
+
+#global majmin_ver %(echo %{version} | cut -d. -f1,2)
+%global majmin_ver %{version}
+
+BuildRequires: kf5-kcalendarcore-devel >= %{majmin_ver}
+BuildRequires: kf5-kcalendarutils-devel >= %{majmin_ver}
+BuildRequires: kf5-kcontacts-devel >= %{majmin_ver}
+BuildRequires: qt5-qtbase-devel
+
+%if 0%{?tests}
+BuildRequires: dbus-x11
+BuildRequires: xorg-x11-server-Xvfb
+%endif
+
+%description
+%{summary}.
+
+%package devel
+Summary: Development files for %{name}
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: cmake(KF5CalendarCore)
+Requires: kf5-kcalendarcore-devel >= %{majmin_ver}
+%description devel
+The %{name}-devel package contains libraries and header files for
+developing applications that use %{name}.
+
+%prep
+%autosetup -n %{framework}-%{version} -p1
+
+%build
+mkdir %{_target_platform}
+pushd %{_target_platform}
+%{cmake_kf5} .. \
+ -DBUILD_TESTING:BOOL=%{?tests:ON}%{!?tests:OFF}
+popd
+%make_build -C %{_target_platform}
+
+%install
+make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
+
+%find_lang %{name} --all-name --with-html
+
+%check
+%if 0%{?tests}
+export CTEST_OUTPUT_ON_FAILURE=1
+xvfb-run -a \
+dbus-launch --exit-with-session \
+make test ARGS="--output-on-failure --timeout 10" -C %{_target_platform} ||:
+%endif
+
+%ldconfig_scriptlets
+
+%files -f %{name}.lang
+%license LICENSES/*
+%{_kf5_datadir}/qlogging-categories5/*%{framework}.*
+%{_kf5_libdir}/libKF5Tnef.so.*
+
+%files devel
+%{_kf5_includedir}/KTNEF/
+%{_kf5_libdir}/libKF5Tnef.so
+%{_kf5_libdir}/cmake/KF5Tnef/
+%{_kf5_archdatadir}/mkspecs/modules/qt_KTNef.pri
+
+%changelog
+* Tue Jun 06 2023 misaka00251 <liuxin@iscas.ac.cn> - 22.12.0-1
+- Init package