summaryrefslogtreecommitdiff
path: root/khangman.spec
diff options
context:
space:
mode:
Diffstat (limited to 'khangman.spec')
-rw-r--r--khangman.spec118
1 files changed, 118 insertions, 0 deletions
diff --git a/khangman.spec b/khangman.spec
new file mode 100644
index 0000000..6265284
--- /dev/null
+++ b/khangman.spec
@@ -0,0 +1,118 @@
+%global majmin_ver %(echo %{version} | cut -d. -f1,2)
+
+Name: khangman
+Summary: Hangman game
+Version: 22.08.0
+Release: 1
+
+License: GPLv2+
+URL: https://invent.kde.org/edu/%{name}
+
+%global revision %(echo %{version} | cut -d. -f3)
+
+%if %{revision} >= 50
+%global stable unstable
+%else
+%global stable stable
+%endif
+
+Source0: http://download.kde.org/%{stable}/release-service/%{version}/src/%{name}-%{version}.tar.xz
+
+BuildRequires: desktop-file-utils
+BuildRequires: extra-cmake-modules
+BuildRequires: gettext
+BuildRequires: kf5-kcompletion-devel
+BuildRequires: kf5-kconfig-devel
+BuildRequires: kf5-kconfigwidgets-devel
+BuildRequires: kf5-kcoreaddons-devel
+BuildRequires: kf5-kdbusaddons-devel
+BuildRequires: kf5-kdeclarative-devel
+BuildRequires: kf5-kdelibs4support-devel
+BuildRequires: kf5-kdnssd-devel
+BuildRequires: kf5-kguiaddons-devel
+BuildRequires: kf5-ki18n-devel
+BuildRequires: kf5-kiconthemes-devel
+BuildRequires: kf5-kio-devel
+BuildRequires: kf5-kitemmodels-devel
+BuildRequires: kf5-kitemviews-devel
+BuildRequires: kf5-kjobwidgets-devel
+BuildRequires: kf5-knewstuff-devel
+BuildRequires: kf5-knewstuff-devel
+BuildRequires: kf5-knotifyconfig-devel
+BuildRequires: kf5-kservice-devel
+BuildRequires: kf5-kwidgetsaddons-devel
+BuildRequires: kf5-kwindowsystem-devel
+BuildRequires: kf5-kxmlgui-devel
+BuildRequires: kf5-rpm-macros
+BuildRequires: libappstream-glib
+
+BuildRequires: libkeduvocdocument-devel >= %{majmin_ver}
+BuildRequires: pkgconfig(Qt5Core) pkgconfig(Qt5Qml) pkgconfig(Qt5Quick) pkgconfig(Qt5QuickWidgets) pkgconfig(Qt5Svg)
+
+Requires: dustin-dustismo-roman-fonts
+Requires: dustin-domestic-manners-fonts
+Requires: kdeedu-data
+Requires: qt5-qtgraphicaleffects
+Requires: qt5-qtmultimedia
+Requires: qt5-qtquickcontrols
+
+Conflicts: kdeedu < 4.7.0-10
+
+Obsoletes: khangman-libs < 15.04
+Obsoletes: khangman-devel < 15.04
+
+%description
+%{summary}.
+
+
+%prep
+%autosetup -p1
+
+
+%build
+mkdir %{_target_platform}
+pushd %{_target_platform}
+%{cmake_kf5} ..
+popd
+%make_build -C %{_target_platform}
+
+
+%install
+make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
+
+if [ -f "%{buildroot}%{_sysconfdir}/xdg/%{name}.knsrc" ]; then
+mkdir -p %{buildroot}%{_kf5_datadir}/knsrcfiles
+mv \
+ %{buildroot}%{_sysconfdir}/xdg/%{name}.knsrc \
+ %{buildroot}%{_kf5_datadir}/knsrcfiles/%{name}.knsrc
+fi
+
+
+%find_lang %{name} --all-name --with-html --with-man --with-qt
+
+rm -fv %{buildroot}%{_kf5_datadir}/khangman/fonts/Dustismo_Roman.ttf
+rm -fv %{buildroot}%{_kf5_datadir}/khangman/fonts/Domestic_Manners.ttf
+rm -fv %{buildroot}%{_kf5_datadir}/icons/hicolor/*/apps/khangman-harmattan.*
+
+
+%check
+appstream-util validate-relax --nonet %{buildroot}%{_kf5_metainfodir}/org.kde.%{name}.appdata.xml ||:
+desktop-file-validate %{buildroot}%{_kf5_datadir}/applications/org.kde.%{name}.desktop ||:
+
+
+%files -f %{name}.lang
+%license COPYING*
+%doc README
+%{_kf5_bindir}/%{name}*
+%{_kf5_datadir}/knsrcfiles/%{name}.knsrc
+%{_kf5_datadir}/applications/org.kde.%{name}.desktop
+%{_kf5_metainfodir}/org.kde.%{name}.appdata.xml
+%{_kf5_datadir}/icons/hicolor/*/apps/%{name}.*
+%{_kf5_datadir}/%{name}/
+%{_kf5_datadir}/config.kcfg/%{name}.kcfg
+%{_mandir}/man6/%{name}.6*
+
+
+%changelog
+* Sat Dec 17 2022 misaka00251 <liuxin@iscas.ac.cn> - 22.08.0-1
+- Init package