summaryrefslogtreecommitdiff
path: root/kmag.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-07-21 06:39:44 +0000
committerCoprDistGit <infra@openeuler.org>2023-07-21 06:39:44 +0000
commitf63ee0b1c0a27ae5143b523558cc5f6d34e83cad (patch)
treec95e7201214388b892e287a62ce923224f24c90a /kmag.spec
parentadbedb383b60777438a8bc3887c6d58a7a61da9e (diff)
automatic import of kmagopeneuler23.03
Diffstat (limited to 'kmag.spec')
-rw-r--r--kmag.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/kmag.spec b/kmag.spec
new file mode 100644
index 0000000..6003a96
--- /dev/null
+++ b/kmag.spec
@@ -0,0 +1,75 @@
+%undefine __cmake_in_source_build
+
+Name: kmag
+Version: 22.08.0
+Release: 1
+Summary: A screen magnifier
+
+License: GPLv2
+URL: http://accessibility.kde.org/
+
+%global revision %(echo %{version} | cut -d. -f3)
+
+%if %{revision} >= 50
+%global stable unstable
+%else
+%global stable stable
+%endif
+
+Source0: http://download.kde.org/%{stable}/release-service/%{version}/src/%{name}-%{version}.tar.xz
+
+BuildRequires: desktop-file-utils
+BuildRequires: libappstream-glib
+
+BuildRequires: extra-cmake-modules
+BuildRequires: cmake(KF5DocTools)
+BuildRequires: cmake(KF5I18n)
+BuildRequires: cmake(KF5KIO)
+BuildRequires: cmake(KF5XmlGui)
+
+BuildRequires: cmake(Qt5PrintSupport)
+BuildRequires: cmake(Qt5Widgets)
+
+Conflicts: kdeaccessibility < 1:4.7.80
+
+%description
+%{summary}.
+
+
+%prep
+%autosetup -p1
+
+
+%build
+mkdir %{_target_platform}
+pushd %{_target_platform}
+%{cmake_kf5} ..
+popd
+%make_build -C %{_target_platform}
+
+
+%install
+make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
+
+%find_lang %{name} --all-name --with-html --with-man
+
+
+%check
+appstream-util validate-relax --nonet %{buildroot}%{_kf5_metainfodir}/org.kde.%{name}.appdata.xml ||:
+desktop-file-validate %{buildroot}%{_kf5_datadir}/applications/org.kde.%{name}.desktop ||:
+
+
+%files -f %{name}.lang
+%doc AUTHORS ChangeLog README TODO
+%license COPYING*
+%{_kf5_bindir}/%{name}*
+%{_kf5_datadir}/%{name}
+%{_kf5_metainfodir}/org.kde.%{name}.appdata.xml
+%{_kf5_datadir}/applications/org.kde.%{name}.desktop
+%{_kf5_datadir}/icons/hicolor/*/*/*
+%{_mandir}/man1/*.1*
+
+
+%changelog
+* Tue Dec 20 2022 misaka00251 <liuxin@iscas.ac.cn> - 22.08.0-1
+- Init package