summaryrefslogtreecommitdiff
path: root/kmplot.spec
diff options
context:
space:
mode:
Diffstat (limited to 'kmplot.spec')
-rw-r--r--kmplot.spec95
1 files changed, 95 insertions, 0 deletions
diff --git a/kmplot.spec b/kmplot.spec
new file mode 100644
index 0000000..a82e9fe
--- /dev/null
+++ b/kmplot.spec
@@ -0,0 +1,95 @@
+%undefine __cmake_in_source_build
+
+Name: kmplot
+Summary: Mathematical Function Plotter
+Version: 22.08.0
+Release: 1
+
+License: GPLv2+
+URL: https://cgit.kde.org/%{name}.git
+
+%global revision %(echo %{version} | cut -d. -f3)
+
+%if %{revision} >= 50
+%global stable unstable
+%else
+%global stable stable
+%endif
+
+Source0: http://download.kde.org/%{stable}/release-service/%{version}/src/%{name}-%{version}.tar.xz
+
+BuildRequires: desktop-file-utils
+BuildRequires: extra-cmake-modules
+BuildRequires: gettext
+BuildRequires: kf5-kcompletion-devel
+BuildRequires: kf5-kconfig-devel
+BuildRequires: kf5-kconfigwidgets-devel
+BuildRequires: kf5-kcoreaddons-devel
+BuildRequires: kf5-kcrash-devel
+BuildRequires: kf5-kdbusaddons-devel
+BuildRequires: kf5-kdeclarative-devel
+BuildRequires: kf5-kdelibs4support-devel
+BuildRequires: kf5-kdoctools-devel
+BuildRequires: kf5-kguiaddons-devel
+BuildRequires: kf5-ki18n-devel
+BuildRequires: kf5-kiconthemes-devel
+BuildRequires: kf5-kio-devel
+BuildRequires: kf5-kitemviews-devel
+BuildRequires: kf5-kjobwidgets-devel
+BuildRequires: kf5-knewstuff-devel
+BuildRequires: kf5-knotifyconfig-devel
+BuildRequires: kf5-kparts-devel
+BuildRequires: kf5-kservice-devel
+BuildRequires: kf5-kwidgetsaddons-devel
+BuildRequires: kf5-kwindowsystem-devel
+BuildRequires: kf5-kxmlgui-devel
+BuildRequires: kf5-rpm-macros
+BuildRequires: libappstream-glib
+BuildRequires: pkgconfig(Qt5Gui) pkgconfig(Qt5Widgets) pkgconfig(Qt5Svg) pkgconfig(Qt5PrintSupport)
+
+Conflicts: kdeedu-math < 4.7.0-10
+
+%description
+%{summary}.
+
+
+%prep
+%autosetup -p1
+
+
+%build
+mkdir %{_target_platform}
+pushd %{_target_platform}
+%{cmake_kf5} ..
+popd
+%make_build -C %{_target_platform}
+
+
+%install
+make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
+
+%find_lang %{name} --all-name --with-html --with-man --with-qt
+
+
+%check
+appstream-util validate-relax --nonet %{buildroot}%{_kf5_metainfodir}/org.kde.%{name}.appdata.xml ||:
+desktop-file-validate %{buildroot}%{_kf5_datadir}/applications/org.kde.%{name}.desktop ||:
+
+
+%files -f %{name}.lang
+%license LICENSES/*
+%{_kf5_bindir}/%{name}
+%{_kf5_datadir}/applications/org.kde.%{name}.desktop
+%{_kf5_metainfodir}/org.kde.%{name}.appdata.xml
+%{_kf5_datadir}/icons/hicolor/*/apps/%{name}.*
+%{_kf5_datadir}/kxmlgui5/%{name}/
+%{_kf5_datadir}/config.kcfg/%{name}.kcfg
+%{_kf5_datadir}/kservices5/%{name}_part.desktop
+%{_kf5_plugindir}/parts/%{name}part.so
+%{_datadir}/dbus-1/interfaces/org.kde.%{name}.*.xml
+%{_mandir}/man1/kmplot.*
+
+
+%changelog
+* Mon Dec 19 2022 misaka00251 <liuxin@iscas.ac.cn> - 22.08.0-1
+- Init package