summaryrefslogtreecommitdiff
path: root/js-jquery-ui.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-07-09 07:14:25 +0000
committerCoprDistGit <infra@openeuler.org>2023-07-09 07:14:25 +0000
commit5d30642a9a03ca40f8435411db549b309187c073 (patch)
tree194dc53a9f7097d37757295d5d88da079970ecc5 /js-jquery-ui.spec
parent0a2bcea8f185a4a51e9a6fdae70cadc2d7ace859 (diff)
automatic import of js-jquery-uiopeneuler23.03
Diffstat (limited to 'js-jquery-ui.spec')
-rw-r--r--js-jquery-ui.spec52
1 files changed, 52 insertions, 0 deletions
diff --git a/js-jquery-ui.spec b/js-jquery-ui.spec
new file mode 100644
index 0000000..50864d2
--- /dev/null
+++ b/js-jquery-ui.spec
@@ -0,0 +1,52 @@
+%global jsname jquery-ui
+
+Name: js-%{jsname}
+Version: 1.13.2
+Release: 1
+Summary: jQuery user interface
+
+License: MIT
+URL: https://jqueryui.com/
+Source0: https://github.com/jquery/%{jsname}/archive/%{version}/%{jsname}-%{version}.tar.gz
+# We need to bundle build dependencies since they are no
+# longer available in Fedora. This uses the same
+# technique as the js-jquery package.
+Source1: %{jsname}-%{version}-node-modules.tar.gz
+# Script to create the above sources
+Source2: create-source.sh
+
+BuildArch: noarch
+BuildRequires: nodejs >= 1:10
+BuildRequires: web-assets-devel
+BuildRequires: python3-rcssmin
+Requires: js-jquery >= 1.8.0
+Requires: web-assets-filesystem
+
+%description
+A curated set of user interface interactions, effects, widgets, and
+themes built on top of the jQuery JavaScript Library.
+
+%prep
+%setup -q -n %{jsname}-%{version} -a 1
+rm -rf dist
+
+%build
+./node_modules/grunt-cli/bin/grunt -v requirejs:js concat:css uglify:main
+
+# Provide a compressed version of the cascading style sheet
+python3 -m rcssmin -b < dist/jquery-ui.css > dist/jquery-ui.min.css
+
+%install
+mkdir -p %{buildroot}%{_jsdir}/%{jsname}
+install -m 644 -p dist/* %{buildroot}%{_jsdir}/%{jsname}
+mkdir -p %{buildroot}%{_jsdir}/%{jsname}/images
+install -m 644 -p themes/base/images/* %{buildroot}%{_jsdir}/%{jsname}/images
+
+%files
+%{_jsdir}/%{jsname}
+%license LICENSE.txt
+%doc AUTHORS.txt CONTRIBUTING.md README.md
+
+%changelog
+* Wed May 17 2023 lichaoran <pkwarcraft@hotmail.com> - 1.13.2-1
+- Init package