summaryrefslogtreecommitdiff
path: root/mock-core-configs.spec
diff options
context:
space:
mode:
Diffstat (limited to 'mock-core-configs.spec')
-rw-r--r--mock-core-configs.spec54
1 files changed, 48 insertions, 6 deletions
diff --git a/mock-core-configs.spec b/mock-core-configs.spec
index f7eecba..3634ab8 100644
--- a/mock-core-configs.spec
+++ b/mock-core-configs.spec
@@ -2,8 +2,8 @@
%global mockgid 135
Name: mock-core-configs
-Version: 31.6
-Release: 1
+Version: 38.3
+Release: 2
Summary: Mock core config files basic chroots
License: GPLv2+
@@ -13,7 +13,44 @@ URL: https://github.com/rpm-software-management/mock/
# cd mock/mock-core-configs
# git reset --hard %%{name}-%%{version}-%%{release}
# tito build --tgz
-Source: https://github.com/rpm-software-management/mock/releases/download/%{name}-%{version}-1/%{name}-%{version}.tar.gz
+Source0: https://github.com/rpm-software-management/mock/releases/download/%{name}-%{version}-1/%{name}-%{version}.tar.gz
+Source1: openeuler-20.03_LTS_SP3-aarch64.cfg
+Source2: openeuler-20.03_LTS_SP3-x86_64.cfg
+Source3: openeuler-20.03_LTS_SP2-aarch64.cfg
+Source4: openeuler-20.03_LTS_SP2-x86_64.cfg
+Source5: openeuler-20.03_LTS_SP1-aarch64.cfg
+Source6: openeuler-20.03_LTS_SP1-x86_64.cfg
+Source7: openeuler-20.03_LTS-aarch64.cfg
+Source8: openeuler-20.03_LTS-x86_64.cfg
+Source9: openeuler-21.03-aarch64.cfg
+Source10: openeuler-21.03-x86_64.cfg
+Source11: openeuler-21.09-aarch64.cfg
+Source12: openeuler-21.09-x86_64.cfg
+Source13: openeuler-20.09-aarch64.cfg
+Source14: openeuler-20.09-x86_64.cfg
+Source15: openeuler-22.09-aarch64.cfg
+Source16: openeuler-22.09-x86_64.cfg
+Source17: openeuler-22.03_LTS-aarch64.cfg
+Source18: openeuler-22.03_LTS-x86_64.cfg
+Source19: openeuler-23.03-aarch64.cfg
+Source20: openeuler-23.03-x86_64.cfg
+Source21: openeuler-22.03_LTS_SP1-aarch64.cfg
+Source22: openeuler-22.03_LTS_SP1-x86_64.cfg
+Source23: openeuler-20.03-sp3.tpl
+Source24: openeuler-20.03-sp2.tpl
+Source25: openeuler-20.03-sp1.tpl
+Source26: openeuler-20.03.tpl
+Source27: openeuler-20.09.tpl
+Source28: openeuler-21.03.tpl
+Source29: openeuler-21.09.tpl
+Source30: openeuler-22.03-sp1.tpl
+Source31: openeuler-22.03.tpl
+Source32: openeuler-22.09.tpl
+Source33: openeuler-23.03.tpl
+Source34: openeuler-22.03-sp2.tpl
+Source35: openeuler-22.03_LTS_SP2-aarch64.cfg
+Source36: openeuler-22.03_LTS_SP2-x86_64.cfg
+
BuildArch: noarch
Requires: openEuler-gpg-keys
Requires: distribution-gpg-keys
@@ -37,7 +74,7 @@ Config files which allow you to create chroots for:
%prep
%setup -q
-
+cp -pav $(dirname %{SOURCE1})/openeuler-* .
%build
# nothing to do here
@@ -51,6 +88,8 @@ mkdir -p %{buildroot}%{_sysconfdir}/mock/templates
cp -a etc/mock/*.cfg %{buildroot}%{_sysconfdir}/mock
cp -a etc/mock/templates/*.tpl %{buildroot}%{_sysconfdir}/mock/templates
cp -a etc/mock/eol/*cfg %{buildroot}%{_sysconfdir}/mock/eol
+cp -a openeuler-*.cfg %{buildroot}%{_sysconfdir}/mock
+cp -a openeuler-*.tpl %{buildroot}%{_sysconfdir}/mock/templates
# generate files section with config - there is many of them
echo "%defattr(0644, root, mock)" > %{name}.cfgs
@@ -71,7 +110,7 @@ getent group mock > /dev/null || groupadd -f -g %mockgid -r mock
exit 0
%post
-# get release ver such as: 22.03
+# get release ver such as: 22.03
ver=$(source /etc/os-release && echo $VERSION_ID)
mock_arch=$(python3 -c "import dnf.rpm; import hawkey; print(dnf.rpm.basearch(hawkey.detect_arch()))")
cfg=openeuler-$ver-${mock_arch}.cfg
@@ -94,5 +133,8 @@ fi
%ghost %config(noreplace,missingok) %{_sysconfdir}/mock/default.cfg
%changelog
-* Fri May 19 2023 lichaoran <pkwarcraft@hotmail.com> 36.1-1
+* Wed Jul 12 2023 lichaoran <pkwarcraft@hotmail.com> 38.3-2
+- add openEuler 22.03-lts-sp2 configs
+
+* Fri May 19 2023 lichaoran <pkwarcraft@hotmail.com> 38.3-1
- Init package