summaryrefslogtreecommitdiff
path: root/python-asttokens.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-asttokens.spec')
-rw-r--r--python-asttokens.spec122
1 files changed, 49 insertions, 73 deletions
diff --git a/python-asttokens.spec b/python-asttokens.spec
index 956bb97..cf4dea4 100644
--- a/python-asttokens.spec
+++ b/python-asttokens.spec
@@ -1,85 +1,61 @@
-%global _empty_manifest_terminate_build 0
-Name: python-asttokens
-Version: 2.2.1
-Release: 1
-Summary: Annotate AST trees with source code positions
-License: Apache 2.0
-URL: https://github.com/gristlabs/asttokens
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c8/e3/b0b4f32162621126fbdaba636c152c6b6baec486c99f48686e66343d638f/asttokens-2.2.1.tar.gz
-BuildArch: noarch
-
-Requires: python3-six
-Requires: python3-typing
-Requires: python3-astroid
-Requires: python3-pytest
-
-%description
-The ``asttokens`` module annotates Python abstract syntax trees (ASTs) with the positions of tokens
-and text in the source code that generated them.
-It makes it possible for tools that work with logical AST nodes to find the particular text that
-resulted in those nodes, for example for automated refactoring or highlighting.
+Name: python-asttokens
+Version: 2.2.1
+Release: 1%{?dist}
+Summary: Module to annotate Python abstract syntax trees with source code positions
+
+License: Apache-2.0
+URL: https://github.com/gristlabs/asttokens
+Source0: %{name}-%{version}.tar.gz
+
+BuildArch: noarch
+BuildRequires: python3-devel
+BuildRequires: python3dist(setuptools)
+BuildRequires: python3dist(setuptools-scm)
+BuildRequires: python3dist(wheel)
+BuildRequires: python3dist(toml)
+BuildRequires: python3dist(pytest)
+BuildRequires: python3dist(astroid)
+BuildRequires: python3dist(six)
+BuildRequires: python3dist(typing-extensions)
+
+%global _description %{expand:
+The asttokens module annotates Python abstract syntax trees (ASTs)
+with the positions of tokens and text in the source code that
+generated them. This makes it possible for tools that work with
+logical AST nodes to find the particular text that resulted in those
+nodes, for example for automated refactoring or highlighting.}
+
+%description %_description
+
%package -n python3-asttokens
-Summary: Annotate AST trees with source code positions
-Provides: python-asttokens
-BuildRequires: python3-devel
-BuildRequires: python3-setuptools
-BuildRequires: python3-pip
-%description -n python3-asttokens
-The ``asttokens`` module annotates Python abstract syntax trees (ASTs) with the positions of tokens
-and text in the source code that generated them.
-It makes it possible for tools that work with logical AST nodes to find the particular text that
-resulted in those nodes, for example for automated refactoring or highlighting.
-
-%package help
-Summary: Development documents and examples for asttokens
-Provides: python3-asttokens-doc
-%description help
-The ``asttokens`` module annotates Python abstract syntax trees (ASTs) with the positions of tokens
-and text in the source code that generated them.
-It makes it possible for tools that work with logical AST nodes to find the particular text that
-resulted in those nodes, for example for automated refactoring or highlighting.
+Summary: %{summary}
+Requires: python3dist(six)
+%{?python_provide:%python_provide python3-asttokens}
+
+%description -n python3-asttokens %_description
+
%prep
-%autosetup -n asttokens-2.2.1
+%autosetup -p1 -n asttokens-%{version}
+
%build
%py3_build
+
%install
%py3_install
-install -d -m755 %{buildroot}/%{_pkgdocdir}
-if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
-if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
-if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
-if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
-pushd %{buildroot}
-if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
-fi
-if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
-fi
-if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
-fi
-if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
-fi
-touch doclist.lst
-if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
-fi
-popd
-mv %{buildroot}/filelist.lst .
-mv %{buildroot}/doclist.lst .
-
-%files -n python3-asttokens -f filelist.lst
-%dir %{python3_sitelib}/*
-
-%files help -f doclist.lst
-%{_docdir}/*
+
+%check
+pytest-3 tests/ -v --ignore=tests/testdata/
+
+%files -n python3-asttokens
+%license LICENSE
+%doc README.rst
+%{python3_sitelib}/*
+
%changelog
-* Fri May 19 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.1-1
-- Package Spec generated
+* Wed Mar 29 2023 li_zengyi <zengyi@isrc.iscas.ac.cn> - 2.2.1-1
+- Init asttokens 2.2.1 package