summaryrefslogtreecommitdiff
path: root/python-cachelib.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-cachelib.spec')
-rw-r--r--python-cachelib.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-cachelib.spec b/python-cachelib.spec
new file mode 100644
index 0000000..5cf5554
--- /dev/null
+++ b/python-cachelib.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cachelib
+Version: 0.9.0
+Release: 1
+Summary: A collection of cache libraries in the same API interface.
+License: BSD-3-Clause
+URL: https://github.com/pallets-eco/cachelib
+Source0: https://files.pythonhosted.org/packages/79/f2/1c76df4d295789bbc836eea50b813d64f86e640c29fe8f0a3686e9c4e3e9/cachelib-0.9.0.tar.gz
+BuildArch: noarch
+
+
+%description
+A collection of cache libraries in the same API interface. Extracted from werkzeug.
+
+%package -n python3-cachelib
+Summary: A collection of cache libraries in the same API interface.
+Provides: python-cachelib = %{version}-%{release}
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+%description -n python3-cachelib
+A collection of cache libraries in the same API interface. Extracted from werkzeug.
+
+%package help
+Summary: Development documents and examples for cachelib
+Provides: python3-cachelib-doc
+%description help
+Development documents and examples for cachelib
+
+%prep
+%autosetup -n cachelib-%{version}
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cachelib -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Nov 18 2022 liqiuyu <liqiuyu@kylinos.cn> - 0.9.0-1
+- Update package to version 0.9.0
+
+* Thu Jun 23 2022 SimpleUpdate Robot <tc@openeuler.org> - 0.7.0-1
+- Upgrade to version 0.7.0
+
+* Tue May 10 2022 wulei <wulei80@h-partners.com> - 0.1.1-2
+- License compliance rectification
+
+* Mon Aug 03 2020 Python_Bot <Python_Bot@openeuler.org>
+- Package Spec generated