summaryrefslogtreecommitdiff
path: root/python-hatch-vcs.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-hatch-vcs.spec')
-rw-r--r--python-hatch-vcs.spec55
1 files changed, 55 insertions, 0 deletions
diff --git a/python-hatch-vcs.spec b/python-hatch-vcs.spec
new file mode 100644
index 0000000..d283c7e
--- /dev/null
+++ b/python-hatch-vcs.spec
@@ -0,0 +1,55 @@
+Name: python-hatch-vcs
+Version: 0.4.0
+Release: 1
+Summary: Hatch plugin for versioning with your preferred VCS
+
+License: MIT
+URL: https://pypi.org/project/hatch-vcs
+Source0: https://files.pythonhosted.org/packages/f5/c9/54bb4fa27b4e4a014ef3bb17710cdf692b3aa2cbc7953da885f1bf7e06ea/hatch_vcs-0.4.0.tar.gz
+BuildArch: noarch
+
+BuildRequires: python3-devel python3-pip python3-hatchling
+BuildRequires: python3-setuptools_scm python3-pathspec python3-hatch-vcs
+BuildRequires: python3dist(pytest)
+BuildRequires: git-core
+
+
+%global common_description %{expand:
+This provides a plugin for Hatch that uses your preferred version control
+system (like Git) to determine project versions.}
+
+%description %{common_description}
+
+%package -n python3-hatch-vcs
+Summary: %{summary}
+
+%description -n python3-hatch-vcs %{common_description}
+
+%prep
+%autosetup -n hatch_vcs-%{version} -p1
+
+%build
+%pyproject_build
+
+%install
+%pyproject_install hatch_vcs
+
+%check
+%{__python3} -m pytest
+
+%files -n python3-hatch-vcs
+%license LICENSE.txt
+%doc README.md
+%{python3_sitelib}/hatch_vcs
+%{python3_sitelib}/hatch_vcs-%{version}*-info
+
+%changelog
+* Tue Mar 12 2024 Dongxing Wang <dongxing.wang_a@thundersoft.com> - 0.4.0-1
+- Update package to version 0.4.0
+ Officially support Python 3.12 and drop support for Python 3.7
+
+* Fri Sep 01 2023 wulei <wu_lei@hoperun.com> - 0.3.0-2
+- Fix setuptools_scm 7.1.0 test incompatible
+
+* Thu Apr 13 2023 caodongxia <caodongxia@h-partners.com> - 0.3.0-1
+- Package init