summaryrefslogtreecommitdiff
path: root/python-py3dns.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-03-29 06:50:30 +0000
committerCoprDistGit <infra@openeuler.org>2023-03-29 06:50:30 +0000
commit23f8c29d0b8817cd4843674f5bd3a53e1e474492 (patch)
treec03c7c93eeb1b969431f4b129c371a16085b1ea8 /python-py3dns.spec
parentef73d04cb05b9de5dc15619badc4070a954224ae (diff)
automatic import of python-py3dns
Diffstat (limited to 'python-py3dns.spec')
-rw-r--r--python-py3dns.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-py3dns.spec b/python-py3dns.spec
new file mode 100644
index 0000000..da6a4d0
--- /dev/null
+++ b/python-py3dns.spec
@@ -0,0 +1,73 @@
+%global _empty_manifest_terminate_build 0
+Name: python-py3dns
+Version: 3.2.1
+Release: 1
+Summary: Python 3 DNS library
+License: Python License
+URL: https://launchpad.net/py3dns
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8a/b7/bd0fca1b330527ccf5f47a586900797dd1e054909f7d4c5e287de8b3fe59/py3dns-3.2.1.tar.gz
+Patch0: python3-py3dns-handle-absent-resolv.patch
+BuildArch: noarch
+
+
+%description
+Python 3 DNS library:
+
+%package -n python3-py3dns
+Summary: Python 3 DNS library
+Provides: python-py3dns
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-py3dns
+Python 3 DNS library:
+
+%package help
+Summary: Development documents and examples for py3dns
+Provides: python3-py3dns-doc
+%description help
+Python 3 DNS library:
+
+%prep
+%autosetup -n py3dns-3.2.1 -p1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-py3dns -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.1-1
+- Package Spec generated