summaryrefslogtreecommitdiff
path: root/rpkg.spec
diff options
context:
space:
mode:
Diffstat (limited to 'rpkg.spec')
-rw-r--r--rpkg.spec143
1 files changed, 5 insertions, 138 deletions
diff --git a/rpkg.spec b/rpkg.spec
index de81265..3950b39 100644
--- a/rpkg.spec
+++ b/rpkg.spec
@@ -1,5 +1,5 @@
Name: rpkg
-Version: 1.66
+Version: 1.65
Release: 1
Summary: Python library for interacting with rpm+git
@@ -8,10 +8,6 @@ URL: https://pagure.io/rpkg
BuildArch: noarch
Source0: https://pagure.io/releases/rpkg/%{name}-%{version}.tar.gz
-# Disable python2 build by default
-%global with_python2 0
-# Enable python3 build by default
-%global with_python3 1
%global with_check 0
# This is intended for Python 3 only, hence also no Python version in the name.
@@ -35,105 +31,20 @@ Source0: https://pagure.io/releases/rpkg/%{name}-%{version}.tar.gz
Patch0: remove-koji-and-rpm-py-installer-from-requires.patch
Patch1: 0001-Do-not-use-pytest-related-dependencies-temporarily.patch
Patch2: 0002-Remove-pytest-coverage-execution.patch
-%if 0%{?with_python2}
-Patch3: 0003-Remove-Environment-Markers-syntax.patch
-%endif
-Patch4: 0004-Process-source-URLs-with-fragment-in-pre-push-hook.patch
-Patch5: 0005-container-build-update-signing-intent-help-for-OSBS-.patch
-Patch6: 0006-Do-not-generate-pre-push-hook-script-in-some-cases.patch
-Patch7: 0007-More-robust-spec-file-presence-checking.patch
-Patch8: 0008-Update-to-spec-file-presence-checking.patch
-Patch9: 0009-Add-more-information-about-pre-push-hook.patch
-Patch10: 0010-pre-push-check-have-to-use-spectool-with-define.patch
-Patch11: 0011-A-HEAD-query-into-a-lookaside-cache.patch
-Patch12: 0012-pre-push-hook-script-contains-a-user-s-config.patch
-Patch13: 0013-Fix-unittests-for-clone-and-pre-push-hook-script.patch
-Patch14: 0014-import_srpm-allow-pre-generated-srpms.patch
-Patch15: 0015-Ignore-missing-spec-file-in-pre-push-hook.patch
-Patch16: 0016-Check-remote-file-with-correct-hash.patch
-Patch17: 0017-Allow-empty-commits-when-uses_rpmautospec.patch
-Patch18: 0018-Config-file-option-to-skip-the-hook-script-creation.patch
-Patch19: 0019-Pre-push-hook-won-t-check-private-branches.patch
-Patch20: 0020-Use-release-s-rpmdefines-in-unused-sources-check.patch
-Patch21: 0021-Do-not-require-sources-file-for-all-namespaces.patch
+Patch4: 0004-fedpkg-local-does-not-show-rpmbuild-output.patch
+Patch5: 0005-Fixes-for-exploded-SRPM-layouts.patch
+Patch6: 0006-mockbuild-escape-rpm-command-under-mock.patch
%description
Python library for interacting with rpm+git
-
-%if 0%{?with_python2}
-%package -n python2-%{name}
-Summary: %{summary}
-%{?python_provide:%python_provide python2-%{name}}
-
-BuildRequires: python2-devel
-
-# We br these things for man page generation due to imports
-BuildRequires: rpmlint
-BuildRequires: rpmdevtools
-BuildRequires: python2-koji >= 1.21
-BuildRequires: python2-CCColUtils
-BuildRequires: PyYAML
-BuildRequires: GitPython
-BuildRequires: python-pycurl
-BuildRequires: python-requests
-BuildRequires: python-requests-kerberos
-BuildRequires: python-six >= 1.9.0
-BuildRequires: python2-argcomplete
-BuildRequires: python2-mock
-BuildRequires: python2-nose
-BuildRequires: python2-setuptools
-
-Requires: mock
-Requires: openEuler-rpm-config
-Requires: rpm-build
-Requires: rpmlint
-Requires: rpmdevtools
-Requires: python2-argcomplete
-Requires: python2-CCColUtils
-Requires: python2-koji >= 1.21
-Requires: PyYAML
-Requires: GitPython >= 0.2.0
-Requires: python-pycurl
-Requires: python-requests
-Requires: python-requests-kerberos
-Requires: python-six >= 1.9.0
-Requires: rpm-python
-
-Requires: %{name}-common = %{version}-%{release}
-
-
-# Backward compatibility with capability pyrpkg
-Provides: pyrpkg = %{version}-%{release}
-# All old versions before 1.49-1 should not be used anymore
-Obsoletes: pyrpkg < 1.49-2
-
-
-%description -n python2-%{name}
-A python library for managing RPM package sources in a git repository.
-%endif
-# end of python2 section
-
-
-%if 0%{?with_python3}
%package -n python3-%{name}
Summary: %{summary}
-%{?python_provide:%python_provide python3-%{name}}
-# Obsolete python2-rpkg (remove after Fedora29)
-%if 0%{?with_python2} == 0
-Obsoletes: python2-rpkg < %{version}-%{release}
-%endif
BuildRequires: python3-devel
BuildRequires: python3-GitPython
BuildRequires: python3-koji >= 1.24
-%if 0%{?rhel}
-BuildRequires: python3-gobject-base
-BuildRequires: libmodulemd
-BuildRequires: python3-requests-kerberos
-%else
BuildRequires: python3-libmodulemd
-%endif
BuildRequires: python3-argcomplete
BuildRequires: python3-CCColUtils
BuildRequires: python3-openidc-client
@@ -156,14 +67,8 @@ Requires: python3-argcomplete
Requires: python3-GitPython >= 0.2.0
Requires: python3-CCColUtils
Requires: python3-koji >= 1.24
-%if 0%{?rhel}
-Requires: python3-gobject-base
-Requires: libmodulemd
-Requires: python3-requests-kerberos
-%else
Requires: python3-libmodulemd
Requires: python3-rpmautospec
-%endif
Requires: python3-rpm
Requires: python3-pycurl
Requires: python3-six >= 1.9.0
@@ -174,9 +79,6 @@ Requires: %{name}-common = %{version}-%{release}
%description -n python3-%{name}
A python library for managing RPM package sources in a git repository.
-%endif
-# end of python3 section
-
%package common
Summary: Common files for %{name}
@@ -197,24 +99,11 @@ Common files for python2-%{name} and python3-%{name}.
sed -i -n '/extras_require/,/}/!p' setup.py
%build
-%if 0%{?with_python2}
-%{__python2} setup.py build
-%endif
-
-%if 0%{?with_python3}
%py3_build
-%endif
%install
-%if 0%{?with_python2}
-%{__python2} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
-%endif
-
-%if 0%{?with_python3}
%py3_install
-%endif
-
# Create configuration directory to holding downstream clients config files
# that are built on top of rpkg
@@ -235,41 +124,19 @@ example_cli_dir=$RPM_BUILD_ROOT%{_datadir}/%{name}/examples/cli
# need to run check as non-root
%check
%if 0%{?with_check}
-%if 0%{?with_python2}
-%{__python2} -m nose tests
-%endif
-
-%if 0%{?with_python3}
%pytest
%endif
-%endif
-%if 0%{?with_python2}
-%files -n python2-%{name}
-%doc README.rst CHANGELOG.rst
-%if 0%{?rhel} && 0%{?rhel} < 7
-%doc COPYING COPYING-koji LGPL
-%else
-%license COPYING COPYING-koji LGPL
-%endif
-# For noarch packages: sitelib
-%{python2_sitelib}/pyrpkg
-%{python2_sitelib}/%{name}-%{version}-py*.egg-info
-%endif
-
-%if 0%{?with_python3}
%files -n python3-%{name}
%doc README.rst CHANGELOG.rst
%license COPYING COPYING-koji LGPL
%{python3_sitelib}/pyrpkg
%{python3_sitelib}/%{name}-%{version}-py*.egg-info
-%endif
%files common
%{_datadir}/%{name}
%{_sysconfdir}/rpkg
-
%changelog
-* Fri Mar 24 2023 lichaoran <pkwarcraft@hotmail.com> - 1.66-1
+* Fri Mar 24 2023 lichaoran <pkwarcraft@hotmail.com> - 1.65-1
- Initial package