summaryrefslogtreecommitdiff
path: root/python-115wangpan.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-115wangpan.spec')
-rw-r--r--python-115wangpan.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-115wangpan.spec b/python-115wangpan.spec
new file mode 100644
index 0000000..dfc2ca3
--- /dev/null
+++ b/python-115wangpan.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-115wangpan
+Version: 0.7.6
+Release: 1
+Summary: Unofficial Python API wrapper for 115.com
+License: BSD
+URL: https://github.com/shichao-an/115wangpan
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4f/ee/831703aab8f38adf178eb7dd9d954bbc49b37f6e0268180ff39a9a729429/115wangpan-0.7.6.tar.gz
+BuildArch: noarch
+
+
+%description
+|Build| |PyPI version|
+115 Wangpan (115网盘 or 115云) is an unofficial Python API and SDK for 115.com. Supported Python verisons are 2.6, 2.7, 3.3, 3.4.
+* Documentation: http://115wangpan.readthedocs.org
+* GitHub: https://github.com/shichao-an/115wangpan
+* PyPI: https://pypi.python.org/pypi/115wangpan/
+
+%package -n python3-115wangpan
+Summary: Unofficial Python API wrapper for 115.com
+Provides: python-115wangpan
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-115wangpan
+|Build| |PyPI version|
+115 Wangpan (115网盘 or 115云) is an unofficial Python API and SDK for 115.com. Supported Python verisons are 2.6, 2.7, 3.3, 3.4.
+* Documentation: http://115wangpan.readthedocs.org
+* GitHub: https://github.com/shichao-an/115wangpan
+* PyPI: https://pypi.python.org/pypi/115wangpan/
+
+%package help
+Summary: Development documents and examples for 115wangpan
+Provides: python3-115wangpan-doc
+%description help
+|Build| |PyPI version|
+115 Wangpan (115网盘 or 115云) is an unofficial Python API and SDK for 115.com. Supported Python verisons are 2.6, 2.7, 3.3, 3.4.
+* Documentation: http://115wangpan.readthedocs.org
+* GitHub: https://github.com/shichao-an/115wangpan
+* PyPI: https://pypi.python.org/pypi/115wangpan/
+
+%prep
+%autosetup -n 115wangpan-0.7.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-115wangpan -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.6-1
+- Package Spec generated