summaryrefslogtreecommitdiff
path: root/python-1bead-org.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-1bead-org.spec')
-rw-r--r--python-1bead-org.spec92
1 files changed, 92 insertions, 0 deletions
diff --git a/python-1bead-org.spec b/python-1bead-org.spec
new file mode 100644
index 0000000..616f933
--- /dev/null
+++ b/python-1bead-org.spec
@@ -0,0 +1,92 @@
+%global _empty_manifest_terminate_build 0
+Name: python-1bead.org
+Version: 0.0.11
+Release: 1
+Summary: Web application for 1bead.org
+License: MIT
+URL: https://github.com/maxzheng/1bead.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/91/c8/b94eade6078053f2185ccd8e7cee4ec2b9bd24bfb9fd0a6295e076cc0ee8/1bead.org-0.0.11.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-aiohttp-jinja2
+Requires: python3-aiodns
+Requires: python3-cchardet
+Requires: python3-click
+
+%description
+# 1bead.org
+
+Web application for http://1bead.org
+
+
+
+
+%package -n python3-1bead.org
+Summary: Web application for 1bead.org
+Provides: python-1bead.org
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-1bead.org
+# 1bead.org
+
+Web application for http://1bead.org
+
+
+
+
+%package help
+Summary: Development documents and examples for 1bead.org
+Provides: python3-1bead.org-doc
+%description help
+# 1bead.org
+
+Web application for http://1bead.org
+
+
+
+
+%prep
+%autosetup -n 1bead.org-0.0.11
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-1bead.org -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.11-1
+- Package Spec generated