summaryrefslogtreecommitdiff
path: root/python-atarri.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-atarri.spec')
-rw-r--r--python-atarri.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-atarri.spec b/python-atarri.spec
new file mode 100644
index 0000000..d78b17c
--- /dev/null
+++ b/python-atarri.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ATARRI
+Version: 1.1
+Release: 1
+Summary: A TESS Archive RR Lyrae Classifier
+License: GPL-3.0
+URL: https://github.com/kennethcarrell/ATARRI
+Source0: https://mirrors.aliyun.com/pypi/web/packages/79/78/6973231bd4171be8fe44fb74f954b77e0c394dae9612c6e342ccc83047ae/ATARRI-1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-astropy
+Requires: python3-lightkurve
+Requires: python3-astroquery
+Requires: python3-matplotlib
+Requires: python3-scipy
+
+%description
+ATARRI (A TESS Archive RR Lyrae Classifier) is a GUI designed to visualize and do simple analysis of RR Lyrae stars using FFI data from TESS.
+
+For more information visit: https://github.com/kennethcarrell/ATARRI
+
+
+
+
+%package -n python3-ATARRI
+Summary: A TESS Archive RR Lyrae Classifier
+Provides: python-ATARRI
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ATARRI
+ATARRI (A TESS Archive RR Lyrae Classifier) is a GUI designed to visualize and do simple analysis of RR Lyrae stars using FFI data from TESS.
+
+For more information visit: https://github.com/kennethcarrell/ATARRI
+
+
+
+
+%package help
+Summary: Development documents and examples for ATARRI
+Provides: python3-ATARRI-doc
+%description help
+ATARRI (A TESS Archive RR Lyrae Classifier) is a GUI designed to visualize and do simple analysis of RR Lyrae stars using FFI data from TESS.
+
+For more information visit: https://github.com/kennethcarrell/ATARRI
+
+
+
+
+%prep
+%autosetup -n ATARRI-1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ATARRI -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1-1
+- Package Spec generated