summaryrefslogtreecommitdiff
path: root/python-bingwallpaper.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-bingwallpaper.spec')
-rw-r--r--python-bingwallpaper.spec226
1 files changed, 226 insertions, 0 deletions
diff --git a/python-bingwallpaper.spec b/python-bingwallpaper.spec
new file mode 100644
index 0000000..f3f39a5
--- /dev/null
+++ b/python-bingwallpaper.spec
@@ -0,0 +1,226 @@
+%global _empty_manifest_terminate_build 0
+Name: python-BingWallpaper
+Version: 1.2.2
+Release: 1
+Summary: A python script which can download bing's beautiful images and set the image to your computer wallpaper.
+License: MIT
+URL: https://github.com/LogicJake/some-scripts/tree/master/bing-wallpaper
+Source0: https://mirrors.aliyun.com/pypi/web/packages/ce/cc/dbaddaf17592b4762f3ecf56f18145525ed8d39c198c4fa1b169bb06ec2d/BingWallpaper-1.2.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+
+%description
+
+[![pip](https://img.shields.io/pypi/dm/BingWallpaper.svg)](https://pypi.python.org/pypi/BingWallpaper)
+## bing-wallpaper
+A python script which can download bing's beautiful images and set the image to your computer wallpaper. This script can also change wallpaper every once in a while. It is tested and works well on ubuntu.
+### Installation
+```bash
+pip install BingWallpaper
+```
+### HOW TO USE
+#### arguments
+There are three arguments you can set:
+```
+usage: wallpaper [-h] [--interval [INTERVAL]] [--num [NUM]] [--path [PATH]]
+ [stop]
+
+timely replacement wallpaper from bing.
+
+positional arguments:
+ stop stop wallpaper
+
+optional arguments:
+ -h, --help show this help message and exit
+ --interval [INTERVAL]
+ time interval for scripts to change wallpapers. By
+ seconds.
+ --num [NUM] number of images saved in local folder at most
+ --path [PATH] path to save images
+```
+* stop
+stop wallpaper
+* interval
+Time interval for scripts to change wallpapers. The unit of this argument is second and default value is **3 seconds**.
+* num
+Number of images saved in local folder at most. Script will only keep **num** latest bing's images, and the expired will be deleted. Script will choose one image as wallpaper randomly. Default value is **7**.
+* path
+Path to save wallpaper. If the current user does not have permission to write to or create the path, you may need administrator privileges. Default value is **'/home/user/wallpapers'**.
+
+#### example
+```bash
+wallpaper
+```
+This is the simplest command and three arguments are set to the default value. You can customize your commands like this:
+```bash
+wallpaper --interval 4 --num 5 --path /home/bing/test/
+```
+If you want to stop the script, you can run the following code.
+```bash
+wallpaper stop
+```
+
+
+
+
+%package -n python3-BingWallpaper
+Summary: A python script which can download bing's beautiful images and set the image to your computer wallpaper.
+Provides: python-BingWallpaper
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-BingWallpaper
+
+[![pip](https://img.shields.io/pypi/dm/BingWallpaper.svg)](https://pypi.python.org/pypi/BingWallpaper)
+## bing-wallpaper
+A python script which can download bing's beautiful images and set the image to your computer wallpaper. This script can also change wallpaper every once in a while. It is tested and works well on ubuntu.
+### Installation
+```bash
+pip install BingWallpaper
+```
+### HOW TO USE
+#### arguments
+There are three arguments you can set:
+```
+usage: wallpaper [-h] [--interval [INTERVAL]] [--num [NUM]] [--path [PATH]]
+ [stop]
+
+timely replacement wallpaper from bing.
+
+positional arguments:
+ stop stop wallpaper
+
+optional arguments:
+ -h, --help show this help message and exit
+ --interval [INTERVAL]
+ time interval for scripts to change wallpapers. By
+ seconds.
+ --num [NUM] number of images saved in local folder at most
+ --path [PATH] path to save images
+```
+* stop
+stop wallpaper
+* interval
+Time interval for scripts to change wallpapers. The unit of this argument is second and default value is **3 seconds**.
+* num
+Number of images saved in local folder at most. Script will only keep **num** latest bing's images, and the expired will be deleted. Script will choose one image as wallpaper randomly. Default value is **7**.
+* path
+Path to save wallpaper. If the current user does not have permission to write to or create the path, you may need administrator privileges. Default value is **'/home/user/wallpapers'**.
+
+#### example
+```bash
+wallpaper
+```
+This is the simplest command and three arguments are set to the default value. You can customize your commands like this:
+```bash
+wallpaper --interval 4 --num 5 --path /home/bing/test/
+```
+If you want to stop the script, you can run the following code.
+```bash
+wallpaper stop
+```
+
+
+
+
+%package help
+Summary: Development documents and examples for BingWallpaper
+Provides: python3-BingWallpaper-doc
+%description help
+
+[![pip](https://img.shields.io/pypi/dm/BingWallpaper.svg)](https://pypi.python.org/pypi/BingWallpaper)
+## bing-wallpaper
+A python script which can download bing's beautiful images and set the image to your computer wallpaper. This script can also change wallpaper every once in a while. It is tested and works well on ubuntu.
+### Installation
+```bash
+pip install BingWallpaper
+```
+### HOW TO USE
+#### arguments
+There are three arguments you can set:
+```
+usage: wallpaper [-h] [--interval [INTERVAL]] [--num [NUM]] [--path [PATH]]
+ [stop]
+
+timely replacement wallpaper from bing.
+
+positional arguments:
+ stop stop wallpaper
+
+optional arguments:
+ -h, --help show this help message and exit
+ --interval [INTERVAL]
+ time interval for scripts to change wallpapers. By
+ seconds.
+ --num [NUM] number of images saved in local folder at most
+ --path [PATH] path to save images
+```
+* stop
+stop wallpaper
+* interval
+Time interval for scripts to change wallpapers. The unit of this argument is second and default value is **3 seconds**.
+* num
+Number of images saved in local folder at most. Script will only keep **num** latest bing's images, and the expired will be deleted. Script will choose one image as wallpaper randomly. Default value is **7**.
+* path
+Path to save wallpaper. If the current user does not have permission to write to or create the path, you may need administrator privileges. Default value is **'/home/user/wallpapers'**.
+
+#### example
+```bash
+wallpaper
+```
+This is the simplest command and three arguments are set to the default value. You can customize your commands like this:
+```bash
+wallpaper --interval 4 --num 5 --path /home/bing/test/
+```
+If you want to stop the script, you can run the following code.
+```bash
+wallpaper stop
+```
+
+
+
+
+%prep
+%autosetup -n BingWallpaper-1.2.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-BingWallpaper -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.2-1
+- Package Spec generated