summaryrefslogtreecommitdiff
path: root/python-CommonMark.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-06 12:44:09 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-06 12:44:09 +0000
commit8e084d9fc8877e811930e951309d3aa98821355e (patch)
treed811d3ba64ee44e1f2df0bc3723bedf9a2437fff /python-CommonMark.spec
parent38757be37cf59f4c4a710a084c58a508025409ec (diff)
automatic import of python-CommonMark
Diffstat (limited to 'python-CommonMark.spec')
-rw-r--r--python-CommonMark.spec105
1 files changed, 105 insertions, 0 deletions
diff --git a/python-CommonMark.spec b/python-CommonMark.spec
new file mode 100644
index 0000000..9130f7c
--- /dev/null
+++ b/python-CommonMark.spec
@@ -0,0 +1,105 @@
+%global _empty_manifest_terminate_build 0
+Name: python-commonmark
+Version: 0.9.1
+Release: 1
+Summary: Python parser for the CommonMark Markdown spec
+License: BSD-3-Clause
+URL: https://github.com/rtfd/commonmark.py
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/60/48/a60f593447e8f0894ebb7f6e6c1f25dafc5e89c5879fdc9360ae93ff83f0/commonmark-0.9.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-future
+Requires: python3-flake8
+Requires: python3-hypothesis
+
+%description
+commonmark.py is a pure Python port of `jgm <https://github.com/jgm>`__'s
+`commonmark.js <https://github.com/jgm/commonmark.js>`__, a
+Markdown parser and renderer for the
+`CommonMark <http://commonmark.org>`__ specification, using only native
+modules. Once both this project and the CommonMark specification are
+stable we will release the first ``1.0`` version and attempt to keep up
+to date with changes in ``commonmark.js``.
+commonmark.py is tested against the CommonMark spec with Python versions
+2.7, 3.4, 3.5, 3.6, and 3.7.
+**Current version:** 0.9.1
+|Pypi Link| |Build Status| |Doc Link|
+
+%package -n python3-commonmark
+Summary: Python parser for the CommonMark Markdown spec
+Provides: python-commonmark
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-commonmark
+commonmark.py is a pure Python port of `jgm <https://github.com/jgm>`__'s
+`commonmark.js <https://github.com/jgm/commonmark.js>`__, a
+Markdown parser and renderer for the
+`CommonMark <http://commonmark.org>`__ specification, using only native
+modules. Once both this project and the CommonMark specification are
+stable we will release the first ``1.0`` version and attempt to keep up
+to date with changes in ``commonmark.js``.
+commonmark.py is tested against the CommonMark spec with Python versions
+2.7, 3.4, 3.5, 3.6, and 3.7.
+**Current version:** 0.9.1
+|Pypi Link| |Build Status| |Doc Link|
+
+%package help
+Summary: Development documents and examples for commonmark
+Provides: python3-commonmark-doc
+%description help
+commonmark.py is a pure Python port of `jgm <https://github.com/jgm>`__'s
+`commonmark.js <https://github.com/jgm/commonmark.js>`__, a
+Markdown parser and renderer for the
+`CommonMark <http://commonmark.org>`__ specification, using only native
+modules. Once both this project and the CommonMark specification are
+stable we will release the first ``1.0`` version and attempt to keep up
+to date with changes in ``commonmark.js``.
+commonmark.py is tested against the CommonMark spec with Python versions
+2.7, 3.4, 3.5, 3.6, and 3.7.
+**Current version:** 0.9.1
+|Pypi Link| |Build Status| |Doc Link|
+
+%prep
+%autosetup -n commonmark-0.9.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-commonmark -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Mar 06 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.1-1
+- Package Spec generated