summaryrefslogtreecommitdiff
path: root/python-haroun.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-haroun.spec')
-rw-r--r--python-haroun.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-haroun.spec b/python-haroun.spec
new file mode 100644
index 0000000..80985cd
--- /dev/null
+++ b/python-haroun.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Haroun
+Version: 0.1.5
+Release: 1
+Summary: My own PyTorch framework
+License: MIT
+URL: https://github.com/hraouak/haroun
+Source0: https://mirrors.aliyun.com/pypi/web/packages/75/dd/803ecfd7ad110e0bf8b8dc05536a866f2a9434d7913cbd143bdc3b8f6a00/Haroun-0.1.5.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-Haroun
+Summary: My own PyTorch framework
+Provides: python-Haroun
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Haroun
+
+
+%package help
+Summary: Development documents and examples for Haroun
+Provides: python3-Haroun-doc
+%description help
+
+
+%prep
+%autosetup -n Haroun-0.1.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Haroun -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.5-1
+- Package Spec generated