summaryrefslogtreecommitdiff
path: root/python-libradar.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-libradar.spec')
-rw-r--r--python-libradar.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-libradar.spec b/python-libradar.spec
new file mode 100644
index 0000000..3823fcd
--- /dev/null
+++ b/python-libradar.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-LibRadar
+Version: 2.1.0
+Release: 1
+Summary: A tool for Android library detection.
+License: Apache License, Version 2.0
+URL: https://github.com/pkumza/libradar
+Source0: https://mirrors.aliyun.com/pypi/web/packages/03/d3/48a6387faf8e4ac041439541c2e18e279c1c017b220939e3ec239b2b45b4/libradar-2.1.0.tar.gz
+BuildArch: noarch
+
+
+%description
+LibRadar is an automatic tool for third-party library (SDK) detection of Android apps.
+
+%package -n python3-LibRadar
+Summary: A tool for Android library detection.
+Provides: python-LibRadar
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-LibRadar
+LibRadar is an automatic tool for third-party library (SDK) detection of Android apps.
+
+%package help
+Summary: Development documents and examples for LibRadar
+Provides: python3-LibRadar-doc
+%description help
+LibRadar is an automatic tool for third-party library (SDK) detection of Android apps.
+
+%prep
+%autosetup -n libradar-2.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-LibRadar -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.0-1
+- Package Spec generated