summaryrefslogtreecommitdiff
path: root/python-mage2gen.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-mage2gen.spec')
-rw-r--r--python-mage2gen.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-mage2gen.spec b/python-mage2gen.spec
new file mode 100644
index 0000000..deaedb2
--- /dev/null
+++ b/python-mage2gen.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Mage2Gen
+Version: 2.3.3
+Release: 1
+Summary: Magento 2 module generator
+License: GPL3
+URL: https://github.com/krukas/Mage2Gen
+Source0: https://mirrors.aliyun.com/pypi/web/packages/63/36/903bae55b0e50438eea11cf9dfd24920d8333cea92ba9118571b07a3e2da/Mage2Gen-2.3.3.tar.gz
+BuildArch: noarch
+
+
+%description
+Mage2Gen is a python library for generating Magento 2 modules. It is
+build to be extendable with snippets for creating more complex Magento 2
+modules based on simple input.
+
+%package -n python3-Mage2Gen
+Summary: Magento 2 module generator
+Provides: python-Mage2Gen
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Mage2Gen
+Mage2Gen is a python library for generating Magento 2 modules. It is
+build to be extendable with snippets for creating more complex Magento 2
+modules based on simple input.
+
+%package help
+Summary: Development documents and examples for Mage2Gen
+Provides: python3-Mage2Gen-doc
+%description help
+Mage2Gen is a python library for generating Magento 2 modules. It is
+build to be extendable with snippets for creating more complex Magento 2
+modules based on simple input.
+
+%prep
+%autosetup -n Mage2Gen-2.3.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Mage2Gen -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 2.3.3-1
+- Package Spec generated