summaryrefslogtreecommitdiff
path: root/python-retro.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-retro.spec')
-rw-r--r--python-retro.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-retro.spec b/python-retro.spec
new file mode 100644
index 0000000..e0d96ed
--- /dev/null
+++ b/python-retro.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Retro
+Version: 2.9.0
+Release: 1
+Summary: Lightweight Declarative Web Toolkit
+License: Revised BSD License
+URL: http://www.github.com/sebastien/retro
+Source0: https://mirrors.aliyun.com/pypi/web/packages/f0/5d/d774e99f06320f06c150a8e5eb74e2690e6713ef5ad8405a4ab0b5db16ec/Retro-2.9.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Retro is a lightweight declarative web toolkit designed to make it easier to
+develop web services and Web applications in Python. Retro uses WSGI and
+provide a set of decorators that make it very easy to turn your existing code
+into a web application or to write new ones.
+
+
+%package -n python3-Retro
+Summary: Lightweight Declarative Web Toolkit
+Provides: python-Retro
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Retro
+Retro is a lightweight declarative web toolkit designed to make it easier to
+develop web services and Web applications in Python. Retro uses WSGI and
+provide a set of decorators that make it very easy to turn your existing code
+into a web application or to write new ones.
+
+
+%package help
+Summary: Development documents and examples for Retro
+Provides: python3-Retro-doc
+%description help
+Retro is a lightweight declarative web toolkit designed to make it easier to
+develop web services and Web applications in Python. Retro uses WSGI and
+provide a set of decorators that make it very easy to turn your existing code
+into a web application or to write new ones.
+
+
+%prep
+%autosetup -n Retro-2.9.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Retro -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 2.9.0-1
+- Package Spec generated