summaryrefslogtreecommitdiff
path: root/python-XStatic-Angular.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-XStatic-Angular.spec')
-rw-r--r--python-XStatic-Angular.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-XStatic-Angular.spec b/python-XStatic-Angular.spec
new file mode 100644
index 0000000..138228e
--- /dev/null
+++ b/python-XStatic-Angular.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-XStatic-Angular
+Version: 1.8.2.2
+Release: 1
+Summary: Angular 1.8.2 (XStatic packaging standard)
+License: MIT
+URL: http://angularjs.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/10/45/ef21b960ea44834912f1131d84d972210f7815c63938843c30e72be451e1/XStatic-Angular-1.8.2.2.tar.gz
+BuildArch: noarch
+
+
+%description
+Angular JavaScript library packaged for setuptools (easy_install) / pip.
+This package is intended to be used by **any** project that needs these files.
+It intentionally does **not** provide any extra code except some metadata
+**nor** has any extra requirements. You MAY use some minimal support code from
+the XStatic base package, if you like.
+You can find more info about the xstatic packaging way in the package `XStatic`.
+
+%package -n python3-XStatic-Angular
+Summary: Angular 1.8.2 (XStatic packaging standard)
+Provides: python-XStatic-Angular
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-XStatic-Angular
+Angular JavaScript library packaged for setuptools (easy_install) / pip.
+This package is intended to be used by **any** project that needs these files.
+It intentionally does **not** provide any extra code except some metadata
+**nor** has any extra requirements. You MAY use some minimal support code from
+the XStatic base package, if you like.
+You can find more info about the xstatic packaging way in the package `XStatic`.
+
+%package help
+Summary: Development documents and examples for XStatic-Angular
+Provides: python3-XStatic-Angular-doc
+%description help
+Angular JavaScript library packaged for setuptools (easy_install) / pip.
+This package is intended to be used by **any** project that needs these files.
+It intentionally does **not** provide any extra code except some metadata
+**nor** has any extra requirements. You MAY use some minimal support code from
+the XStatic base package, if you like.
+You can find more info about the xstatic packaging way in the package `XStatic`.
+
+%prep
+%autosetup -n XStatic-Angular-1.8.2.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-XStatic-Angular -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Mar 06 2023 Python_Bot <Python_Bot@openeuler.org> - 1.8.2.2-1
+- Package Spec generated