summaryrefslogtreecommitdiff
path: root/python-XStatic-mdi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-XStatic-mdi.spec')
-rw-r--r--python-XStatic-mdi.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-XStatic-mdi.spec b/python-XStatic-mdi.spec
new file mode 100644
index 0000000..5dd22d8
--- /dev/null
+++ b/python-XStatic-mdi.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-XStatic-mdi
+Version: 1.6.50.2
+Release: 1
+Summary: mdi 1.6.50 (XStatic packaging standard)
+License: SIL OFL 1.1
+URL: http://materialdesignicons.com
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1c/02/fb6e654eca3486fd74a80a51aada0e621225193957b0e5b97dc157c57c32/XStatic-mdi-1.6.50.2.tar.gz
+BuildArch: noarch
+
+
+%description
+mdi javascript library packaged for setuptools (easy_install) / pip.
+This package is intended to be used by **any** project that needs these files.
+It intentionally does **not** provide any extra code except some metadata
+**nor** has any extra requirements. You MAY use some minimal support code from
+the XStatic base package, if you like.
+You can find more info about the xstatic packaging way in the package
+`XStatic`.
+
+%package -n python3-XStatic-mdi
+Summary: mdi 1.6.50 (XStatic packaging standard)
+Provides: python-XStatic-mdi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-XStatic-mdi
+mdi javascript library packaged for setuptools (easy_install) / pip.
+This package is intended to be used by **any** project that needs these files.
+It intentionally does **not** provide any extra code except some metadata
+**nor** has any extra requirements. You MAY use some minimal support code from
+the XStatic base package, if you like.
+You can find more info about the xstatic packaging way in the package
+`XStatic`.
+
+%package help
+Summary: Development documents and examples for XStatic-mdi
+Provides: python3-XStatic-mdi-doc
+%description help
+mdi javascript library packaged for setuptools (easy_install) / pip.
+This package is intended to be used by **any** project that needs these files.
+It intentionally does **not** provide any extra code except some metadata
+**nor** has any extra requirements. You MAY use some minimal support code from
+the XStatic base package, if you like.
+You can find more info about the xstatic packaging way in the package
+`XStatic`.
+
+%prep
+%autosetup -n XStatic-mdi-1.6.50.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-XStatic-mdi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Mar 06 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.50.2-1
+- Package Spec generated